The specified module could not be found. (ERROR_MOD_NOT_FOUND)



    when I click on the lookups tab with SQL Server 2005 Legacy DTS I get the following error.


    The specified module could not be found. (ERROR_MOD_NOT_FOUND)

    Some modules the query builder depends on could not be found. The query builder designer will not be functional.




    What module is this and how do I get it?

    Wednesday, 23 April 2008 7:10 PM

All replies

  • I am having the same exact problem, have a call open with MS, when I hear back, I'll post the solution.
    Monday, 24 November 2008 9:45 PM
  • Did you check out


    and make sure the run-time and design-time support for DTS packages have been installed?


    Tuesday, 25 November 2008 2:41 AM
  • I am seeing this issue as well and no, the above link does not address the issue.

    I get the error when clicking the ellipsis to look at a specific lookup in a dts package.
    Tuesday, 25 November 2008 9:55 PM
  • Do This to resolve the issue:

    1) Install SQL 2K client
    2) SQL2K sp4
    3) Hotfix 2151

    4) SQL 2K5 client
    5) The SQL 2K DTS components for SQL 2K5


    • Proposed as answer by Ryan Dev Wednesday, 8 April 2009 3:28 PM
    Wednesday, 26 November 2008 4:39 PM
  • Hi,

    The last info is spot on.

    Here is complete steps I had to follow, to enable admin of DTS in SQL 2005 on x64/x86, when running on Windows 7 x64 test rig:
    1. Installed x64 SQL 2005 tools, with Integration Services for some required components.
    2. Service Packed it via Windows Update (run it twice to get followup Vista updates).
    3. Went to here:
        which seems to be the only latest versions from various MS pages that work correctly (Feature Pack for Microsoft SQL Server 2005 - December 2008 for reference):
      a) Installed x86 Microsoft SQL Server 2000 DTS Designer Components 
      b) Installed x64 Microsoft SQL Server 2005 Backward Compatibility Components
    4. Fired up tools, edited a DTS, all looked fine. Tried to 'Build Query' and got the dreaded ERROR_MOD_NOT_FOUND

    Now, at this point (with hindsight), could have jumped to step 7, but for the record I did this:

    5. Uninstalled all of that, thinking it was x64 that was limited enought to not give full DTS admin tools.
    6. Reinstalled it all again with purely x86, got exactly the same error. (Along with an error about DTS COM dll being installed as both x86 and x64)

    7. Carried on and installed SQL 2K client (x86 I think).
    8. Service packed it to 4.
    9. Looked for Hotfix, but couldn't acquire it, and it was related to an Index issue I won't walk into, so didn't bother.
    10. Retried the same 'Build Query' and it worked.
    11. Got down on the floor and prayed to the mighty Schmed.

    Hope that pain helps someone else, or even me in a year. *Waves to self in future*
    Wednesday, 8 April 2009 3:27 PM