none
Compatabilty with ubuntu 18.04LTS

    Question

  • i am building a new Linux cluster based on Ubuntu and want to make sure I use the LTS release.

    18.04LTS has been recently released so I  have built a few nodes on this version.

    I am able to install the node agent and it appears in HPC manager but reports an error "HPC Node Manager Service is unreachable"

    looking at the logs on the Linux server I see repeated every minute;
    ERROR:HPC node manager process crashes: 127
    Restart HPC node manager process after 60 seconds

    is there some version compatibilities to be aware of?

    Tuesday, 1 May 2018 4:14 AM

All replies

  • Hey Peter, Ubuntu 1804 hasn't been validated at our testing side. We could do a validation and see what's going wrong.

    Qiufang Shi

    Tuesday, 1 May 2018 4:07 PM
  • Hi Peter, currently we don't have UBuntu 1804LTS available for testing, we will update this thread once we got this version for testing

    Qiufang Shi

    Thursday, 3 May 2018 7:53 PM
  • Hi there,

    1804LTS is available from the ubuntu download page https://www.ubuntu.com/download/server 

    thanks

    pete

    Thursday, 3 May 2018 8:30 PM
  • Hi Peter,

    I deployed a cluster in Azure, and upgraded one Linux node from Ubuntu 16.04 LTS to Ubuntu 18.04 LTS. The Cluster works well.

    Could you provide the logs under /opt/hpcnodemanager/logs on the Linux node for investigation? Mail hpcdisc@microsoft.com if you do not have a place to share the logs. 

    Chenling




    Tuesday, 8 May 2018 10:30 AM
  • What was the solution to this?  I have the exact same situation.
    Monday, 26 November 2018 11:32 PM
  • Ubuntu1804 will be supported in the upcoming QFE of HPC Pack2016 Update 2.

    Qiufang Shi

    Wednesday, 28 November 2018 9:24 AM