none
IaaS Bursting - Provisioning tasks in template - issue

    Question

  • HN is on premise. Trying to burst into Azure for an SOA service (I am on 2016 Update 1 with recent fixes installed):

    1) Have a deployment task ("Run OS Command") set on the template, but it is not working. Its as follows:

    echo n.n.n.n HNODE >> %WINDIR%\system32\drivers\etc\hosts

    My understanding is that with this command, when I create a node with the template, the above line should be in hosts file and the IaaS node should be able to resolve HN. It's not giving any error either (even when I set continue on error to false)

    2) I also have a mount shared folder deployment task set. The shared folder I am trying to mount is from on-premise. this is not working either.

    3) Is there a way to install 'custom' software during one of these 'provisioning' steps? If so. how? the only other option seems to be to create custom image myself and perform all customization on it and set it through "CustomWindowsImage" option while creating the template - correct?


    • Edited by SRIRAM R Sunday, 23 September 2018 6:45 PM
    Friday, 21 September 2018 5:21 PM

Answers

  • The deployment tasks are designed for on premises bare metal deployment. 

    For burst to Azure IaaS nodes scenario, the deployment steps are very different, currently, for Linux node or Non-domain joined windows node, no deployment task support.

    For domain joined windows nodes, only support to add tasks in "Maintenance" step.

    You need to configure the DNS of your virtual network to make the compute node can resolve the IP address of head node.

    • Marked as answer by SRIRAM R Wednesday, 10 October 2018 11:16 AM
    Wednesday, 10 October 2018 4:50 AM