locked
Workflow UpdateStep Issue RRS feed

  • General discussion

  • I have a workflow on Opportunity Create. In this workflow i am updating the same opportunity. 

    I am getting error on the Update step and here are the error details:

    Plugin Trace:

    [Microsoft.Xrm.Sdk.Workflow: Microsoft.Xrm.Sdk.Workflow.Activities.UpdateEntity]
    [UpdateStep11]



    Error Message:

    Unhandled Exception: Microsoft.Crm.CrmException: User does not have the privilege to act on behalf another user.
       at Microsoft.Crm.BusinessEntities.SecurityLibrary.VerifyUser(Guid user, ExecutionContext context)
       at Microsoft.Crm.BusinessEntities.ExecutionContext.SetCaller(Guid callerId, Boolean setCallerLanguage, Boolean verifyUser)
       at Microsoft.Crm.BusinessEntities.ExecutionContext.OnBeginRequest(Guid userId, Boolean startTransaction, IsolationLevel isolationLevel, ExecutionOperationContext operationContext, CallerOriginToken originToken)
       at Microsoft.Crm.Workflow.WorkflowTransactionContext.OnBeginRequest()
       at Microsoft.Crm.Workflow.Services.ActivityServiceBase.ExecuteInTransactedContext(ActivityDelegate activityDelegate)
       at Microsoft.Crm.Workflow.Services.UpdateActivityService.UpdateInternal(Entity entity, String stepId)
       at Microsoft.Crm.Workflow.Services.UpdateActivityService.ExecuteInternal(ActivityContext executionContext, UpdateEntity updateEntity)
       at Microsoft.Crm.Workflow.Services.UpdateActivityService.Execute(ActivityContext executionContext, UpdateEntity updateEntity)
       at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager)
       at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)



    Monday, August 4, 2014 9:11 AM

All replies

  • Hi,

    Did you check the "Act on Behalf of Another User" privilege of the user's security role ?


    Thanks and Regards. Make sure to "Vote as Helpful" and "Mark As Answer",if you get answer of your question.

    Monday, August 4, 2014 11:37 AM
  • I tried with system administrator and it still fails
    Monday, August 4, 2014 11:42 AM
  • I have the same problem,I tried many solution found in google but still not working 
    Wednesday, August 27, 2014 2:55 PM