locked
Visual studio refuses to connect to crm through crm explorer RRS feed

  • Question

  • Normally while I develop in crm I use the CRM explorer tool in visual studio but for the last few days it's decided that it's not possible to connect to a crm server.

    If I select Tools | Connect to crm server I get the error message "An unsecured or incorrectly secured fault was received from the other party. See the inner FaultException for the fault code and detail". When I accept that and try to enter the server details then at the logon part of the dialogue I get the error message "An error occurred while verifying security for the message". If I connect directly through a browser to crm there is no problem.

    Studio doesn't seem to show me an innerexceptions at this point so where, if anywhere, would I find more information or alternatively what is likely to be the issue with CRM this time (or do I just give up and tell our users to upgrade to using an abacus? :X )

    Sunday, July 28, 2013 2:07 PM

All replies

  • Generally that error points to a date/time mismatch between the CRM server and your client system from which you are trying to connect to CRM.

    Did you by any chance change any CRM configuration like make it IFD? Make sure you have used correct ssl certificates.

    HTH

    Sam


    Dynamics CRM MVP | Inogic | http://inogic.blogspot.com| news at inogic dot com

    If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    • Proposed as answer by Sam - Inogic Monday, July 29, 2013 3:24 AM
    Monday, July 29, 2013 3:24 AM