locked
Windows Home Server installation error "Could not initialize UI subsystem" RRS feed

  • Question

  • Windows Home Server goes to the  "Set up is Initializing..." progress bar.
    The first progress bar completes.  During the second progress bar I get the error "Could not initialize UI subsystem".
    When I clear the error message window, the system reboots.
    Monday, July 20, 2009 6:04 PM

All replies

  • Try replacing your DVD drive.
    I'm not on the WHS team, I just post a lot. :)
    Monday, July 20, 2009 7:17 PM
    Moderator
  • Couple of the obvious things to check... is the installation DVD still in the dvd drive - if not, put it back and have you checked that all the cables connecting the drives are connected correctly?

    Sorry if you have checked those already!

    Andrew
    MVP - Windows Home Server
    Monday, July 20, 2009 7:18 PM
    Moderator
  • You can try another port to connect the DVD drive. If it is connected to an SATA port, try one of the first 4 ports on the board.
    Also the system should have at least 512 MB memory dedicated to the OS. Some onboard adapters take RAM from the physical memory - try to reduce this amoung or add more RAM.
    Could also be, that the video adapter has issues (not enough video memory as the contradictionary problem). If you have a separate video card at your hands, you can try to borrow this for your WHS.
    Best greetings from Germany
    Olaf

    Monday, July 20, 2009 7:55 PM
    Moderator
  • Also, check to make sure your DVD drive is not connected to the slave port on the second IDE port without a master device on it. Leave the DVD in the drive for the whole install. When WHS is at the desktop, then remove the DVD.

    Cruise
    Wednesday, July 22, 2009 2:45 PM
  • The solution that I used to get past all problems was to use a usb drive to install Windows Home Server. Since my computer doesn't allow booting from USB I had to create a Windows PE CD (without any customizing), which then allowed me to use the USB drive to install it and get completely around the UI errors that I was seeing. To do this method:

    • Download Windows Automated Installation Kit (AIK) from MicroSoft (this is free).
    • Install the kit (you may have to burn this to a CD or use a mounting software
    • Start up the command prompt.
    • Type in the following:
      1. cd Program Files\Windows AIK\Tools\PETools\
      2. copype.cmd x86 c:\winpe_x86
      3. oscdimg -n –bc:\winpe_x86\etfsboot.com c:\winpe_x86\ISO c:\winpe_x86\winpe_x86.iso
    • Burn the ISO to a CD
    • Put the CD into the machine that you are setting up and plug in your USB drive.
    • Start the machine.
    • Once the command prompt shows you can now access your USB drive (if you only have 1 HD, then it should be drive E)
    • Change directory to Files
    • Change directory to Install
    • Run the install.com
    • Run the qs.exe

    Hope this helps to solve the problem.

    • Proposed as answer by WildDragon Saturday, October 3, 2009 1:21 AM
    Saturday, October 3, 2009 1:21 AM
  • Lots of people having this problem and lots of posts on the Internet about this.  Just my two cents.  Was installing Windows Home Server (Genuine Microsoft DVD) on a ABIT IB9 Mobo, 1TB SATA Seagate, 512MB memory.  Kept getting  Could Not Initialize UI Subsystem.  Tried updating the BIOS, and several other things.  The DVD-ROM was IDE and plugged into the IDE1 connector.  I swapped to a SATA DVD-ROM and presto, worked like a charm.  Hope that helps someone.
    Thursday, October 14, 2010 3:32 PM