locked
Dashboard takes precedence over remote login! RRS feed

  • Question

  • I can log into my server through the xxx.homeserver.com login site, using my personal user ID and password.  However, when I try to remotely log in to the server from that site, I cannot get the server administrator desktop display.  Instead, the Dashboard insists on starting up.  I never get the option to provide the administrator ID and password to get to the desktop.  I have done this before, however, so I don't know what went wrong.  I'll of course appreciate any insight anyone can provide.  Are others also having this problem? 

          actor39

    Tuesday, June 21, 2011 3:08 AM

All replies

  • The only way you can remote into the server is by direct RDP - either by using the server name/IP internally on your network, or by setting up an RDP forwarding port on your router to the server if you want to do this externally.

     


    This post is "AS IS" and confers no rights.
    Michael Leworthy [MSFT]
    Senior Technical Product Manager
    Windows Server - SMB
    Microsoft Corporation
    Tuesday, June 21, 2011 4:17 AM
  • If you install an Addin like Awieco Remote Launcher or WHS Advanced Admin you can start mstsc.exe that you can use to connect an RDP session to the desktop on top of the connection to the dashboard. No need to open up your router, the traffic is handled by the Remote Desktop Gateway of you WHS so you need no additional configuration.

    Cheers,

    Danee


    Media Center Plug-ins: http://www.mcesoft.nl
    Tuesday, June 21, 2011 11:38 AM
  • On Tue, 21 Jun 2011 11:38:55 +0000, Danee wrote:

    If you install an Addin like Awieco Remote Launcher or WHS Advanced Admin you can start mstsc.exe that you can use to connect an RDP session to the desktop on top of the connection to the dashboard. No need to open up your router, the traffic is handled by the Remote Desktop Gateway of you WHS so you need no additional configuration.

    There's no need to install any add-in at all, just install the Remote
    Desktop Services role with the Remote Desktop Gateway role service.


    Paul Adare
    MVP - Identity Lifecycle Manager
    http://www.identit.ca
    Vacuum type: A derogatory term.  See "bubble memory."

    Tuesday, June 21, 2011 12:04 PM
  • Of course this would be unsupported, but it is just a simple registry change to RDP to the server instead of launching the dashboard.

    HKLM\SOFTWARE\Microsoft\Windows Server\RDP

    Create a new DWORD called EnableServerRemoteDesktop and set it to 1

    -timotl

    Tuesday, June 21, 2011 1:21 PM
  • Well, timotl, I changed the registry as you suggested, and now I can't get ANY web access to the homeserver website.  So I will have to make another trip back to the server site and change the registry back to its original state.  Maybe I should look into the addins.

     


    actor39
    Thursday, June 23, 2011 2:35 AM
  • Well, I have to apologize to timotl.  It seems that the internet service to the site where the server is located has been down for at least 15 hours.  Once that service was restored, I was able to logon to the server, an then easily bring up the desktop of the server.  Bravo, timotl!!!  I'm voting your suggestion as "helpful"!
    actor39
    Thursday, June 23, 2011 5:38 PM
  • Just a note to remark that whenever I change the web login interface page, to use a custom background, for example, WHS changes the value of EnableServerRemoteDesktop back to zero.  So if you do this while connected via the desktop, remember before you leave the desktop to re-enter the value 1 for this Dword in the registry.  Then all will be fine.

    actor39
    Tuesday, July 5, 2011 2:27 PM