locked
CRM 2013 Sub Grid Ribbon RRS feed

  • Question

  • Hi,

    We recently moved one of our solutions from CRM 2011 to CRM 2013 and I am having a few problems with ribbons.

    We have a custom entity (INCIDENT) which has a sub grid view on the form displaying all KB articles (no relationship)

    In the past we clicked on a record in the view and a new tab will appear showing our custom button.

    I know CRM 2013 is now using the command bar and there are no tabs.

    How do I get around solving this issue??

    Wednesday, December 4, 2013 10:15 PM

All replies

  • Check this post  http://jlattimer.blogspot.com/2013/10/context-sensitive-sub-grid-commands-in.html

    If my response helps you in finding your answer then please click 'Mark as Answer' and 'Vote as Helpful'

    Wednesday, December 4, 2013 10:56 PM
  • Hi. I had read the article before making this post.

    The problem with that article is that I have to create a relationship with another entity which I do not want to do.

    I want to display all articles in the view (not associated)

    Wednesday, December 4, 2013 11:46 PM
  • Hi,

    Many times it happens while migrating some of inconsistency gets established.

    Assuming your application was working as expected in CRM 2011, I will say that you

    1. remove the subgrid view,
    2. publish all the customizations,
    3. Re-add the subgrid view
    4. publish the customizations.

    Make sure you take care of any dependencies of that subgrid. Take a note of the name of the subgrid and other settings for the subgrid so that you give the same name and settings to the new one.

    I hope this helps.

    Thanks & Regards,


    Anubhav Bajpai

    Thursday, December 5, 2013 6:16 AM
  • Thanks for your response Anubhav.

    This will not help resolve the issue as the problem is with how the ribbons are displayed on views.

    Thursday, December 5, 2013 9:22 AM