locked
Remote connection not working RRS feed

  • Question

  • Hi All

    I can't get remote access to computers working.

    Port forwarding is set up correctly (I think), I have allowed remote access on the machine I want to access, I remote desktop in to the machine on the LAN, but my homeserver.com website always shows the machine as Not Available for remote connection.

    If I open https://myhomeserver/Remote on the LAN, I get the same thing, all the computers show as Not Available for connection.

    Any help appreciated.

    ETA: When I connect to https://myhomeserver/Remote, I get a security error warning. Might that be part of the problem?

    ETA2: I've just managed to connect directly to my desktop using other RDP software and updating the ports on the router, so it's definitely something to do with my WHS. Any ideas appreciated. I forgot to mention I always get the warning that port forwarding check has failed.

    Sunday, September 19, 2010 1:40 PM

All replies

  • I fixed this, more by good luck than judgement.

    As my router, a D-Link DSL-2740B, doesn't supoprt PnP properly, I set up the port forwarding manually.
    As on my previous Netgear router, I forwarded 80, 443, 3389 and 4125 to my WHS. However, nothing would work. Eventually I gave up, and used DynDNS to set up a direct connection to my desktop, so changed the forwarding of 3389 to my desktop instead of my WHS.

    For some reason, this has fixed the problem. It appears forwarding 3389 to the WHS causes some issue. So I now only have 80, 443 and 4125 forwarded to my WHS. I still have 3389 forwarded to my desktop, but will remove that, as well as the DynDNS stuff, this evening and test again.

    Monday, September 20, 2010 7:45 AM
  • Do you have more than one computer with RDP enabled?

    By default computers have port 3389 used for RDP.  So you would need to change this default port in the registry if you are going to access more than 1 computer over the internet.  I use DynDNS for my setup but I leave it at 3389 because I'm only connecting to my server remotely.

    Monday, September 20, 2010 4:41 PM
  • No, I only have one. At first port 3389 was forwarded to my WHS, but when I forwarded it to my desktop, the WHS log in started working.
    Wednesday, September 22, 2010 8:00 AM