locked
SSRS Report Filtering CRM 2013 on-premise RRS feed

  • Question

  • Running into a problem in CRM 2013, SQL 2012 while trying to use FROM FilteredEntity AS CRMAF_FilteredEntity (replaced the word Entity for the actual custom entity name). When uploading the RDL file it does not appear to do its magic converting it allowing filtering on the current record. No way load it under the Run on Current Record. The same report worked in earlier versions of CRM. Another odd thing is when I upload the RDL file I may not get the same results each time, never places it under Run on Current Record, but runs on all the records one time and the next upload of the same RDL file it just errors out when I run the report. Just curious if anyone else is running into the same problem with CRM 2013 on-premise or has a solution. I have tried a bunch of the things that were suggested for CRM 2011 but nothing seems to get me over the hump in the road for this problem I am having.




    Wednesday, May 7, 2014 11:45 AM

All replies

  • Hello mdm4ai;

    Well I can certainly help with the report not showing under the entity it should be running against. The issue here is that in the properties of the report itself (select report and press edit) it has to have the entity you wish it run under selected on the "Related Records Types" field. If it worked in the past you entity would have been here by uploading a newer version I've seen this be cleared before. The next step is in the "Display In" field it has to have at least the "Forms for related record types" selected in this field.

    Please take a look and let me know if you can get that issue resolved to start. Once you get that resolved it might resolve some issues your having around the pre filtering. I'll do a bit of research around the guide lines on the pre filtering and maybe come up with a reason as to why it's not working.

    Good luck!


    Jason Cosman

    Thursday, May 15, 2014 2:29 PM