locked
Outlook Client "This folder Cannot be opened until Microsoft Dynamics CRM for Outlook is enabled" error RRS feed

  • Question

  • My company recently bought Dynamics CRM 4.0  due to its Outlook integration.  I have it set up and 100% accessible from the internet and intranet.  I ran the IFD tool and have all of that configured to perfection.  I also installed rollup 12.  Yesterday we were asked to start deploying the client to marketers and we could not get the client configured and working on a single laptop.  After much research it was because none of our laptops are domain machines nor do we have the infrastructure in place to support that.  I then read I could use the "Online Provider" option for external non-domain employees.  So I ran the configuration wizard and it seemed to go through perfectly.  No errors in the logs or anything.  But when I open up Outlook and click in the Microsoft Dynamics CRM folder it gives me the error "This folder Cannot be opened until Microsoft Dynamics CRM for Outlook is enabled".  If I run the client diagnostics it gives me these notable results:

    Warning:  You recently used a different Outlook profile than the one the Microsoft Dynamics CRM add-in has been configured for. The Microsoft Dynamics CRM add-in will be enabled only for the profile it was configured for

    Error:  Cached metadata information appears to be corrupted and was deleted. Please restart Outlook

    This is a brand new Outlook install and I configured it completely before installing.  There is only the one profile and it was created before I ran the client.  

    Any help would be greatly appreciated.  We bought Dynamics specifically for its Outlook integration and it seems kind of strange that it seems to throw road blocks at every turn.

     

     

     

     

    Wednesday, September 15, 2010 2:11 PM

Answers

  • Ok it seems 3 of the clients don't work but the other 10+ work when configured for Online Provider.  I will track down the issue with the problem laptops.  I am sorry to waste your time on a problem that was clearly mine.  I figured three computers with the same problem would be a systemic issue but I guess there's something in common keeping them from working properly.  Thank you everyone who tried to help :) 
    Wednesday, September 15, 2010 6:06 PM
  • No problem, I'm glad you were willing to work through the troubleshooting steps and try on additional machines.  Your assumption was reasonable (not working on 3 thus not working).

    Another thing you can check on the computer is the log file for the install.  Look through it for the word error, the last error will be towards the bottom.  You might be able to glean some information from it.  Check this KB for the log file location.  The only difference is the final folder will be Logs rather than Trace.


    Regards, Donna

    Wednesday, September 15, 2010 6:58 PM

All replies

  • Can you go to the CRM Menu and select Options from the Outlook client.  Ensure the checkbox Set this Computer to be the Synchronizing Client is selected on the Synchronizing tab.  

    Regards, Donna

    Wednesday, September 15, 2010 2:46 PM
  • Oddly I don't get a CRM menu in Outlook.  Only the folder in the tree.  I see no reference to it, nothing on the ribbon,  and nothing in the system tray.  I have uninstalled and reinstalled both office and the client and still nothing.  I see it has an entry in the Trust Center under Add-Ins and it says it is enabled.  Strange.
    Wednesday, September 15, 2010 3:09 PM
  • Ok, let's back up a little.  When you ran the configuration wizard, I assume you selected Online and used the IFD url, the same one used on the machine to connect to CRM when it is not connected to the domain.  Please ensure you are using the correct URL.  You can test this by first accessing CRM through the Web browser & then use the same URL in the Outlook client.  Please be sure the machine is not connected to the network when you do the test.

    Please see this post by Customer Effective for more information.


    Regards, Donna

    Wednesday, September 15, 2010 4:30 PM
  • Ok, let's back up a little.  When you ran the configuration wizard, I assume you selected Online and used the IFD url, the same one used on the machine to connect to CRM when it is not connected to the domain.  Please ensure you are using the correct URL.  You can test this by first accessing CRM through the Web browser & then use the same URL in the Outlook client.  Please be sure the machine is not connected to the network when you do the test.

    Please see this post by Customer Effective for more information.


    Regards, Donna

    Yes, that is correct.  I used the IFD URL and it prompted for my username and password and I entered both and the configuration wizard finished.  This was done from the users home with no VPN or anything connecting them back to the company intranet.  This seems like a strange problem.  I am going to try more than the few I have tried to make sure I am not just having bad luck.
    Wednesday, September 15, 2010 5:02 PM
  • Ok it seems 3 of the clients don't work but the other 10+ work when configured for Online Provider.  I will track down the issue with the problem laptops.  I am sorry to waste your time on a problem that was clearly mine.  I figured three computers with the same problem would be a systemic issue but I guess there's something in common keeping them from working properly.  Thank you everyone who tried to help :) 
    Wednesday, September 15, 2010 6:06 PM
  • No problem, I'm glad you were willing to work through the troubleshooting steps and try on additional machines.  Your assumption was reasonable (not working on 3 thus not working).

    Another thing you can check on the computer is the log file for the install.  Look through it for the word error, the last error will be towards the bottom.  You might be able to glean some information from it.  Check this KB for the log file location.  The only difference is the final folder will be Logs rather than Trace.


    Regards, Donna

    Wednesday, September 15, 2010 6:58 PM