locked
Move CRM 4.0 DB to New Domain and Import RRS feed

  • Question

  • Hi,

    I'm having some problems imporiting a CRM 4.0 db into a new domain.  I have a new machine with a clean install of CRM 4.0. I have also restored the MSCRM db into SQL.

    Users from the previous domain exist in AD in a the new Domain. Although I do need to map some of them.  When I click next I get an error saying "At least the setup user needs to be mapped before this organization can be imported"  I'm logged on as the administorator which is the logon that was used to install previously.

    Any assistance welcomed.

    Thanks,
    Adam

    Thursday, March 18, 2010 10:43 AM

Answers

  • Last time I had this problem, I went to the systemuser table in MSCRM_CONFIG database and updated the column setupuser to 'true' for my user account.

    It worked.

    But it is not supported

    My blog : http://mscrmtools.blogspot.com
    You will find:
    Bulk Delete Launcher(Delete data based on advanced find queries)
    Form Javascript Manager (export/import javascript from forms)
    ISV.Config Manager (graphical ISV.config edition - export/import)
    View Layout replicator (customize one view and replicate to others)
    And others (use tool tag on my blog)
    • Marked as answer by Jim Glass Jr Tuesday, March 30, 2010 4:28 PM
    Thursday, March 18, 2010 3:52 PM
    Moderator

All replies

  • Hi,
    So are all previous CRM users mapped?
    Rob
    www.crmconsult.info www.chorusit.com Twitter:robertpeledie
    Thursday, March 18, 2010 10:58 AM
  • to move your organization from domain to anothere one is not easy but it will do in this steps:
    1- backup your organization database that will start with mscrm_(organization name)
    2- restor the database in the new database server
    3- from deployment manger import organization
    4- you must write the organization name with the same name and upercase
    5- when you reached maping user specified the administrator user and map it with your administrator user and aothere users
    by defualt it will map the users with the same names
    i hope it is help you this steps
    Thanks for any help :) my blog is: http://www.waelk.com
    • Edited by wael_e Thursday, March 18, 2010 11:39 AM forget words
    Thursday, March 18, 2010 11:38 AM
  • Hi Adam,

    with wich account you start the deploymend manager? Try to use the user, who has installed the crm server, then it should works.
    Viele Grüße

    Michael Sulz
    MVP für Microsoft Dynamics CRM
    Thursday, March 18, 2010 3:34 PM
  • Last time I had this problem, I went to the systemuser table in MSCRM_CONFIG database and updated the column setupuser to 'true' for my user account.

    It worked.

    But it is not supported

    My blog : http://mscrmtools.blogspot.com
    You will find:
    Bulk Delete Launcher(Delete data based on advanced find queries)
    Form Javascript Manager (export/import javascript from forms)
    ISV.Config Manager (graphical ISV.config edition - export/import)
    View Layout replicator (customize one view and replicate to others)
    And others (use tool tag on my blog)
    • Marked as answer by Jim Glass Jr Tuesday, March 30, 2010 4:28 PM
    Thursday, March 18, 2010 3:52 PM
    Moderator
  • Thanks everyone for their replies.

    wael_e Users MedalsUsers MedalsUsers MedalsUsers MedalsUsers MedalsI have already completed the steps you have outlined.  The error occurs when I click next from the map users form.


    Michael Sulz<abbr class="affil">MVP</abbr>Users MedalsUsers MedalsUsers MedalsUsers MedalsUsers Medals I'm running Deployment Manager loged in as Adminsitrator. This is the login which was used in both domains to install CRM. Users MedalsUsers MedalsUsers MedalsUsers Medals

    Tanguy T     systemuser table in MSCRM_CONFIG  doesn't have a SetUpUser column. The columns  it has are DefaultOrganizationID, ID, Name, and IsDeleted
    Thursday, March 18, 2010 8:01 PM
  • I have sorted the problem


    I have opened the SystemUsers table in Orginsation_MSCRM and edited the DomainName column to match our domain.


    Thanks everyone for your replies.

    Thursday, March 18, 2010 8:09 PM
  • I had the exactly same problem today. I used the approach that Tanguy has suggested and it worked, but i want to point that the change should be made against the <CrmOrganization>_MSCRM database, not the MSCRM_CONFIG one. 

    I previously had similar problem as well, I was able to continue the import process by re-mapping the installation user to a different domain user. Not sure why it didn't let me do that this time. I could not afford time to investigate so I took the easy (though a little scary) path. 

    It was definitely not a pleasant moment for me to make this kind of change to CRM database, but it worked. Thanks Tanguy!


    Daniel Cai | http://danielcai.blogspot.com
    Thursday, March 10, 2011 10:16 PM
  • In case others encounter this problem, especially when migrating to a new domain, here is how I was able to do it:

    1) I ran the following query against the CRM database (not the config database):

    Update SystemUserBase Set Accessmode='0', Setupuser='0', IsDisabled='0'

    2) I opened the SystemUserBase table, found the row of the Administrator account I would use to map against the new Administrator account. I changed Setupuser to 'True'. I changed the DomainName field to the new account as DOMAIN\AcctName. I changed everything in the row to match the new admin account (the first name, last name, email, full name columns).

    3) I updated the ActiveDirectoryGuid (also a column of SystemUserBase) to match the new admin account. I found the Guid by login onto the DC server, opening adsiedit.msc, finding the user and right clicking to see the properties. I scrolled down to the objectguid attribute, wrote it down, and changed the ActiveDirectoryGuid value.

    4) I ran the deployment manager, allowed it to try to auto-match. It gave an error but matched most of them. I had some disabled users that I chose not to recreate a AD account for (since this is being installed on a new domain) and the wizard let me proceed without any problems!

    Hopefully these instructions will help someone out there!
    Kyle

    Tuesday, January 17, 2012 12:12 AM