locked
Can't install Windows Genuine Advantage Notification (KB905474) RRS feed

  • Question

  • Hi folks,

    My system also attempted to install the KB905474 update and stalled.  I wish I'd written down the 0x errors, but don't have that available any longer.  I called HP and they suggest a format and reinstall of the OS.  I doubt that would fix the problem.  Here's the results of my MGADiag:

    WGA Diagnostic Data (1.5.0530.2):
    --------------------
    Genuine Validation Status: Genuine
    Windows Product Key: *****-*****-2CXKV-GMP22-HF2BQ
    Windows Product Key Hash: 25dG7mX6zCS/Ri0MYOSCvb3ct0w=
    Windows Product ID: 76477-OEM-2111907-00101
    Windows Product ID Type: 2
    Windows License Type: OEM SLP
    Windows OS version: 5.1.2600.2.00010300.2.0.hom
    Download Center code: Retrieving code...
    ID: 9efb6e2c-d8df-41e8-bdd0-64b88ceeaede
    Is Admin: Yes
    AutoDial: No
    Registry: 0x0
    WGA Version: Registered, 1.5.532.0.
    Signature Type: Microsoft.
    Validation Diagnostic:

    Scan: Complete
    Cryptography: Complete

    Office Status: 100
    Office Diagnostics:

    Proxy settings: N/A
    User Agent: Mozilla/4.0 (compatible; MSIE 6.0; Win32)
    Default Browser: C:\Program Files\Internet Explorer\iexplore.exe
    Download signed ActiveX controls: Allowed
    Download unsigned ActiveX controls: Prompt
    Run ActiveX controls and plug-ins: Allowed
    Initialize and script ActiveX controls not marked as safe: Prompt
    Allow scripting of Internet Explorer Webbrowser control: Allowed
    Active scripting: Allowed
    Script ActiveX controls marked as safe for scripting: Allowed

    Office Details: <GenuineResults><MachineData><UGUID>9efb6e2c-d8df-41e8-bdd0-64b88ceeaede</UGUID><Version>1.5.0530.2</Version><OS>5.1.2600.2.00010300.2.0.hom</OS><PKey>*****-*****-*****-*****-HF2BQ</PKey><PID>76477-OEM-2111907-00101</PID><PIDType>2</PIDType><SID>S-1-5-21-1919368426-2457006209-1597716652</SID><SYSTEM><Manufacturer>Hewlett-Packard</Manufacturer><Model>Pavilion ZV6100 (EC367UA#ABA)     </Model></SYSTEM><BIOS><Manufacturer>Hewlett-Packard</Manufacturer><Version>F.1B</Version><SMBIOSVersion major="2" minor="31"/><Date>20051011000000.000000+000</Date><SLPBIOS>Compaq,Hewlett,Hewlett,Compaq</SLPBIOS></BIOS><HWID>E13A3C07018400E6</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Pacific Standard Time(GMT-08:00)</TimeZone></MachineData>   <Software><Office><Result>100</Result><Products><Product GUID="{90110409-6000-11D3-8CFE-0150048383C9}"><LegitResult>100</LegitResult><Name>Microsoft Office Professional Edition 2003</Name><Ver>11</Ver><Val>6683180514DB500</Val><Hash>+wqFBJ6bpeH/bi2yEwRkuu+Pw4o=</Hash><Pid>73931-640-8494244-57707</Pid></Product></Products></Office></Software></GenuineResults> 

    Any help would be appreciated.

    Warm Regards,

     

    Benedict

    Wednesday, May 31, 2006 10:28 PM

Answers

  • Thnx Greg.

    Your solution worked out as well for me too.

    Greetz, Red.

    Thursday, June 1, 2006 12:38 AM
  •  

    I'm very glad the this worked for both of you!

     

    Thanks for your feedback,

    Greg

     

    Thursday, June 1, 2006 4:50 PM
  • zynuk:

     

    I'm glad you wer able to resolve the issue!

     

    Greg

     

    Wednesday, June 7, 2006 8:55 PM

All replies

  • benedict:

    Can you try this:

    Open internet explorer, click "tools" then "manage add-ons" then find the Windows Genuine Advantage activeX control and put it as "ENABLE". If the setting is only allowed to be changed by administrators, then you must go to your C:\windows\system32 and DELETE the LegitCheckControl.dll file. Then go to http://www.microsoft.com/genuine/downloads/Validate.aspx?displaylang=en and revalidate. That will reload the DLL file correctly. Reboot your computer after this.

     

    I hope this helps,

    Greg

     

    Wednesday, May 31, 2006 10:30 PM
  • Hi Greg,

    Thank you very much for the information.  I followed your advice and can share the following results:

    1.  I checked currently loaded Add-on's and didn't find the Windows Validation.  However, I did find it when I toggled to show those add-ons which had previously used and it was Enabled.

    2.  I deleted the LegitCheckControl.dll file.

    3.  When I attempted to restart it notified me of an update it intended to install when i shut down and offered the option to skip it in the shutdown menu.  I instead opted to cancel the shutdown and checked to see which update was being installed using the taskbar icon (looks like a yellow sheild).  It was the same one that failed earlier. 

    4.  I chose to install it prior to shutting down and it installed successfully.

    5.  Upon reboot I returned to the website you mentioned and it said I was Validated again.

    6.  Upon reboot again I no longer receive the error message .

    Thanks a zillion for your help.

    Sincerely,

    Benedict

    Wednesday, May 31, 2006 11:12 PM
  • Thnx Greg.

    Your solution worked out as well for me too.

    Greetz, Red.

    Thursday, June 1, 2006 12:38 AM
  •  

    I'm very glad the this worked for both of you!

     

    Thanks for your feedback,

    Greg

     

    Thursday, June 1, 2006 4:50 PM
  • Greg:

    This did NOT work for me

    1 WGA Active X was enabled

    2 Deleted LegitCheckControl.dll (after closing Iexplorer)

    3 Followed Greg's link, installed new validation check

    4 Rebooted .....   Auto update and manual attempts still fail

    5 Note...  Defender Beta did update on the reboot. 

    Any further assistance will be appreciated...   Thanks   Bob

    Wednesday, June 7, 2006 5:48 PM
  • zynuk:

    We're going to try something different for you zynuk.

    Can you manually download and install this update: http://www.download.windowsupdate.com/msdownload/update/v3-19990518/cabpool/windowsxp-kb905474-enu-x86_4bafa8793e8cdcaf4ba4ffc494df32d496154544.exe

    reboot and go to Windows update and see if that fixed the problem.

     

    Thanks,

    Greg

    Wednesday, June 7, 2006 6:06 PM
  • Greg:

    Thank you for the email...

    Followed your instuctions, and now I don't have the error, as it does NOT ask me to update.  It tells me I am fully updated.  A review of the "installed log shows all my previous attempts, but no an indication of a succsessful install.

    I keep my system up to date, and was interested in getting it fixed.

    All seems normal...   Thank you very much  ...  Bob

     

    Wednesday, June 7, 2006 8:50 PM
  • zynuk:

     

    I'm glad you wer able to resolve the issue!

     

    Greg

     

    Wednesday, June 7, 2006 8:55 PM
  • The reinstallation of the WGAN worked for me too. Thanks a million.

    Cheers,

    Aaron.

    Thursday, June 8, 2006 3:07 AM
  • Thanks, Greg.

    Direct download and install solved the problem for me too.

    Thanks,

    Paul

    Wednesday, June 14, 2006 6:29 AM
  • I was suffering the "failed to install" problem as well with successful installation already listed in my update history.

    The direct download and install fixed the problem!

    Thanks VERY much!

    Wednesday, June 14, 2006 4:13 PM
  • These two steps have not helped me at all. My computer was ok until I did system restall due to a virus. I have tried the manual download. What other options are there?
    Tuesday, September 12, 2006 6:05 PM
  • Go to C, go to Windows folder, go to system32 folder, go to KB905474 folder, and click on Wgasetup.That will install the kb905474 update.
    Thursday, April 30, 2009 11:33 AM
  • I was also having the same problems as the OP's posts above. The machine I was working on is a recovered malware machine. Tried all of the above recommendations and was still having problems getting WGA to complete its setup.

    Then I started checking services on the machine. The previous IT guy here had hit this machine with whatever tools he tried to eradicate problems. By the time I worked on the machine several crucial services were not running (Event Log, etc). While working on the WGA issue, I noticed that there was a scheduled job in Task Schedular that kept re-appearing after the initial WGA Setup installation. I restarted the Task Schedular and ran the scheduled WGASetup job which completed the final stage of WGA setup.

    Running the WGA Setup as recommended by by OP above will also likely complete this setup, however I wanted to find "root cause" as to why this whole procedure wasn't working in it's normal "automated" fashion.

    Thank you's to all of the above people for their VERY helpfull posts. Some of you above may have had this problem due to a disabled Task Schedular as I did. Check this out.

    John
    Thursday, October 22, 2009 5:22 PM