locked
CRM 4.0 Installation Error- Invalid CommandTimeout RRS feed

  • Question

  • Hi,

    Hope all are doing great. I am trying to install CRM 4.0 on DC VMWare virtual machine. I got the following error. Can any one help me out to fix this issue?

    12:02:54|   Info| Executing Sql Scripts ...
    12:02:54|   Info| File = Scripts\Constants.sql, Message = Add required database constants to mimic enumerations, Target = All
    12:03:00|   Info| File = Scripts\Constraints.sql, Message = Add required database constraints, Target = All
    12:03:01|   Info| File = Scripts\SqlGovernor.sql, Message = Add required Sql Governor values, Target = All
    12:03:03|   Info| File = Scripts\Reserved.sql, Message = Add required reserved names for config database, Target = All
    12:03:03|   Info| File = Scripts\SecurityRolesOnPremiseAndSPLA.sql, Message = Add pre-defined security roles, Target = OnPremise, SPLA
    12:03:03|   Info| File = Scripts\PrivilegesOnPremiseAndSPLA.sql, Message = Add pre-defined security privileges, Target = OnPremise, SPLA
    12:03:04|   Info| Installing Sql Jobs ...
    12:03:04|   Info| Name = .HardDelete, Description = Add hard delete job, Target = All
    12:03:47|   Info| Name = .SiteWideCleanup, Description = Add site-wide cleanup job, Target = All
    12:03:47|  Error| System.Exception: Action Microsoft.Crm.Setup.Server.InstallConfigDatabaseAction failed. ---> System.ArgumentException: Invalid CommandTimeout value -1294967296; the value must be >= 0.


    • Edited by vijayygr Tuesday, July 24, 2012 8:57 AM
    Tuesday, July 24, 2012 8:21 AM

Answers

  • please verify the timeout settings by following this link

    http://blogs.msdn.com/b/crminthefield/archive/2011/06/13/microsoft-dynamics-crm-timeout-settings.aspx

    any after this try tto install it.

    hope this time you will suceed.


    If you see answers and helpful posts, please click Vote as Helpful, Propose as Answer, and/or Mark as answer._____________________________________________________Ahmed - CRM APPLICATION MANAGEMENT ______________________ These replies/answers are my own and doesn’t relate to any company or organization.

    • Marked as answer by vijayygr Tuesday, July 24, 2012 7:21 PM
    Tuesday, July 24, 2012 1:14 PM
  • Hi,

    Thans a lot. It really worked. I could able to install successfully now. I have done the following:
    1) Searched the files for web.config and opened all with note pad and changed the default <http Runtime executionTimeout="300"> to 1500. This I have done even in CRM 4.0 installation files as well.
    2) I reduced the ODBC timeout in registry to 300000 from 3000000000.
    3) During installation of CRM with create new website. As soon the installation created CRM website, I went and changed the ASP.Net (a.IIS 6.0 -> Website Properties -> ASP.NET tab -> Edit Configuration button -> Application tab -> Request execution timeout (seconds)) to 1500.
    After doing all the above changes, my installation proceeded further and completed successfully.
    Thanks once again..

    Regards,
    Vijay

    • Marked as answer by vijayygr Tuesday, July 24, 2012 7:21 PM
    Tuesday, July 24, 2012 7:21 PM

All replies

  • I've never seen this error before, but the setup program must be picking up a Timeout setting from somewhere. Possibilities are:

    • The machine.config or enterprise.config files in %winder%\Microsoft.NET\Framework\v2.0.50727\CONFIG
    • The OLEDBTimeout registry value

    Looking at the vlaue in your error, I expect a timeout has been set to an excessively large number, and this has been treated as a signed integer, which becomes a negative value. Try a value that's less than ~2 000 000 000


    Microsoft CRM MVP - http://mscrmuk.blogspot.com  http://www.excitation.co.uk


    Tuesday, July 24, 2012 10:19 AM
    Moderator
  • please verify the timeout settings by following this link

    http://blogs.msdn.com/b/crminthefield/archive/2011/06/13/microsoft-dynamics-crm-timeout-settings.aspx

    any after this try tto install it.

    hope this time you will suceed.


    If you see answers and helpful posts, please click Vote as Helpful, Propose as Answer, and/or Mark as answer._____________________________________________________Ahmed - CRM APPLICATION MANAGEMENT ______________________ These replies/answers are my own and doesn’t relate to any company or organization.

    • Marked as answer by vijayygr Tuesday, July 24, 2012 7:21 PM
    Tuesday, July 24, 2012 1:14 PM
  • Hi,

    Thans a lot. It really worked. I could able to install successfully now. I have done the following:
    1) Searched the files for web.config and opened all with note pad and changed the default <http Runtime executionTimeout="300"> to 1500. This I have done even in CRM 4.0 installation files as well.
    2) I reduced the ODBC timeout in registry to 300000 from 3000000000.
    3) During installation of CRM with create new website. As soon the installation created CRM website, I went and changed the ASP.Net (a.IIS 6.0 -> Website Properties -> ASP.NET tab -> Edit Configuration button -> Application tab -> Request execution timeout (seconds)) to 1500.
    After doing all the above changes, my installation proceeded further and completed successfully.
    Thanks once again..

    Regards,
    Vijay

    • Marked as answer by vijayygr Tuesday, July 24, 2012 7:21 PM
    Tuesday, July 24, 2012 7:21 PM
  • Hi Vijay,

    good to know that you suceeded.

    thanks for the update :) 


    If you see answers and helpful posts, please click Vote as Helpful, Propose as Answer, and/or Mark as answer._____________________________________________________Ahmed - CRM APPLICATION MANAGEMENT ______________________ These replies/answers are my own and doesn’t relate to any company or organization.

    Wednesday, July 25, 2012 10:56 AM