locked
OrganizationData.svc cannot be activated due to an exception during compilation. The exception message is: Value cannot be null RRS feed

  • Question

  • We activated SSL in Dynamics CRM 2011 website and OrganizationData.svc stopped working.

    CRM Application and SOAP endpoint (Organization.svc) continue working, just the rest endpoint stopped.

     

    Accessing OrganizationData.svc throw this exception:

    Object reference not set to an instance of an object. at Microsoft.Crm.MainApplication.Application_Error

     

    And in trace logs:

     

    Error: The service '/<ORG>/XRMServices/2011/OrganizationData.svc' cannot be activated due to an exception during compilation.  The exception message is: Value cannot be null.

    Parameter name: addresses.

    Error Message: The service '/<ORG>/XRMServices/2011/OrganizationData.svc' cannot be activated due to an exception during compilation.  The exception message is: Value cannot be null.

    Parameter name: addresses.

    Source File: Not available

    Line Number: Not available

    Request URL: https://<CRM-URL>/<ORG>/XRMServices/2011/OrganizationData.svc

    Stack Trace Info: [ArgumentNullException: Value cannot be null.

    Parameter name: addresses]

     

    Some ideas? Some registry or db configs?  We have only 1 frontend server.

    Thanks.

     


    Virtual Group - Soluções Inteligentes www.virtualgroup.com.br
    Tuesday, January 17, 2012 12:49 PM

Answers

  • Do you get the same behavior when you goto:

    1. Settings -> Customization -> Developer Resources

    2. Click the URL for the OData End-Point?   It should open in the browser.  If there are issues with the end point itself you should get the same or similiar errors when clicking the link directly.

    I'm assuming in IIS you added the https binding to the website as well?  Also, what kind of certificate are you using for SSL is it a *. cert or a named cert.  If it's a named cert there is the potential that the name of the SSL certificate does not match the server name/url that is set as the primary.  This could be causing an issue potentially.

    What do you get for the URL's in Deployment Manager:

    1. Start Deployment Manager

    2. Right click Microsoft Dynamics CRM (in the left-hand pane)

    3. Click Properties

    4. It will display the default URL bindings for the website.  Are these showing http/https? 

    Jeremy

    Wednesday, January 18, 2012 4:31 AM

All replies

  • Strange.  I would maybe remove the org using deployment manager and then try to re-attach it again in deployment manager to see if it jogs anything loose.
    Jamie Miley
    Check out my about.me profile!
    http://mileyja.blogspot.com
    Linked-In Profile
    Follow Me on Twitter!
    Tuesday, January 17, 2012 3:14 PM
    Moderator
  • Do you get the same behavior when you goto:

    1. Settings -> Customization -> Developer Resources

    2. Click the URL for the OData End-Point?   It should open in the browser.  If there are issues with the end point itself you should get the same or similiar errors when clicking the link directly.

    I'm assuming in IIS you added the https binding to the website as well?  Also, what kind of certificate are you using for SSL is it a *. cert or a named cert.  If it's a named cert there is the potential that the name of the SSL certificate does not match the server name/url that is set as the primary.  This could be causing an issue potentially.

    What do you get for the URL's in Deployment Manager:

    1. Start Deployment Manager

    2. Right click Microsoft Dynamics CRM (in the left-hand pane)

    3. Click Properties

    4. It will display the default URL bindings for the website.  Are these showing http/https? 

    Jeremy

    Wednesday, January 18, 2012 4:31 AM
  • Hi Jeremy,

    Sorry for the delay.

    I forget to set https property in deployment manager. Simplest thing that I forget.

    Thanks!


    Virtual Group - Soluções Inteligentes www.virtualgroup.com.br
    Friday, February 3, 2012 5:00 PM
  • No worries.  Glad to hear that it was just a simple change and not bigger problems.

    Jeremy

    Friday, February 3, 2012 5:05 PM