none
Could not find SmartDevice.Connectivity in my system - hence couldn't deploy app

    Question

  • I get the following error when I try to run my windows app in Simulator. :

    Could not load file or assembly 'Microsoft.SmartDevice.Connectivity, Version=12.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a. Deploy: 0 succeeded, 1 failed, 0 skipped.

    I tried installing Smartdevice.Connectivity from nuget but it tried to install version 10.0 which is not compatible with .Net 4.5.1. The dll is missing in my disk. Kindly help out. Thanks.

    I am using VS Express 2013 for Windows 8.1.


    Monday, October 20, 2014 5:57 PM

Answers

  • Hi Janani,

    Test Tools in Visual Studio 2010 and 2012forum is to discuss Visual Studio testing issues. You got the error when you run a windows app in simulator, it is out of support range of this forum.

    If the windows app is windows phone app, I suggest consulting your issue on Developing for Windows Phoneforum: https://social.msdn.microsoft.com/Forums/sqlserver/en-US/home?forum=wpdevelop, you will get better solution there.

    Thank you for your understanding.

    Best regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, October 21, 2014 2:17 AM