How do I resolve "invalid response document returned from xmlrpc server" error? RRS feed

  • Question

  • I've used WLW with WordPress blogs for years, love the program. Most issues I experience are to do with the blog software or the server rather than WLW, and the one I have now I suspect is in that category. But I hope someone here can offer some advice on how I can resolve this.

    Right now, if I attempt to post anything to my WP blog, or try to retrive a post or page already posted, I get this error message:

    An unexpected error has occurred while attempting to log in:

    Invalid Server Response - the response to the Blogger.getUserBlogs
    method received from the blog server was invalid:

    Invalid response document returned from XmlRpc server

    Here's a screenshot of the error dialog that pops up: http://moby.to/3mkwvu

    I get the same error if I attempt to edit my blog settings.So effectively, I'm locked out of remote publishing to my blog. I should add that I have not added or changed anything on the blog re remote publishing with WLW - all was working just fine until a week ago.

    If I look at the WLW log, among the huge amount of info there I see multiple entries (coinciding with each attempt to connect WLW with the blog) containing text like this:

    WindowsLiveWriter,1.7572,None,00006,11-Mar-2010 10:13:17.679,"Exception parsing XML-RPC response:
    WindowsLive.Writer.CoreServices.XmlRpcClientInvalidResponseException: Invalid response document returned from XmlRpc server ---> System.Xml.XmlException: Data at the root level is invalid. Line 1, position 1.
       at System.Xml.XmlTextReaderImpl.Throw(Exception e)
       at System.Xml.XmlTextReaderImpl.Throw(String res, String arg)
       at System.Xml.XmlTextReaderImpl.ParseRootLevelWhitespace()
       at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
       at System.Xml.XmlTextReaderImpl.Read()
       at System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
       at System.Xml.XmlDocument.Load(XmlReader reader)
       at System.Xml.XmlDocument.LoadXml(String xml)
       at WindowsLive.Writer.CoreServices.XmlRpcMethodResponse..ctor(String responseText)
       --- End of inner exception stack trace ---
       at WindowsLive.Writer.CoreServices.XmlRpcMethodResponse..ctor(String responseText)
       at WindowsLive.Writer.CoreServices.XmlRpcClient.CallMethod(String methodName, XmlRpcValue[] parameters)
    <?xml version=""1.0""?>

    I'm at a bit of a loss to figure out how to fix this issue other than start over with installing WLW again (and possibly WP). Reluctant to do that iunless it's the only option.

    Any thoughts? Suggestions? Appreciate all advice!

    Some version info:

    Thursday, March 11, 2010 11:54 AM

All replies

  • I'm going to take a quick shot at this...
    I'm running Wordpress [latest version] with Windows Live Writer [latest] and it seems to have no issues.

    Referencing the message you provided, the issue is that the server/blog [Wordpress] is returning something the software doesn't understand; it can't parse it or import it, thus we have the error.

    I assume the issue 'just started' happening...

    I've had periodic issues with my site, but those have been typically fixed by maintenancing the database in Wordpress.
    You don't mention it, but have you tried that?

    My apologies, but if this isn't the issue- this would be a developer issue; their comments are sparse in the forum.

    Hope this helps.

    L. Henry Jr.
    Thursday, March 11, 2010 12:36 PM
  • Thanks, lehenryjr, appreciate your suggestion. Yes, the issues only started recently. I suspect you're right, ie, it's a developer issue, meaning a confident answer likely from a developer. Here's hoping :)
    Thursday, March 11, 2010 2:02 PM
  • An update. A knowledgeable friend pointed me to this post usefully-entitled "How To: Fix invalid blogger.getUsersBlogs method response" - http://wlwplugins.com/how-to-fix-invalid-bloggergetusersblogs-method-response.php

    It suggests adding this text to .htaccess in the root directory on the server:

    <Files xmlrpc.php>
    SecFilterInheritance Off

    If I do that, though, I immediately get a 500 error on the server. Removing those lines from .htaccess, no 500 error. Next step: I've asked my hosting service (DreamHost) if mod_security is blocking access to xmlrpc.php and if so, can they set it to allow access to that file.

    Awaiting their response...
    • Edited by janglesextra Friday, March 12, 2010 7:08 AM Fixed typo.
    Friday, March 12, 2010 7:06 AM
  • I have had the same problem a month or so ago. I solved it at that time. Now I'm setting up another blog and having the same problem again. I can't remember what I did. Bad. Really Bad. But here is what I have found so far.
    1. None of the things I have found on Google resolved it.
    2. If I only have 43 post on my site Windows Live Writer works the way it should.
    3. If I have 44 or more post I get the WLW error and it doesn't make any difference which post I "Trash" and then "Restore" after I test WLW the results are always the same it fails.

    The way I found out was to "Trash" 10 post and found out it worked. I then restored them one at a time and if I restored even one of them it failed. Next step was to Restore all of them and Trash 10 other post. Same results. It makes no difference which ones I Trash. As long as I only have 43 post it works and 44 doesn't.

    I'm going to keep trying and when (not if) I resolve the problem I'll post back here.
    Bob Jones
    Friday, March 12, 2010 7:27 PM
  • Here is an update. I have made a little headway but still not there.
    If I deactivate 3 WP plugins then WLW works OK
    The plugins I have to deactivate are;
    Wordpress Data Base Backup
    WP Ajax Edit Comments
    WP Super Edit

    Back to work. I hate it when things don't work right.
    Bob Jones
    Friday, March 12, 2010 8:19 PM
  • Did you add any WordPress plug-ins recently? There are a few Wordpress plug-ins that can cause problems with XML-RPC. Try disabling all of your Wordpress plug-ins and then try to post with Writer and see if that solves the problem.

    If Writer works, try enabling a few a time and see when Writer stops working.

    If Writer still doesn't work, let me know and we'll attempt to diagnose this further.

    Windows Live Writer Developer
    Friday, March 12, 2010 8:21 PM
  • OK, I have WLW able to download a list of post from my site. I did not want to do without the three plugins listed above so I started through the list over and over. Here is what I ended up deleting.
    Google Analytics Dashboard
    Google Analytics For Wordpress
    Subscribe Sidebar
    Smart 404
    Search Meter

    If any of these are active at the same time that Wordpress Database Backup, WP Ajax Edit Comments or WP Super Edit are active Window Live Writer can't download a list of post. I am satisfied that this has resolved my problem and will not look any farther.

    I suggest that if you are having this problem that you disable ALL your plugins and then activate them one at a time until you find the ones that cause a problem. Then if you can't do without some of the problem plugins you can activate them and start through the list again, and again, and again until you have what you must have.

    I did notice that in WLW that when trying to download the list of post sometimes it will fail the first try and if you try again it will get the list.
    I hope this helps.
    Bob Jones
    • Proposed as answer by lehenryjr Monday, March 22, 2010 5:29 PM
    Friday, March 12, 2010 9:54 PM
  • In my case, this Plugin was the wrongdoer


    Sunday, July 10, 2011 9:47 PM
  • Hi,  I'm so hoping I can get some help here.  Please bear in mind that I am a novice in all this HTML, etc...

    I have a self-hosted WordPress blog and I post to a free Blogger blog, which I have been doing using WLW since last November.  No issues other than it would crash occasionally.   

    I've posted to both blogs using WLW from my laptop (Windows Vista) and my desktop (Windows XP) - no issues on either computer.

    Last week, however, I successfully posted to my self hosted WP blog on Wednesday night.  Then when I tried to post from WLW on Saturday I received this error:

    • An unexpected error has occurred while attempting to log in:

      Network Connection Error - Error attempting to connect to blog at:


      The server committed a protocol violation.
     I've contacted my web host who tells me that it's a WLW issue.  I've tried to un-install using the Control Panel and then do a re-install but apparently it's not completely removing the files (even though I checked to make sure the WLW folder was gone).

    After reading this discussion, I've checked to verify that it's not my plug-ins which I didn't think would cause the problem as I had not added or updated any.  It's not the plug ins.

    I am at a complete loss and although I've done searches, all the technical talk is really confusing.  Any help would be sooooooo very much appreciated :-).

    • Proposed as answer by Doug Millington Wednesday, October 19, 2011 3:54 AM
    • Unproposed as answer by Doug Millington Wednesday, October 19, 2011 3:54 AM
    Sunday, July 31, 2011 3:10 PM
  • I just had this same issue and just today I updated the Yet Another Related Post Plugin (YARPP) so after reading this thread I deactivated the YARPP plugin and WLW posted to my blog fine. I then reactivated the plugin - kinda of a PITA but it worked.
    Wednesday, October 19, 2011 3:57 AM
  • I just spent 4 hours on this with Windows 8 and WLW 2012. Turns out it was a hyperlink in the body of the post. I removed all plugins, images and then started going aftrer the formatting. Finally removed a link and it worked. Returned to the original post and simply removed the link. The post published.

    Now I have to figure out if it will work at all.


    Matthew McDermott, MVP SharePoint

    Tuesday, September 11, 2012 4:10 PM