locked
SATA Controller Card not recognized at boot - Silicon Image 3132 Base BIOS used RRS feed

  • Question

  • I just read this post: http://social.microsoft.com/Forums/en/whshardware/thread/3c250792-4497-4096-9eb6-03592c0de919

    But it didn't help.  I purhcased a Rosewil RSV-S$-X from Newegg.ca - i comes with a 2 port SATA Controller Card that is flashed with a RAID BIOS. After installing in the WHS box (DELL 8400) I flashed it with the "Base" (NON-RAID) Bios and installed the corresponding drivers.  All worked fine...but sporadically the controller "disappears" when the server reboots.  This happened once right after I installed the card (with the original RAID drivers/BIOS) but I figured it was some issue with the original BIOS or drivers.

    After everything was setup I was able to partition/format 2 - 2TB drives in the Rosewill box but today the power went out and when the server rebooted, it doesn't see the controller card.  Typically the card ID and BIOS pop up on the screen after the norm BIOS info and before WHS starts...but now nothing.  I've tried reinstalling the actual controller card (reseating it) but no luck. Doesn't matter if the drives (Rosewill box) are attached or not.

    Rosewill support is telling me to change some setting in my BIOS relating to PnP but there are no such settings.  They also suggested a failing CMOS battery but I'm not having any other issues with the PC..just with this card.

    Not sure what else I can do to troubleshoot. 

    I recall having to install "Chipset drivers" when I had restored XP onto the 8400 before it was recommissioned as a WHS box, but was told somewhere along the line I likely did NOT need to install those drivers for WHS - so the only other driver installed with the WHS install (right after) was the drivers for the integrated NIC.  Not sure if the "ChipSet" Drivers would potentially help with this issue?

    The Card uses a Silicon Image 3132 chip and I did extensive reading on the BIOS/Drivers and had no issues reflashing the card with the NON-RAID BIOS.  It did see the 2 drives as separate drives also.

    Any ideas?

     

     

    Tuesday, May 3, 2011 1:53 AM

Answers

  • UPDATE: turned out it was the card supplied with the enclosure.  Newegg (well Rosewill) Custmer Support shipped me a different (retail) card that was based on the same chipset and designated as "non-RAID" and it worked out of the box.  The drivers I had installed worked with the card once I installed it.  It's been smooth sailing ever since.

    Well, until I had to do a server re-installation and had some technical difficulties with my ancient Floppy Drive "refreshing" so it would see the Si3132 drivers on the second floppy!  But I'm going to look into slipstreaming the drivers onto the WHS Installation CD in case I have this issue again.

     

    But the enxlosure is awesome, 8TB of storage in one toaster sized box, one power cable, one eSATA cable to the WHS.  No need for all those single external drives any longer.

    Thursday, September 1, 2011 10:03 PM