locked
Workflow Import fails RRS feed

  • Question

  • Hi there

    I am unable to publish workflows after importing them from DEV to TEST. When I open the Workflow all the steps have "red" cross indicating there are errors in the workflow. But these workflows work fine on the DEV.

    Any help is much appreciated.

    Enviroment: CRM 4 (UR6) is on Win2K3 (64 bits), IE 7

    Regards,
    Friday, December 18, 2009 1:11 PM

Answers

  • I have found out what the problem is..

    The workflow has a lookup reference in the DEV. When this workflow is imported into TEST, obviously it doesnt find the lookup (GUID value is different). And hence it fails.

    I will have to either soft configure this or change the lookup manually in each enviroment that the workflow is promoted to.

    Regards,
    • Marked as answer by P Dandawate Friday, December 18, 2009 2:34 PM
    Friday, December 18, 2009 2:34 PM

All replies

  • Hi,

    open the steps and look for the error details. When you use user on the DEV system you must change them to the right user on the test system
    Viele Grüße

    Michael Sulz
    axcentro GmbH
    MVP für Microsoft Dynamics CRM
    Friday, December 18, 2009 1:51 PM
  • Hi Michael

    Thanks for your reply.

    There is only step in the workflow. If I recreate this step manually in the TEST it works, but when I import this from the DEV it fails.

    Regards,
    Friday, December 18, 2009 1:54 PM
  • I have found out what the problem is..

    The workflow has a lookup reference in the DEV. When this workflow is imported into TEST, obviously it doesnt find the lookup (GUID value is different). And hence it fails.

    I will have to either soft configure this or change the lookup manually in each enviroment that the workflow is promoted to.

    Regards,
    • Marked as answer by P Dandawate Friday, December 18, 2009 2:34 PM
    Friday, December 18, 2009 2:34 PM