locked
One (and one only) of my PC's can't connect completely to WHS 2011 RRS feed

  • Question

  • Replaced old WHS with fresh WHS 2011 install. One PC running the same OS (Win7 Pro / x64) and on the same LAN switch as another one that works perfectly fine will install the connector and the dashboard will come up, but it shows the backup status as "unknown" and under "computer properties" for the PC it says that it "cannot determine OS info". Logging into the launchpad results in a "server is offline" error. I tried reinstalling the connector several times, no change. Checked my LAN settings (no proxy) and all sorts of other things recommended online - nothing. Any suggestions? My first connector install was done over Remote Desktop Connection (I was too lazy to go upstairs), BTW, after that I re-installed it "directly" - I figure it's just a rumor that installing over RDC causes problems anyway, it would be inconceivable to ship WHS 2011 with such basic bugs ;).

     

    Thanks!

    PeterK

    Saturday, October 1, 2011 3:47 AM

All replies

  • Are the time settings on the server and client the same?

    Saturday, October 1, 2011 9:43 AM
  • Yes, I sync'd the time on both ends with the time server (and made sure they match the wall clock).
    Saturday, October 1, 2011 1:43 PM
  • See also this thread?

    - Theo


    No home server like Home Server
    Saturday, October 1, 2011 10:17 PM
  • (I've logged in from another PC and I'm probably using a different LiveID - I'm still a hosed user, though ;)

    I did look at that thread, but my situation is even worse - the thing never ever works properly, whereas in that thread the problem goes away when the connector is re-installed. I've re-installed it several times and it doesn't help. Of course, having to re-install the connector every few days isn't much better but at least they can get *a* backup done, whereas I can't get it to work with this PC at all, so no backups.

     

    Any other ideas?

     

    Thanks

    PeterK

    Sunday, October 2, 2011 12:13 AM
  • Any other ideas?


    Hmm..
    First that comes to mind:

    • Assuming you from the problem client PC you can ping the server both by name and IP (If you did do so already, please check?)
    • Network is setup as a "private" network (check "Network and sharing center")
    • Any non-standard applications that might block in/outgoing ports (anti-virus, firewall)?
    • Check the client PC's event list. Anything "suspicious"?

    - Theo.


    No home server like Home Server
    Sunday, October 2, 2011 2:09 PM
  • Thanks for the tips; unfortunately, I appear no closer to getting this PC to back up.

    • I can not only ping the server, the dashboard comes up. The launchpad will not connect, though, and backups won't happen.
    • Networking flavor is "home".
    • I believe I only have MS Security Essentials and the standard firewall installed; turning the firewall completely off didn't help.
    • The event viewer shows the usual noise but nothing jumps out.

    Is there some kind of a diagnostics thing available for problems like these? I tried to install the log collector (which I used to report my other big WHS 2011 problem) but it won't install on this "semi-connected" client PC, of course.

    Thanks

    PeterK

    Tuesday, October 4, 2011 2:57 PM
  • Then your only 'diagnostics' are the logfile. You can find them at "C:\ProgramData\Microsoft\Windows Server\Logs"
    First check "Launchpad.2.log", "Launchpad.log" and "TransferService.log"

    PS - Just a thought...
    There might be a problem with the launchpad authenticating to the server. Try as follows:
    * On the server (using the Dashboard) change the password for the username you use to log in on the client.
    * Change the password to a "simple" password (i.e not using any special characters).
    * Restart the client.

    Lauchpad now should ask you for username and password (does it?)
    Authenticate Lauchpad using the username and new password?

    - Theo.

     


    No home server like Home Server
    Tuesday, October 4, 2011 9:00 PM
  • I don't see "Launchpad.2.log" or "TransferService.log" in that directory, but I did find "Launchpad.log" and some other log files. The stuff in there is so verbose / repetitive, though, that I can't make much head or tail of it and I probably shouldn't post that much junk on this thread, so I stuck it on my web site if anyone has time to look at it - the compressed log summary is at www dot kukol dot com slash whs dot 7z. The one thing that jumps out from the logs is that there are a lot of connection timeout errors such as the following ("stars" is the name of the client computer; sometimes its IP address 192.168.0.153 is also listed):

        Could not connect to net.tcp://stars:6602//Microsoft.WindowsServerSolutions.Common.ProviderFramework.IProviderRegistry.

    I also tried the user trick - I deactivated the normal user I use completely and created a new test account (with a trivial password) just for this experiment - but, alas, there was no obvious difference in the result.

    Thanks for your help!

    PeterK

    Wednesday, October 5, 2011 1:19 AM
  • Found your logs :-)

    (EndpointNotFoundException) Could not connect to net.tcp://stars:6602//Microsoft.WindowsServerSolutions.Common.ProviderFramework.IProviderRegistry. The connection attempt lasted for a time span of 00:00:21.0677114. TCP error code 10060: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 192.168.0.153:6602.

    Could you check on Client f the following service is running: "Net.Tcp Port Sharing Service".

    If not, try starting it manually.
    If it does not start, my guess would be there is a problem with the .NET Framework 4.0 on this particular client PC.

    To try and solve this:
    * Uninstalling the connector
    * Uninstall the .NET Framework 4.0
    * Restart the client PC
    * Re-install the WHS client connector (first download and save it to the clients desktop, run it from there)

    - Theo.

     


    No home server like Home Server
    Wednesday, October 5, 2011 8:06 PM
  • The service is running but just in case I un-installed the WHS connector and all vestiges of .NET v4 - upon re-installing WHS (from a saved copy on the local HD) the results are exactly the same as before.

     

    Thanks

    PeterK

    Thursday, October 6, 2011 1:19 AM
  • Hi Peter,
    :-| Now I am out of ideas...

    I would suggest reporting your problem to MS Connect (please also add your client logfiles to the report?)

    - Theo.


    No home server like Home Server
    Thursday, October 6, 2011 7:57 PM
  • Have you been able to correct this problem?  i am having the exact same issue with a laptop on my home network.
    Sunday, November 6, 2011 3:32 PM
  • I suggest you to submit a bug on Microsoft Connect forum.

    Link: https://connect.microsoft.com/

    You can get help from the engineer via Connect forum, also you can upload you logs to the product team.

    I believe your problem will be resolved soon.

    Friday, November 18, 2011 3:08 AM
  • Add me to the list, as well.  My symptoms are identical to those posted by PeterK.  I have installed the client from scratch on my laptop (Alienware) several times, and this machine can connect through the dashboard, but shows "offline".  I have done everything suggested in the previous posts, and still have had no luck.  The server works well, and my desktop client works just fine.  I do not have a DNS or connection issue; the server pings from the laptop perfectly.  If anyone has been through this, and has solved this problem, please let me (us?) know what you did to fix it.  Thanks!
    Monday, December 19, 2011 10:47 PM