locked
Resource shows as overallocated but is not RRS feed

  • Question

  • I have a project that has been published to the server (PS2010). When looking at the schedule in Project Pro the resource (a few of them) show the overallocation icon (the red man). When I look at the Resource Usage view the resource has the overallocated warning icon. Yet when I scroll across to where the hours show red, the hours for all projects and tasks for the time period is less than the resource's maximum capacity for the time period.

    Can someone help me understand why a resource could show as overallocated when all tasks for the resource for the time period add up to less than the maximum capacity? I have double checked the calendar being used for the resource is the Standard Enterprise Calendar.

    I have also checked in the Resource Center and the Resource Capacity graph shows as UNDER allocated.

    I need to know if this problem could be indicative of a larger problem. We are trying to isolate overallocated resources and get them resolved. If the indicators are incorrect, it will be way more difficult for the PM to resolve.

    Tuesday, January 24, 2012 9:07 PM

Answers

  • Hi smokief,

    Yes I would also check if the file is ok. Another check you may want to do is in the resource center. Does hte resource also appear overallocated there? if not, than you may be right with the corruption of the file.

     


    Marc Soester [MVP] http://marcsoester.blogspot.com
    • Marked as answer by smokief Tuesday, March 13, 2012 5:40 PM
    Thursday, January 26, 2012 11:01 PM

All replies

  • Resource overallocation could also happen, if the resource is assigned more than one task during exactly the same times/dates. Check if that is the reason for overallocation.

    Team Planner View is better for recognizing this kind of overallocation.


    Prasanna Adavi, PMP, MCTS http://thinkepm.blogspot.com
    Wednesday, January 25, 2012 1:31 AM
  • HI smokief

    That is actually a bug I believe. I see this all the time, that's why I generall dont trust the red color. I believe it has something to do with rounding issues. If you want to ensure that there is no overallocation insert the "Overallocation" line into the resource usage view and check the numbers in there. If this says 0 than you know the resource is not overallocated.

    I hope this helps


    Marc Soester [MVP] http://marcsoester.blogspot.com
    Wednesday, January 25, 2012 4:44 AM
  • Marc - I checked in the Resource Usage view and all the tasks only add up to a fraction of the maximum capacity. But thank you for the insight on the bug.

    Prasanna - I do believe there are tasks assigned on the same dates but the Units add up to less than the maximum capacity.

    My PM just mentioned that the tasks were copied in from a Vendor. I actually wonder now if the files got corrupted at that time. Any thoughts?

    Wednesday, January 25, 2012 2:28 PM
  • Well, Project plans minute by minute, though most people don't need that much detail. You check the capacity over a specific time period (week, months) but the overallocation may be on a much smaller level than that.

    Let's suppose you're looking for overallocations on the week level. On week 3, you have two tasks of, say, 10 hours each. So both of them together still leave you with free time to work on something else, you are underallocated on the week level. But what if by any chance, the work is spread in such a way that you have 9 hours of work to do on Monday? Project knows from your calendar you actually can't work more than 8 hours per day, so you're overallocated on Monday. Because of this, you'll be displayed in bright red in the resource usage view as well as the time period where the overallocation is: week 3. The line "overallocation" though will only display the overallocation for the displayed time period, so nothing will show up because there's no overallocation on the week level.

    Because of this logic, overallocations on the hour level used to be a repeated cause for annoyance, but those don't cause resources to be displayed in red anymore, my thanks to the project team for that.

    I'm not sure if this is the reason for your problem, but it'd be the first thing to check. Go to the red time period and keep clicking "zoom in", you might find out what's causing it.

     

    Regards,

    Livia


    Wednesday, January 25, 2012 3:12 PM
  • Livia - Thank you for the suggestion. I checked the schedule in question and found that as I drill down to smaller time packets (hour) the over-allocation goes away. When I zoom back out to a weekly level it shows as overallocated.

    Still puzzled...

    Wednesday, January 25, 2012 9:47 PM
  • Hi smokief,

    Yes I would also check if the file is ok. Another check you may want to do is in the resource center. Does hte resource also appear overallocated there? if not, than you may be right with the corruption of the file.

     


    Marc Soester [MVP] http://marcsoester.blogspot.com
    • Marked as answer by smokief Tuesday, March 13, 2012 5:40 PM
    Thursday, January 26, 2012 11:01 PM
  • Hello,

    I observe the very same behavior with Project PRO / Project Server 2007 with latest CU.

    I also believe that there are serious bugs in the resource usage views and the computation of resources overallocation flags, loading resources allocation summary or not.

    Here is a case that I observe :

    The total work load of a resource for some day is 4.36 hours for all assigned tasks for all projects. The capacity of this resource, for this day, is 8 hours.

    In PWA (once the project plans have been published), everything looks fine, the load, capacity and availability for that day for that resource is properly reported.

    In Project PRO::Resource Usage view, this resource is reported overallocated for that day (and in general), which is very annoying.

    In Project PRO again, if I display the resource's allocation graph, e.g. from the team builder, everything is properly reported, as it is the case from PWA.

    My recommandation would be to use the resource allocation graph from Project PRO to verify resource capacity/availability, if you do not want to publish while leveling your project.

    Regards,

    Wednesday, April 25, 2012 2:01 PM
  • Hi, maybe the problem is related to a "bug" on "resource usage" and "task usage" views (in project professional 2013).

    Look like my attachment: the task it is scheduled to start on 4/feb/2013 but the view (zoom to month) show me that the allocation must start in Jenuary!!!!

    I tried to changed the task type but nothing happens!

    What do you think about that?

    Thank you

    Wednesday, February 6, 2013 2:00 PM
  • I had a similar experience:

    I opened the "Resource Usage" sheet and modified the "Leveling Options" to Look for Overallocations on a Week-by-Week not day-by-day basis, and the red disappeared...

    Looks like red attribute is calculated by algorithms that are controlled by the "Leveling Options" even if I don't command the leveling on the Resource ribbon.

    Thursday, January 9, 2014 4:28 PM
  • Indeed you're right! The "red guy" showing overallocation is triggered based on the granularity settled in the levelling options.

    Regards.


    Guillaume Rouyre - MBA, MCP, MCTS

    Thursday, January 9, 2014 4:30 PM
  • I would agree that are some scheduling bugs. One is this: When I assign a 2 tasks to one resource at 50% each from Day 1 through Day 100, the last day usually adds up to either less than a full day or more than one. If the former, you probably don't even notice. If the latter, the person shows as over-allocated.


    It's fixed by manually adjusting the hours on the last day. Can't paste image because my account is not yet verified.

    Important points:

    * Using MSP 2016 Professional

    * All manually scheduled, fixed duration tasks

    Monday, July 16, 2018 7:57 PM
  • Just wanted to thank you as, even 6 years on this explanation is relevant concise, and helped me diagnose my own error -  I was programmatically assigning someone to start work at which by default started at 0:01, and with a work day starting at 08:00 this was flagging as an overallocation. Thank you!
    Tuesday, October 30, 2018 3:39 PM