locked
SSAS Filter Web Part (PS2010) RRS feed

  • Question

  • Hi everyone

    I have tried posting this issue in the original thread but couldn't get any replies.

    I'm trying to insert a SQL Server Analysis Services (SSAS) web part to a page. I try to use an existing ODC file in BI Center > Data Connections. After selecting the ODC file in the web part settings, I get the following error message:

    Either the data connection URL does not resolve to a valid data connection or it resolves to a data connection of the wrong type. The data connection URL must be the valid URL of a data connection file on an SQL Server Analysis Services server.

    I'm using SSAS 2008 R2. I plan on using this wep part for filtering for project name. I then want to pass the project name to an Excel report in SharePoint.

    Thanks for your help.

    Marc

    Monday, September 5, 2011 3:04 PM

Answers

  • Thanks Paul for your quick reply! I have verified that the provider is set to MSOLAP.4 and still can't get it to work.

     

    However, I just tried to add the connection again for about the 24th time and now it works! No clue why though... Maybe it was caused by opening the ODC? I guess we'll never know... :)

    Thanks for your help Paul, much appreciated!

    • Marked as answer by shelldor23 Wednesday, September 7, 2011 10:06 AM
    Tuesday, September 6, 2011 5:25 PM

All replies

  • Hi Marc,

    I have just set this up on my environment and this worked as expected, please see the following guide:

    http://office.microsoft.com/en-us/sharepoint-server-help/connect-filter-web-parts-to-excel-web-access-HA010105470.aspx#BMconnect_a_sql_server_2005_analysis_se

    If you have issues, check that the connection files use the MSOLAP.4 provider and not the .3 provider - I have seen this on an environment before.

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com
    Monday, September 5, 2011 7:43 PM
  • Hi PWMather,

    Thanks for your reply and for posting the link. However, the article only discusses how I can connect the SSAS filter web part which would be part II of my adventure. :) The problem is that I don't get this far as I'm struggling with part I: having the SSAS filter web part connect to a ODC file and retrieve values from there.

    Maybe you have some advise for this issue as well? Thank you!

    Marc

    Tuesday, September 6, 2011 4:33 PM
  • Hi Marc,

    Please open one of your ODC files and check the MSOLAP provider, i've got a feeling you will see provider=MSOLAP.3. If this is the case, create a new ODC file (open an existing ODC file in Excel, make the change then export the connection), change the provider to MSOLAP.4 upload this new ODC file to the data connection library then test linking the SSAS filer to the new ODC file that uses the .4 provider.

    I have seen this before and the issue was that the provider in the Cube ODC files was the wrong verion for the SQL AS version, so worth checking using the steps outlined above.

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com
    Tuesday, September 6, 2011 4:55 PM
  • Thanks Paul for your quick reply! I have verified that the provider is set to MSOLAP.4 and still can't get it to work.

     

    However, I just tried to add the connection again for about the 24th time and now it works! No clue why though... Maybe it was caused by opening the ODC? I guess we'll never know... :)

    Thanks for your help Paul, much appreciated!

    • Marked as answer by shelldor23 Wednesday, September 7, 2011 10:06 AM
    Tuesday, September 6, 2011 5:25 PM
  • No problem, glad to hear it now works for you :)

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com
    Tuesday, September 6, 2011 5:27 PM