locked
D-Link DSL-G624T Port Forwarding issue RRS feed

  • Question

  • Hi

     

    I'm having a few problems trying to get access to my WHS over the Internet on a D-Link DSL-G624T.

     

    I have followed the instructions in WHS and set up Port Forwarding (I think) for ports 80,443 and 4125.

     

    In the web interface I have navigated to:

     

    WAN > Advanced (Tab) > Virtual Server

     

    Created a rule called WHS

     

    In it I have added:

     

    Protocol     Port Start    Port End    Port Map

    -------------------------------------------------------------

    TCP            80                80               80

    TCP            443              443            443

    TCP            4125            4125          4125

     

    I have applied the rule and saved and restarted the router.

     

    The WHS has a static IP of 194.238.1.4 and the connection is Pvc0, (I use BT Broadband).

     

    Strangely, there is a setting to enable UPnP however WHS still can't automatically configure the router.

     

    When I browse to my URL <domainname>.livenode.com internally, I get prompted for the routers username and password. Externally, I just get "Page Not Displayed"

     

    If anybody can help with this I would be eternally grateful!!

     

    Thanks in advance

     

    David

     

     

     

     

    Thursday, April 26, 2007 8:54 PM

Answers

  • hello,

    1.

    in port forwarding set protocal to both not just tcp

    2

    UPnp will not work even if your router suports it and it's enabled until the final release.

    good luck

    Friday, April 27, 2007 7:08 AM

All replies

  • I use a D-Link DI-604 - the configurations are slightly different, but your port settings look correct.

     

    Internally you won't get to the WHS because the router does not support loopback - the URL provides the external ip of the router, but the router will not foward from the inside, so you end up with the router configuration page - you need to use the internal ip address of the WHS.

     

    Externally - you might want to check with your ISP - many of them block port 80 along with several other ports to discourage people from running web servers - mine blocks port 80, 8080, and 443

     

    One work around is to configure the router to forward to a different port - for example, you can tell the router to forward port 8080 external (public) to port 80 internal (private) and then use  - http://<your.URL.here>:8080 to get access.

     

    If your ISP doesn't want to tell you which ports are blocked, it will some experimenting with forwarding to figure it out.

    Thursday, April 26, 2007 9:28 PM
  • Thanks for this - I will look at it again.

     

    According to some research I have done, my ISP (BT) don't block any ports so I think my router is throwing a bit of a hissy-fit!

     

    Cheers

     

     

    Thursday, April 26, 2007 11:38 PM
  • hello,

    1.

    in port forwarding set protocal to both not just tcp

    2

    UPnp will not work even if your router suports it and it's enabled until the final release.

    good luck

    Friday, April 27, 2007 7:08 AM
  • Thanks everybody for your help

     

    David

    Friday, April 27, 2007 7:28 PM