locked
COMPILAR PROYECTO DE INSTALACIÓN CON FRAMEWORK 2.0 RRS feed

  • Question

  • HOLA,

    REALICÉ UNA APLICACIÓN UTILIZANDO EL FRAMEWORK 3.5. AL VER QUE LA INTALACIÓN ERA MUY PESADA DECIDÍ CAMBIARLO A LA 2.0, VOLVÍ A A CREAR UN PROYECTO NUEVO SELECCIONANDO EL FRAMEWORK 2.0, IMPORTÉ LOS OBJETOS DEL PROYECTO, MODIFIQUÉ LOS ERRORES QUE ME CAUSÓ LA IMPORTACIÓN Y PERFECTO.

    MI PROBLEMA VIENE DADO CUANDO INCLUYO UN PROYECTO DE INSTALACIÓN. CUANDO GENERO LA SOLUCIÓN Y LA EJECUTO COMO CLICKONE TODO FUNCIONA PERFECTO (EN UNA MÁQUINA CON FRAMEWORK 2.0) PERO SI INTENTO EJECUTAR EL SETUP REALIZADO CON EL PROYECTO DE INTALACIÓN ME EXIGE EL FRAMEWORK 3.5.

    EN LAS PROPIEDADES DE LA APLICACIÓN TENGO INDICADO QUE FUNCIONA SOBRE LA VERSIÓN 2.0 Y NO HE VISTO EN NINGUNA OTRA OPCIÓN LA MANERA DE INDICARLE AL PROYECTO DE INSTALACIÓN QUE NO ES NECESARIO EL 3.5.

    AL INSERTAR EL PROYECTO DE INSTALACIÓN ME ASEGURÉ BIEN DE HABER INDICADO QUE LO QUERÍA PARA FRAMEWORK 2.0, PERO NO HAY MANERA.

    ¿¿ALGUIEN PUEDE ORIENTARME??

    GRACIAS
    • Moved by liurong luo Wednesday, March 18, 2009 1:15 AM issue was not described in English. (Moved from Visual Studio Debugger to Where is the Forum For…?)
    Monday, March 16, 2009 5:58 PM

Answers

  •  

    Hello Alexis, 

     

    Thank you for your post!  I would suggest posting your question in one of the MSDN > Forums Home > .NET Development > .NET Framework Setup located here:  http://social.msdn.microsoft.com/Forums/en-US/netfxsetup/threads/.

    Have a great day!


    Sudarshan shindode Tier 2 Application Support Server and Tools Online Engineering Live Services Team
    • Proposed as answer by sudarshans1 Friday, March 20, 2009 11:35 AM
    • Marked as answer by Kiran Polimetla Thursday, September 10, 2009 8:50 AM
    Friday, March 20, 2009 11:35 AM

All replies

  • Hi,

    Can you please post your query in English Language.


    Thank you
    Kiran Polimetla Tier 2 Application Support Server and Tools Online Engineering Live Services Team
    Thursday, March 19, 2009 12:53 AM
  •  

    I made an application by using framework 3.5. As the installation was very heavy I decided to change it to 2.0. I created a new project by selecting framework 2.0, imported the objects of the project and finally modified the errors caused by the importation. Everything went perfect.

    My problem occurs when I include an installation project: when generating the solution and executing as CLICKONE, everything works fine (in a machine with framework 2.0). However, if I try to execute the setup carried out with the installation project, then it demands framework 3.5.

    I have checked the application's properties and it indicates that it works with version 2.0 and I have not seen any other option that can indicate to the installation project that 3.5 is not necessary.

    When inserting the installation project I made sure I had indicated that I wanted framework 2.0 but somehow it keeps asking me framework 3.5.

    Is there anyone who could help me with this?

    Thank you so much!!

    Friday, March 20, 2009 10:53 AM
  •  

    Hello Alexis, 

     

    Thank you for your post!  I would suggest posting your question in one of the MSDN > Forums Home > .NET Development > .NET Framework Setup located here:  http://social.msdn.microsoft.com/Forums/en-US/netfxsetup/threads/.

    Have a great day!


    Sudarshan shindode Tier 2 Application Support Server and Tools Online Engineering Live Services Team
    • Proposed as answer by sudarshans1 Friday, March 20, 2009 11:35 AM
    • Marked as answer by Kiran Polimetla Thursday, September 10, 2009 8:50 AM
    Friday, March 20, 2009 11:35 AM