locked
Problems with Sharing Printer RRS feed

  • General discussion

  • I have been running around in circles trying to figure out the why and what happen here with printer sharing. Since installing OneCare on both desktop wired and wireless laptop, (Windows XP Pro SP 2) can not share printer.

     

    Refresh and view status summary reports on laptop “OneCare failed to install this printer. OneCare will keep trying to install this printer.” Printer is USB connected and printer manufacture’s support insures me that this printer supports sharing.

     

    Both OneCare firewalls in Ports & protocols these are checked for:

    File/Printer Sharing

    ICMP Outbound

    ICMP v4 Inbound

    Network Discovery

    Remote Desktop from local network (subnet)

     

    Also to be sure of the router’s firewall was allowing communication between both pcs. Went ahead and created a rule in the router’s firewall settings to allow between these two pcs, because the laptop is wireless and it didn’t change a thing.

     

    Uninstalled and reinstalled both OneCare, no change. Both computers and printer were on during install of OneCare on both computers each time.

     

    Here is where I am confused, if the hub pc is configured for 2nd pc and shows the hub and the 2nd pc in OneCare Circle, then in Windows XP in My Network Places/View workgroup computers on the hub pc. Shouldn't there be showing the hub pc and the 2nd pc? There not showing there, but on the 2nd pc in My Network Places/View workgroup the 2nd pc shows there.

     

    Steve posted in another topic he would try to get back to me on that question.

     

    OneCare support through email I am not sure what is happening there yet. Anyway, I have run out of what else to think of for this issue. I have been waiting with all my saved information in a folder to send Feed Back, but haven’t been able to because of a Feed Back error on Connect, but will do when can.

    Tuesday, July 24, 2007 6:08 PM

All replies

  • Hi Knightsky

     

    Thanks for trying out printer sharing. We really appreciate it.

    1. Is one of the machine a corporate machined joined to domain by any chance?

    2. What is the OS on the machines?

    3. What is your printer model?

    4. If you go to the machine that has printer attached, open Windows Printers UI and right click on it, do you see any right click menu item with OneCare on it? What is the menu item?

     

    Thanks

    Neeraj

     

     

    Wednesday, July 25, 2007 3:21 AM
  • I have posted further debugging instructions on Wiki at

     

    http://channel9.msdn.com/wiki/default.aspx/OneCare.RemotePrinterInstallDebugging

     

    Please try them out.

    Wednesday, July 25, 2007 6:48 AM
  • Hello NeerajGarg,

     

    Thanks for your reply, 1st question No, Windows XP Pro SP2, Epson Stylus Photo RX620, and Stop Sharing.

     

    Followed your link to channel9 OneCare Wiki and both pcs are configured for Home or Work, turning off phishing filter using the laptop, both pcs turn yellow and there is a action item. Using the hub turn back on phishing filter and now both pcs have no action item.

     

    That's one of the first things I tried doing was manually install the printer on laptop, and still could not print. Today, after looking for more info in Epson manual I found I did miss one important step.

     

     Ok, here is where I am now: On the Laptop, the Epson printer now shows, (before it did not show), shows sharing, right click menu has OneCare icon stop sharing.
     
     Still can't print, after a short time printer has error "This document failed to print"
     
     On laptop refresh OneCare's share printers list, still have error "OneCare failed to install this printer. OneCare will keep trying to install this printer. Correct printer name is in this list.
     

     I am still waiting to hear back from Epson support. Did check routers logs does not appear to be blocking while trying to print. Did't think the router would be, checked anyway.

     

    Did submit a feedback form on this and uploaded two zip files. Since the laptop's zip file was created before this second time manually installing the printer on the laptop. Should I create a new zip and upload that one too?

     

    Thanks

    Knightsky

     

     

     

     

    Wednesday, July 25, 2007 3:54 PM
  • Hello NeerajGarg,

    Have a question if in the Printer's Properties, Ports is checked usb Virtual printer port USB for Epson Stylus Photo RX620 be the reason I can not print from the manage pc? If so, there is my problem.

     

    Thanks,

    Knightsky

    Wednesday, July 25, 2007 5:48 PM
  • Are you using XP Pro on both machines ?

    Wednesday, July 25, 2007 11:56 PM
  • Hello Adnan Bhutta,

    Yes, XP Pro on both machines.

     

    Knightsky 

    Thursday, July 26, 2007 12:20 AM
  •  

    I have posted debugging steps at http://channel9.msdn.com/wiki/default.aspx/OneCare.RemotePrinterInstallDebugging

    Please try them and let us know which step does your setup fails at.

     

    Thanks for your patience and spending time on debugging this with us. We really appreciate it.

     

     

    Thursday, July 26, 2007 6:48 AM
  • Hello NeerajGarg,

    I have already followed all steps in in Remote Printer Install Debugging and have not failed any of the steps. But OneCare still fails to install the Epson Stylus Photo RX620. After refreshing printer list and view status Onecare retrys to install printer and quits after around 3 minutes.

     

    Knightsky 

     

     

     

    Thursday, July 26, 2007 8:25 AM
  •  

    I believe I have found the problem it is that OneCare’s (client) access to the shared printer is not available. Using Add printer Wizard, Wizard fails to show in the list Host pc, when choosing “A network printer, or a printer attached to another computer”, only workgroup name and client pc show in this list.

    This now brings me back to my original question why does the host pc show only the host pc in My Network Places in the View Workgroup Computers option?

    This is the way it’s been since I first installed OneCare 2.0 on both computers.

    Friday, July 27, 2007 10:44 AM
  • Can you please generate the support log by running YOURDRIVE:\\Program Files\Microsoft Windows OneCare Live\OneCareSupport.exe and send it to us.

     

    Tuesday, July 31, 2007 12:34 AM
  • Will do; upload another support log to my submitted bug report on Connect.

     

    Do have a strong feeling that client pc is being block from accessing the printer, which now has been reinforced by the fact the client pc also can not find the USB external hard drive. The drive is connected to the host computer and is turn on and is recognized by the OS and has plenty of free space and shows to be shared.

    1)      Now I am getting this (both computers are on): On client pc In My Network Places,  (icon has disappeared), click on View Workgroup, system becomes busy, than Error: My Network Places

    2)      “Workgroup is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find if you have access permissions. The list of servers for this workgroup is not currently available.

     

    And this maybe off topic but I feel this is also part of the picture here. Concerning the external drive connected to the host pc I can not do a manual backup either.

    1)      This is the error I am getting: Windows Live OneCare Backup

    2)      Backup can not continue

    3)      OneCare could not backup files to the network share because the current user does not have write permissions. Pleased log on as a user with write permissions to share, and then try running backup again.

    I am the only *person* user account, on this computer.

     

    I am beginning to wonder if the wireless card installed in the host computer, it is disable. Could contribute to this picture of the problems I am experiencing. Because in my theory the WLAN card utility manages the wireless network for the client pc and the host (desktop) is wired. Hence, they may be viewed as on two separate networks by OneCare or XP PRO?  I have to test this theory out after I configure the wireless router’s firewall to allow communication between both pcs that are now wireless.  

     

     

    Tuesday, July 31, 2007 5:30 AM
  • I am not really sure about workgroup error you mentioned.

     

    I am assuming both PC's are connected to the same router directly i.e. via wire or wireless connection. Some people add a wireless router in front of wired router. That can cause problems in home environments.

     

    Assuming that is the case, please try the following:

    1. On the host computer,

      • Start> type cmd.exe to get command prompt. > Type hostname and get the result to see hostname of this machine. Let's say the name was ABC_PC1
      • Open OneCare UI>Change Settings>Firewall Tab>
        • Enable ICMPv4 Inboound.
        • Enable "Internet File Sharing"
        • Enabling these rules is okay if you are behind a router unless you are using tunneling or port forwarding, which mose users don't.
        • Hit enough OK to close dialogs.
      • Create a file share if you don't have one (Select any folder, right click and select share...)
      • On the folder that you have shared, right click on it and select properties
      • Select the "sharing tab" if is visible, if it is not visible, let us know.
      • Select permissions
      • See if you deny permissions on the file share for Guest account, if so delete all permissions for guest account, by default

    3. From the client computer, open a command line window and type "ping ABC_PC1". Replace ABC_PC1 with the actual name of your computer.

    4. If ping does not get any response, for some reason your home networking configuration is not working.

    5. If ping works, type in \\ABC_PC1 in your explorer window. See if that works and shows you the other PC and resources on it.

     

    Thanks

    Neeraj

    Tuesday, July 31, 2007 3:58 PM
  • The workgroup error is not accessible on the client pc, leads me to believe that both computers are not part of the same workgroup or maybe because the host computer can not be found.  

     

    Only one router, which is Check Point ZoneAlarm Secure wireless router with subscription base updates. Both computers access the internet through this router.

     

    Yes, I have already come to the conclusion my home networking configuration is not working. An to my understanding that for the basic user there should be no need for them to setup this configuration with OneCare 2.0 to allow printer and backup to external hard drive sharing. Correcting this is what I have been studying what next to do with OneCare 2.0 installed.

     

    Per instructions the results will produce on the client pc “Ping request could not find host (host name) Please check the name and try again.

     

    Because the client pc is wireless and the host is wired to ensure no block would come from there. Without mentioning OneCare 2.0 while using online chat with the Technical support for this router followed their instructions to configure the router to allow communication between both computers, “to allow printer sharing”. In theory this should rule out the router as the reason.

     

    Also in theory that should leave only OneCare 2.0 and the OS, Windows XP Pro SP 2 the source of the issue.

     

    Tuesday, July 31, 2007 6:02 PM
  •  

    Adnan Bhutta

    While uploading support log on Connect varies at what percentage upload stops and then I keep getting IE can not display the web page error. This also happens after clearing Browser History and restarting the computer, will keep trying.

    Tuesday, July 31, 2007 6:13 PM
  •  

    I just love a good mystery, if you search long enough and if the information is out there you will find it.

     

    With so many players in the issue of not being able to share both printer and external hard drive. Sometimes the theory of ruling out one of the players is incorrect, because of lack of important information that does concern ones own issue, so much for some tech support, that’s why I don’t necessarily stop there.

     

    This is what I have found out about my router through its online forum. Apparently the router has an issue “not being able to bridge between both wired and wireless LANS.”  

     

    On the client pc ping the host by its computer name would fail, but ping the host computer by its IP address on the LAN will succeed.

     

    On client pc by going to start>run>enter: \\IPof the host computer click ok, allows the client pc to see the host pc. A window appears with IP address of host computer, shows the printer shared and the folder I created for this test. An added plus, My Networks Places, View workgroup computers now shows the client pc.

     

    Ok, here is where I am now still studying and working on it.

    Wednesday, August 1, 2007 2:25 AM
  • Thanks Knightsky for helping us out there.

    So netbios name resolution is not working in your home network.

    What is the manufacturer/model of your router?

     

    Thanks

    Neeraj

    Wednesday, August 1, 2007 6:54 PM
  • Just re-read your original reply and noticed you have already mentioned the router as Check Point ZoneAlarm Secure wireless router

    Sorry for missing it earlier.

    Wednesday, August 1, 2007 7:01 PM
  • Just email me the zip files from the host and the client at

     

    adnanb at microsoft dot com

     

    Adnan

     

     

    Wednesday, August 1, 2007 7:42 PM
  • Adnan Bhutta,

    Done! By why of my private email account, look in the subject line for Knightsky: Problems with Sharing Printer.

    Hotmail virus scanner had difficulty with so many embedded zip files.

     

    Wednesday, August 1, 2007 8:41 PM
  •  

    Thanks for sending the logs, i looked at it . You are running into 0x80070709 , which is a known issue. We are investigating it.  I will update the thread when i have more data.
    Wednesday, August 1, 2007 8:44 PM
  • NeerajGarg,

     

    Your welcome, actually I am enjoying this, as stated before I love a good mystery, and this has been a challenge and educational, and in the process contributing to feedback that maybe helpful for OneCare 2.0 and any user who maybe experiencing something similar.

     

    Yes to question, concerning my router ZoneAlarm Z100G, does not by default permit access from WLAN to the LAN. This is what I was instructed to do, by online chat with there support tech to enable access, in this direction; create a firewall rule to allow traffic from the WLAN to the LAN. Was not informed that when mapping the network drive, must use its IP address, and not use its name (unless have Microsoft WINS server).

     

    Later found info if having trouble with the rule working, probably needs to open up the NetBIOS port on the firewall of the LAN computer.

     

    To address this issue with the router having difficulty bridging network with a wired pc and wireless pc, would be forthcoming in a software update. Since this info is dated last March, I needed to gather more information before proceeding, from the router’s tech support.

     

    Now that know I am running into a known issue after finally getting those zip files sent. I may still have some sort of configuration concerning my router, even after the issue (0x80070709) is resolved; I have patience can wait.

     

    Thanks,

    Knightsky

     

    Thursday, August 2, 2007 12:00 AM
  • Thought you might like to know, my issue is somewhat solved. With the router definitely solved and with OneCare 2.0 not sure about it, there was a few unexpected reactions from OC during the process. Not sure of what exactly the known issue (0x80070709) is, but at the moment I have successfully printed the first test page and existing document on the client pc using the shared printer.

     

    I went ahead found and used in the router, bridged the LAN and WLAN network, and using the instructions that I found from the online knowledge base for this router to be sure I did it right, then restarted the computers. OneCare’s behavior to double the network in Network Connection tab, and configure one of them as public and not connected, has been a nuisance from the first install. Can interfere having the same network name in two different assign locations and with one not connected.

     

    In client pc refresh printer list as OneCare found the printer, installed it and offered a button to print a test page. When this was done I still had the Share Printers-Windows Live OneCare, The printer list has been refreshed window open and it still stated OneCare failed to install this printer. I think OneCare is contradicting itself.

     

    Also during OneCare’s install of the printer, the firewall pop-up (I like this being informed, otherwise I would not have known) asking to allow, block etc. SAgent4 went ahead an allowed because had somewhat of an idea of what it is.

     

    The other thing that is strange is in both host and client computers in My Network Places, View workgroup computers, is only the host computer icon. Wondering what happen to the client pcs icon and I am not sure where this is coming from.  

     

    Find this interesting that I have two of the same printers in Printers and Faxes window and in the taskbar. I almost think OneCare likes to double things.

     

    Still need to test the shared external hard drive, but I am printing now.

     

    Have saved two new support log zip flies after all of this was done should they be needed.

     

    Knightsky

     

    Thursday, August 2, 2007 8:48 AM
    • Thanks and Congratulations for getting it to work!
    • Error 0x80070709 is related to the netbios name resolution broken because of the router. So, you should not be seeing that anymore.
    • Duplicate Connections: I am not sure about the issue of "double the connection in connections tab". Can you please send us a screenshot? After you do that, please do the following Settings>Firewall>Advanced>Network Connections>Delete All. Please let us know if the duplicate connection is added again.
    • OneCare contradicting itself: What probably happened is that it failed once and you saw the failure. We automatically retry and succeeded later. I can see how it is confusing. We will try to see if we should close the sync report as soon as information in it is outdated.
    • Duplicate Printers: Can you please send us a screen shot showing duplicates?

    PS: You can send the information above via connect website

     

    Thanks

    Neeraj

     

     

     

     

    Saturday, August 4, 2007 6:47 PM
  • NeeraGarg,

     

    Have filed a bug report concerning the dulicate network connections and have added what else I have found. While looking into this further on the client pc. Uploaded 6 jpeg files, 1 of the files is while temporary disabling the Dell Wireless WLAN Card Utility and using Windows XP to manage the wireless connection, to test if I would continue to have the same results and I did.

     

    Thanks,

    Knightsky

    Sunday, August 5, 2007 3:42 PM
  •  

    Thanks

    Neeraj

    Monday, August 6, 2007 5:27 AM