locked
Not all Communicator users can invite anonymous participants RRS feed

  • Question

  • Hi,

     

    After enabling some users for Unified Communications we have anabled most of the the functionalities for our Office Communicator test users  (federation, IM and enhanced presence). Users can always call each other internally using the SIP id's.

     

    In my case I am able to call every phone number. Even when I start a conference I can invite other people by entering external phone numbers ( I can enter a number in the invite box and click on OK to dail).

     

    But some users can not invite external callers. I'm not sure if I have enabled all functionalities but as far as I know the other users have the same rights as me.

     

    I was seeing that you can set allow "anonymous participents" in the global properties at forest level in the OCS mmc console. Every user should be allowed to invite anonymous participants. Why is it that some users can still not do this?

     

    Please advice.

     

    Cheers,

     

    Thomas

    Tuesday, July 24, 2007 6:43 PM

Answers

  • This post will be continued here:

    http://forums.microsoft.com/Ocs2007publicbeta/ShowPost.aspx?PostID=1593644&SiteID=57
    Saturday, July 28, 2007 5:47 AM

All replies

  • In the communicator log I can find the following. How can I autorise this user?

     

    RequestUri: sip:+31xxxxxxxx@sgtiocs.nl;user=phone

    From: sip:xxxxxxxx@xxxx.nl;tag=24e169a88a

    To: sip:+31xxxxxxxx@sgtiocs.nl;user=phone;tag=3B88C781677D98F31C7561EDC4F499E3

    Call-ID: c902f8c978c1464db9ed7339a25161d5

    Content-type: application/sdp

    v=0

    o=- 0 0 IN IP4 192.168.1.110

    s=session

    c=IN IP4 192.168.1.110

    b=CT:10980

    t=0 0

    m=audio 20096 RTP/AVP 114 111 112 115 116 4 8 0 97 101

    k=base64:uNsIYSpPwx19Of/JnhYZzvBmGk2vsBwUnSxFq7oCovh9WXzBZFRChxCK03ZH

    a=candidate:8bzltpvDYs5BgB8P5bCTQKZtPKskkuDl6empyo9sbR0 1 cxaxzVXAf2p1mNY5aytfHA UDP 0.890 192.168.49.1 61568

    a=candidate:8bzltpvDYs5BgB8P5bCTQKZtPKskkuDl6empyo9sbR0 2 cxaxzVXAf2p1mNY5aytfHA UDP 0.890 192.168.49.1 36736

    a=candidate:JBt03iXD4TxuUU5knaPLV/YGiWy+TkKvi2kJRR/d8rs 1 41sLwswheTIVr07g2OzlNg UDP 0.900 192.168.80.1 43264

    a=candidate:JBt03iXD4TxuUU5knaPLV/YGiWy+TkKvi2kJRR/d8rs 2 41sLwswheTIVr07g2OzlNg UDP 0.900 192.168.80.1 7552

    a=candidateSurprisedbJWhLdvL2zeFchaU83jKP2dRLApZGvH2s0GWOyiQU 1 XxoxWrcJYT6Ww7IXjHSS+w UDP 0.900 192.168.1.110 20096

    a=candidateSurprisedbJWhLdvL2zeFchaU83jKP2dRLApZGvH2s0GWOyiQU 2 XxoxWrcJYT6Ww7IXjHSS+w UDP 0.900 192.168.1.110 45056

    a=candidate:LsInyFgOMUqSgn+lELcvy0y3A4fyc1pW5FADj4OlPK0 1 CRxTQFTZgKGM0DSCwBQsrg TCP 0.190 10.20.30.10 56807

    a=candidate:LsInyFgOMUqSgn+lELcvy0y3A4fyc1pW5FADj4OlPK0 2 CRxTQFTZgKGM0DSCwBQsrg TCP 0.190 10.20.30.10 56807

    a=candidate:J4ULfXmN5GlPFwmDijCQol3fb4Qb6vf/+IEVrHa+fxI 1 Wiu7mM/oNIQD1/Jps6gefg TCP 0.250 83.86.225.41 11264

    a=candidate:J4ULfXmN5GlPFwmDijCQol3fb4Qb6vf/+IEVrHa+fxI 2 Wiu7mM/oNIQD1/Jps6gefg TCP 0.250 83.86.225.41 11264

    a=cryptoscale:1 client AES_CM_128_HMAC_SHA1_80 inline:ImW90Y/COkLSklDtl8kyDzIFQGOYJfS8JFBdae93|2^31|1:1

    a=crypto:2 AES_CM_128_HMAC_SHA1_80 inline:QJ9mFCccvpLL0ArkJUVqucY1kXXYvoLxNnLD7oSO|2^31|1:1

    a=maxptime:200

    a=rtcp:45056

    a=rtpmap:114 x-msrta/16000

    a=fmtp:114 bitrate=12000

    a=rtpmap:111 SIREN/16000

    a=fmtp:111 bitrate=16000

    a=rtpmap:112 G7221/16000

    a=fmtp:112 bitrate=24000

    a=rtpmap:115 x-msrta/8000

    a=fmtp:115 bitrate=12000

    a=rtpmap:116 AAL2-G726-32/8000

    a=rtpmap:4 G723/8000

    a=rtpmap:8 PCMA/8000

    a=rtpmap:0 PCMU/8000

    a=rtpmap:97 RED/8000

    a=rtpmap:101 telephone-event/8000

    a=fmtp:101 0-16

    a=encryptionSurpriseptional

     

    Response Data:

    403 Forbidden

    ms-diagnostics: 4004;reason="Credentials provided are not authorized to act as specified from URI";source="SOCS0001SEL.sgtiocs.nl"

    Resolution:

    If this error continues to occur, please contact your network administrator. The network administrator can use a tool like winerror.exe from the Windows Resource Kit or lcserror.exe from the Office Communications Server Resource Kit in order to interpret any error codes listed above.

    Tuesday, July 24, 2007 6:52 PM
  • The user that was not able to make external calls from the communicator can do it now. I was playing around with some setings in OCS but there is no clear solutions.

     

    We still have problems with other users. Some of them can still not make external calls (call phobe numbers from there communicator)?

     

    Is this a bug in the public beta of OCS?

     

    Has anyone else experienced this?

     

    I'm curious to know.

     

    Regards,

     

    Thomas

     

    Thursday, July 26, 2007 6:59 AM
  • This post will be continued here:

    http://forums.microsoft.com/Ocs2007publicbeta/ShowPost.aspx?PostID=1593644&SiteID=57
    Saturday, July 28, 2007 5:47 AM