none
WLW Blooger issue with new paragraph.

    Question

  • I'm looking for some help. I have a blog on blogger and I have uploaded a custom template. When I hit the enter key in WLW it doesn't start a new paragraph. 

    The HTML looks likie this:

    <p>
      <p>
        <p>&#160;</p>

        <p> WLW Test.</p>
      </p>

      <p>
        <p> New Paragraph here.</p>
      </p>
    </p>

    <p>
      <p>
        <p> New paragraph here.</p></p></p>

    But this is what's displayed:

    WLW test.New Paragraph here.New paragraph here.

    Does anyone else have this issue?

    Any ideas on what I've done wrong?

    Sunday, February 15, 2009 9:43 PM

Answers

  • Jeremy, your template is specifically requesting that paragraphs be displayed this way:

    .post-body p {
    /* Fix bug in IE5/Win with italics in posts */
    margin: 0px 0px 0px 0px;
    padding: 1px 0px 1px 0px;
    display: inline; /* to fix floating-ads wrapping problem in IE */
    height: 1%;
    overflow: visible;
    }

    I have no idea what problem this is trying to work around, but it might be worth trying removal of this entire block to see if it helps.
    • Proposed as answer by davidkclark Monday, February 23, 2009 8:56 PM
    • Marked as answer by J. Ryan Tuesday, February 24, 2009 9:31 PM
    Monday, February 23, 2009 6:08 PM
    Owner

All replies

  • Whoa, we have definitely never seen that before. Does the problem go away if you turn off "View | Edit using theme"? If so, can you show us your template?

    Thanks.
    Monday, February 16, 2009 6:38 PM
    Owner
  • The problem appears to go away when I turn off "View | Edit using theme" but when I publish the post it puts all the paragraphs back  together in one line.

    You can download the xml here:
    http://cid-077d88a3598d60ee.skydrive.live.com/self.aspx/Public/template-tread29%7C_Feb09.xml.xml


    Tuesday, February 17, 2009 8:49 PM
  • Thanks Jeremy. It would also be very helpful to see an example of such a post that you've published to your blog. Thanks.
    Wednesday, February 18, 2009 6:28 PM
    Owner
  • Hi Joe,
    I have a similar issue also.

    If I have clicked in the WLW window the paragraph nesting is not right. That means if I click at the end of a draft post, or between two paragraphs to insert a new paragraph it does not work. Also, the insert functions (blockquote, lists etc.) do not work properly. - the new container comes up after the insertion point and if you keep typing you add text before the new item.

    You are right in guessing that it is only a problem when editing using the theme. I am using one of the basic blogger themes, I have edited a couple of the images, added a few css classes, that is about it.

    I can email you a dump of my layout if you like. Let me know if that would help - I would certainly like to get the editor fixed... I have a couple of posts on my blog describing the problems that I am seeing.
    Saturday, February 21, 2009 1:15 PM
  • Yes, it would help a lot to see which theme is causing this. My e-mail is joe.cheng *AT* microsoft.com if you prefer to contact me that way. Thanks.
    Saturday, February 21, 2009 7:22 PM
    Owner
  • Template sent via email... Too long / boring to post here. Pretty much just one of the standard blogger templates anyway.
    Sunday, February 22, 2009 7:03 AM
  • Jeremy, your template is specifically requesting that paragraphs be displayed this way:

    .post-body p {
    /* Fix bug in IE5/Win with italics in posts */
    margin: 0px 0px 0px 0px;
    padding: 1px 0px 1px 0px;
    display: inline; /* to fix floating-ads wrapping problem in IE */
    height: 1%;
    overflow: visible;
    }

    I have no idea what problem this is trying to work around, but it might be worth trying removal of this entire block to see if it helps.
    • Proposed as answer by davidkclark Monday, February 23, 2009 8:56 PM
    • Marked as answer by J. Ryan Tuesday, February 24, 2009 9:31 PM
    Monday, February 23, 2009 6:08 PM
    Owner
  • David, yours is similar:

    .post-body p {
    line-height: 1.4em;
    /* Fix bug in IE5/Win with italics in posts */
    margin: 0;
    height: 1%;
    overflow: visible;
    }

    David (not Jeremy), you can either remove this block from your Blogger template and disregard whatever IE5/Win problem this was solving, or you can find your Writer editing template on disk and remove this block from there. (You will have to use WordPad, not Notepad, to do the editing as the hard returns are in UNIX style and won't show up in Notepad.)

    You can find the Writer editing template here:
    %AppData%\Windows Live Writer\blogtemplates\<blog-id>\index.htm

    Monday, February 23, 2009 6:27 PM
    Owner
  • Thanks Joe, works like a bought one!
    Monday, February 23, 2009 8:55 PM
  • Thanks Joe! It worked perfectly.
    Tuesday, February 24, 2009 9:31 PM
  • This is the correct answer!
    Wednesday, April 15, 2009 7:22 PM