locked
Failed to initialize VDS, 0x80080005 RRS feed

  • Question

  • Laptop drive failed, installed new drive (exact same model/size) and am now trying to do a restore.  I have tried 32/64 bit restore, using and not using drivers, manual / auto, formatting with advanced options, check disk...  I am at a lost, any other suggestions for doing a restore... backup not much use if I can't restore...  I assume the error is the VDS thing toward the bottom... is that on the server or the laptop?

    [12/26/2012 15:56:18  1e4] Adding backup set, status=Successful, time=12/19/2012 8:43:16 AM, size=13.16 GB, description=windows 8
    [12/26/2012 15:56:18  1e4] Skipping backup set, index=273, status=2, boxChecked=0
    [12/26/2012 15:56:20  1e4] Calling m_Restore.RequestVolumes
    [12/26/2012 15:56:20  170] PASS :RequestCompleteHandler::Completed succeeded (at func: Request completed, d:\wssg_src\colorado_qfe\backup\pc\client\homeservermanager\homeservermanager.cpp (26)
    [12/26/2012 15:56:20  170] Calling m_Restore.RetrieveVolumes
    [12/26/2012 15:56:20  170] m_Restore.RetrieveVolumes returned 1 volumes
    [12/26/2012 15:56:30  318] Calling PhysicalVolumeInfo::GetAll
    [12/26/2012 15:56:32  318]   Volume: \\?\Volume{995aa446-4fb7-11e2-adf1-806e6f6e6963}\
    [12/26/2012 15:56:32  318]   Volume: \\?\Volume{995aa44c-4fb7-11e2-adf1-806e6f6e6963}\
    [12/26/2012 15:56:32  318] PhysicalVolumeInfo::GetAll returned 2 volumes, filtered to 1 volumes
    [12/26/2012 15:56:32  318] WARN: Volumes changed, new number of volumes=1.
    [12/26/2012 15:56:32  170] Found 4 disk entries
    [12/26/2012 15:56:32  170]   Disk: \\?\PhysicalDrive0
    [12/26/2012 15:56:32  170]   Disk: \\?\PhysicalDrive0
    [12/26/2012 15:56:32  170]   Disk: \\?\PhysicalDrive0
    [12/26/2012 15:56:32  170]   Disk: \\?\PhysicalDrive1
    [12/26/2012 15:56:32  1e4] RestoreHelper::CanDoAutoPartition started
    [12/26/2012 15:56:32  1e4] Found disk:   \\?\PhysicalDrive0
    [12/26/2012 15:56:32  1e4]    Size:      500107862016
    [12/26/2012 15:56:32  1e4]    mediaType: 0xc
    [12/26/2012 15:56:32  1e4] Found disk:   \\?\PhysicalDrive1
    [12/26/2012 15:56:32  1e4]    Size:      4043309056
    [12/26/2012 15:56:32  1e4]    mediaType: 0xb
    [12/26/2012 15:56:32  1e4] No existing partition for volume  (Offset=1048576, Size=500105740288), must flatten disk
    [12/26/2012 15:56:32  1e4] Disk Size=500107862016, Total Source Volume Size=500105740288, CanReuse=0
    [12/26/2012 15:56:32  1e4] Last Volume Size=65539, Last Volume Min Size=18446736380355219568, LastVolumeOffset=65539
    [12/26/2012 15:56:32  1e4] endOfLastVolume=500107837440, modifiedLastVolumeSize=500105764864
    [12/26/2012 15:56:35  1e4] PASS :GetStartDateTimeString succeeded (at func: GetDateTimeFormat, d:\wssg_src\colorado_qfe\backup\pc\bmr\restorewizard\backupsetutils.h (40)
    [12/26/2012 15:56:36  1e4] PASS :GetStartDateTimeString succeeded (at func: GetDateTimeFormat, d:\wssg_src\colorado_qfe\backup\pc\bmr\restorewizard\backupsetutils.h (40)
    [12/26/2012 15:56:36  318] Calling PhysicalVolumeInfo::GetAll
    [12/26/2012 15:56:36  318]   Volume: \\?\Volume{995aa446-4fb7-11e2-adf1-806e6f6e6963}\
    [12/26/2012 15:56:36  318]   Volume: \\?\Volume{995aa44c-4fb7-11e2-adf1-806e6f6e6963}\
    [12/26/2012 15:56:36  318] PhysicalVolumeInfo::GetAll returned 2 volumes, filtered to 1 volumes
    [12/26/2012 15:56:36  1e4] Calling m_Restore.Restore
    [12/26/2012 15:56:36  1e4] ReconnectableStream: Created ClientReconnectableStream for {A8F9C8CB-5480-4D29-8E04-659DCA966890}, sizes 16384,10485760,10485760,16384
    [12/26/2012 15:56:36  1e4] Restore - we are in reconnectable state
    [12/26/2012 15:56:36  1e4] Restore started.
    ERROR: Could not load VDS (0x80080005)
    [12/26/2012 15:57:06  428] ERROR: Failed to initialize VDS, 0x80080005
    [12/26/2012 15:57:06  428] CreateBackupVolumes returned 0x80080005, with 0 volume names.
    [12/26/2012 15:57:06  428] RestoreHelper::T_Restore: Unable to perform automatic partition
    [12/26/2012 15:57:06  428] RestoreHelper::T_Restore: restore complete with return value 536870913
    [12/26/2012 15:57:06  428] ERROR: CDialog_Restore::Completed failed, HR=0x80070001 (at func: CDialog_Restore::Completed, d:\wssg_src\colorado_qfe\backup\pc\bmr\restorewizard\dialog_restore.cpp (88)


    John J. Hughes II

    Wednesday, December 26, 2012 9:07 PM

All replies

  • Hi John.

    As it happens, I just did a bare metal restore to a laptop.  In my experience, this error can occur if the new disk has pre-existing partitions. What worked in my case was to remove all partitions from the target disk using Disk Manager, then allowing the Restore Wizard to automatically select the partitions for restore. 

    When you get to the point in the Restore Wizard where you choose what partitions to restore, select the manual option then run Disk Manager using the Advanced button, delete all existing partitions from the target disk, then close Disk Manager.  Then in the Restore Wizard, click the Back button to return to the beginning, then proceed as normal, this time choosing the automatic restore option. 

    It is not necessary to manually create partitions on the target disk; a raw, unpartitioned disk is all you need. Unless something is wrong on the server, this should allow you to successfully complete the bare metal restore.

    It is best to have no disks plugged into the client system except for the new boot disk and the CD-ROM or USB stick that you used to boot the WHS Restore Wizard.

    • Edited by Gary Voth Thursday, December 27, 2012 5:19 PM
    Thursday, December 27, 2012 5:16 PM
  • Thanks for the response but that did not help either.  I have tried with no partitions (how the drive came), with 1 partition which is the same at the original one (basically the whole drive).  Nothing was plugged in except... there is one hard drive and I was running the CD that came with WHS.  I have even tried drivers and without.

    I have done bare metal restores off this computer, just not a laptop.  Other than one time when one of the backups was corrupt I have never had a problem.


    John J. Hughes II

    Friday, December 28, 2012 12:13 AM
  • Okay John.  Are you able to do a folder-level (not bare-metal) restore any files from the original computer using the Dashboard?  (You can do this from any client computer, not necessarily the target one.)  If not, it might indicate a problem with the client backup database on the server.
    Friday, December 28, 2012 1:32 PM
  • Yes I am able to pull files from the sever.  I used another computer to pull the drivers folder off it, I keep all the install files in a directory on the laptop (bad plan) but that worked fine.  Mostly I would not care too much, just rebuild the machine and copy any working data but!  We have Adobe stuff and maybe other things that are licensed, if I do a restore the license will still be valid otherwise I have to call them and have it removed from their system or I may have to purchase another copy.  Restore backup works better for certain thing.  Normally if I know I am upgrading I would deactivate any license copies.

    John


    John J. Hughes II

    Friday, December 28, 2012 6:41 PM
  • I once had a disk that I had pulled from another system that had been part of a dynamic disk array.  Even though I had deleted all of the partitions on this disk, it was still marked as having a GPT partition style, and I could not use it as a restore target until I figured this out and marked it as MBR using Disk Manager.

    Beyond this, I am at a loss... Perhaps someone from Microsoft who can decipher your log file can chime in.

    It does seem that there are a number of recent threads with people having similar issues lately...

    Wednesday, January 2, 2013 11:46 PM
  • John,

    Holler if you are ready to try this again (BMR)

    The simplest thing to do is to reinstall windows, then boot from the thumb, next,next etc, and manually select what to restore and then just restore c:  Windows does not have to be activated, just installed to properly setup the partitions.

    Do you have any clue if this box is uEFI?


    Grey


    • Edited by Still Grey Friday, January 11, 2013 9:46 PM added stuff
    Friday, January 11, 2013 9:41 PM
  • Grey,

    Will try again this weekend, tried to reinstall, could not get an option change the partitions, format yes, partitions no.  Will try again.

    Yes it is EFI, don't know about the 'u' part but I assume it is also.  I saw in the bios an option to turn it off, that was going to be my next trick, see if I install with it off would Windows require I repartition it.


    John J. Hughes II

    Friday, January 11, 2013 10:18 PM
  • Just installing fresh windows, it should do the partitions for you, don;t worry about creating them.  I have taken uEFI backups and restored to BIOS but it was tricky and I had lots of tools, so I would not suggest changing that.  As I said above, it has been working for me.  I should be available this weekend if you need any help

    Grey

    Friday, January 11, 2013 10:27 PM
  • Not sure if it is me or the system but I am losing.

    Yes it is uEFI

    1) As I said I have tried several version of Win7 restore and the recovery disks that I either made or came with the system but the only options seem to be fix or restore from image. Either one does not let me change much of anything.

    2) after some searching I found the drivers for the RAID so I was able to get to the install part of Win7 but where it will let me format the drives it won't let me change the partitions, anything that looks like it might is greyed out.

    There are 5 part to the logical drive.

    a) ESP (EFI) -- system

    b) diag -- OEM (manufacture stuff for testing the system)

    c) <no name> -- MSR

    d) Recovery

    f) OS

    I still think it is strange that Windows can back itself up to the Home server but the home server can't back up the client.

    By the way do you know if the new Windows server supports GPT?


    John J. Hughes II

    Saturday, January 12, 2013 12:56 AM
  • So Sorry. I have no clue what box you actually have.  When I said reinstall windows I thought that was a simple task.  But if you have a (insert name) that does not come with disc(s)

    Do not worry about searching for drivers.  If you get to the point of restore fails with VDS x00etc you are fine on the drivers.

    Okay, so for now I do not have what you have to play with.  One of those partitions you have has the software to put it back to new.  But that is not what we want any way.  And what have we got to lose?  From what I understand nothing.  Your old drive is dead and your new drive is blank. We can put it back to where it was before it died

    Boot from the thumb

    click next for a while till you get to the screen that says let me or manual

    Hold Ctrl shift and alt till a black screen pops up  X:\windows\sources I think.  No matter a cmd propmpt

    type diskpart and press enter

    should say something like diskpart>

    Type list disk press enter

    It should show 2 disk.

    Drive 0 should be your hard drive and drive 1 should be your thumb

    type select disk 0 and press enter (for fun on a lot of these you can actually type the first 3 letters and it works sel dis 0 )

    I am typing from memory, I will make a video :) I think it will say disk 0 selected

    now type clean and press enter

    Now just for me cause I know it works, type convert gpt and press enter.  Think it sya converted

    now type create partition primary sixe=300  enter

    type format quick fs=ntfs label="recovery"

    type create partition efi size=100  enter

    format quick fs=fat32 label="System" enter

    create partition primary

    format quick fs=ntfs label="Windows"

    type exit and enter exit and enter and the black screen goes away.

    Now I forget :(  I am pretty sure you select "I will pick what to put where"

    It should present 2 good choices. small to small and rest to rest.  (will make sense if that is what you see)

    click next.  You will prob get a box that says you already had a boot something, we recomend you click yes.  Click yes.  It will go boggety boogety and end up with succesfull, click finish.

    Click it it will reboot and work.  If not I will refund your money.


    Grey

    Saturday, January 12, 2013 1:27 AM
  • Grey,

    First of all thanks for your help, educational if nothing else.

    Ok, I don't think you need to make a video but if you want :)  Your direction were clear enough.

    The problem I had before with the disk part was in deleting the volumes, "Clean" fixed that so I  managed to successfully "Clean" and "Convert GPT" and then create the new partitions. yea

    Then I restored the backup which was an image and it reset the partitions back to the way they were so fail -- boo

    Now I think we have a slight misunderstanding:  first of all, the computer works fine, new computer, new disk, everything is functional and great. BUT I can't backup using windows home server, normal image backup (and restore it seems) work fine.

    It is my understanding that the problem is Windows Home server does not know how to backup a GPT drive so what I am trying to do is convert "FROM" GPT "TO" MBR I guess.

    Not sure but I guess I can do a "convert MBR"?  I also need to do a non-image backup I guess so I can just restore drive C if that is possible and still allow it to boot.

    Oh well revisit it tomorrow, getting tied and doing dumb things...

    Oh it is a Dell Alienware for what it is worth.


    John J. Hughes II


    Saturday, January 12, 2013 2:39 AM
  • From WHS2011 Release Notes:

    The Windows Home Server 2011 client computer backup features do not support the use of GPT hard disks

    If a client computer is running Windows Home Server 2011, and it has a hard disk that is configured to use the GUID Partition Table (GPT) format, you cannot use back up or restore data from the operating system, individual files, or folders on that computer. However, you can restore individual files or folders from other computers to a client computer that uses GPT formatting.

    In the event that a client computer is configured to use GPT hard disks, you must employ an alternative method to back up or restore that computer.


    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.

    Saturday, January 12, 2013 3:21 AM
  • Phill, you are so wrong :)

    Un edited way to long, but worth a laugh

    it was too big :( so the upload did not take


    Grey


    • Edited by Still Grey Saturday, January 12, 2013 2:16 PM
    Saturday, January 12, 2013 3:25 AM
  • Okay, I vote for on hold till tomoorow :)

    Grey

    Saturday, January 12, 2013 3:37 AM
  • "This video is currently being processed."!!

    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.

    Saturday, January 12, 2013 3:39 AM
  • Yes :)  at least the link worked.

    I only have slow dsl upload.  It says 20 mins left

    Thank you for looking/trying.

    It works for me/as in the video.  If you have the resources to test it, let me know.

    Thanks for all upur posts/all you do to help folks !!


    Grey

    Saturday, January 12, 2013 3:48 AM
  • Grey,

    Will be happy to test it but "The video you have requested is not available.", plan B?


    John J. Hughes II

    Saturday, January 12, 2013 1:22 PM
  • I will have to redo my video, but if you have the proper partitions now, you should just be able to manually select c: to c: and it should not change the partitions.

    Grey

    Saturday, January 12, 2013 2:19 PM
  • Grey

    I am able to restore the PC I am not able to backup the PC with WHS, are you saying WHS can backup a GPT drive?


    John J. Hughes II

    Sunday, January 13, 2013 2:47 AM
  • I know it's a bit old now but I have been having the same issue all afternoon, I had tried this and several other solutions none of which worked.

    Eventually I discovered that this is a known Microsoft issue and they have a work around...... here is the link:

    http://social.technet.microsoft.com/wiki/contents/articles/16126.client-bare-metal-restore-fails-due-to-vds-drive-initialization-fails.aspx?CommentPosted=true#commentmessage

    Friday, November 8, 2013 9:12 PM