locked
Guest Account: Permission Denied on Client PCs RRS feed

  • Question

  • I've got the WHS Server all set up, and installed correctly.  I have the Guest account enabled, with no password, and Full rights to all the shares.  On both my personal desktop (XP Pro) and my laptop (XP Pro), if I try to access the shares, I get:
    ---------------------------
    Murali-Server
    ---------------------------
    \\Murali-Server\Public is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.



    Access is denied.


    ---------------------------
    OK  
    ---------------------------

    I've got the following plug-ins:
    MyMovies for Windows Home Server
    Windows Home Server Disk Management Add-In

    I'm not sure what the problem is at all.  I can share files between the Desktop and Laptop without an issues, so I don't think its the network.  I've tried disabling the WHS firewall, but to no avail.  I've disabled and re-enabled the Guest account, and still no go.  Tried changing the permissions, and still didn't work.

    Any suggestions?
    Tuesday, December 30, 2008 12:06 AM

Answers

  • I ended up reinstalling WHS and it seems to work fine.

    The reason I ended up choosing to just reinstall WHS is because the VPN I had set up for it was also acting screwy... a complete reinstall and everything seems to be good now.

    I have no idea what was originally wrong... but at least it works now.

    Thanks everyone for the help.
    Tuesday, December 30, 2008 6:39 AM

All replies

  • Do both the desktop and the laptop also have user accounts that are associated with the WHS?  If they do, then those accounts also must be granted access to any shares that you want them to have access to.
    Reason:
    When a computer first attempts accecss to a share on the server, the account that's being used is first run against the list of WHS accounts.  If there's a match, then those credentials are used to grant (or deny) access to a given share.
    If there isn't a match, then the account is granted Guest access (if that's enabled.)

    HTH,
    Chris
    [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Tuesday, December 30, 2008 12:14 AM
  • Chris Cupler said:

    Do both the desktop and the laptop also have user accounts that are associated with the WHS?  If they do, then those accounts also must be granted access to any shares that you want them to have access to.


    Hey Chris,

    The account I use to log into the desktop and laptop doesn't exist on the WHS Server.

    Any other suggestions?

    Thanks for any help :)
    Tuesday, December 30, 2008 12:18 AM
  • Did you reboot the WHS after changing the privs on Public?

    When you said that you 'tried changing the permissions', did you do that thru the Console, or directly on the shares (by logging in to the WHS via Remote Desktop)?
    [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Tuesday, December 30, 2008 12:32 AM
  • I tried doing it both via the Console and manually on the shares and no luck.

    I just rebooted, and still getting the same error.
    Tuesday, December 30, 2008 12:44 AM
  • MuraliRath said:

    I tried doing it both via the Console and manually on the shares and no luck.

    I just rebooted, and still getting the same error.


    Part of the problem may be the fact that you manually changed the permissions on the shares.  What do the permissions currently show on your shares?
    Tuesday, December 30, 2008 5:22 AM
    Moderator
  • I ended up reinstalling WHS and it seems to work fine.

    The reason I ended up choosing to just reinstall WHS is because the VPN I had set up for it was also acting screwy... a complete reinstall and everything seems to be good now.

    I have no idea what was originally wrong... but at least it works now.

    Thanks everyone for the help.
    Tuesday, December 30, 2008 6:39 AM