locked
Remote Connection Problem RRS feed

  • Question

  • I am having trouble accessing my Windows Home Server from outside my network.  I believe my ISP (Verizon DSL) is blocking TCP port 80.  I have called them, but they said that it would violate their terms of service to unblock this port.  So, I was wondering if there is any other way to access my Windows Home Server from outside my network?  I was also wondering if Comcast and Verizon Fios block TCP port 80? 

     

    This is the what the configuration on Windows Home Server says:

     

    Router Details: 

     

    Ok - Verifying your router supports UPnP

    Ok - Configuring your router

    Ok - Verifying your website is available on your home server

    Ok - Verifying Remote Access is available on your home server

    Failed - Verifying your router is accepting Web site connections

    Failed - Verifying your router is acceptiong Remote Access connections

     

    Doman Details:

     

    Ok - Verifying your Internet connection to Windows Live

    Ok - Updating Windows Live Custom Domains

    Failed - Verifying your Web site is accessible form the Internet

    Failed - Verifying Remote Access is accessible from the Internet

    Ok - Verifying Windows Live Custom Domains records

     

    Sunday, January 6, 2008 11:02 PM

Answers

  • Windows Home Server uses three ports for the Remote Access web site: 80, 443, and 4125 (all TCP). Port 80 is optional; you can access your server on port 443 if 80 is blocked. However, 443 and 4125 are not optional. Both ports must be open for you to use all features of the Remote Access web site.

    You can use a site such as Shields Up! to determine if those ports are open for you. You may be able to obtain a different service plan from your ISP that allows servers (the main reason for blocking those ports). I will warn you that it will probably be a business plan, and will likely be more expensive.
    Sunday, January 6, 2008 11:40 PM
    Moderator
  •  Tech Pro wrote:

    I went to Shields Up, and it said that ports 80, 443, and 4125 were stealth.  I also do not have McAfee, and I did try this test with my firewall off.  Does this mean that my ISP is blocking those ports? 

    Before I say absolutely that that's the case, have you manually forwarded those ports to your WHS PC in your router's configuration tool, or are you using the UPnP tool in WHS? I would recommend turning off UPnP in your router and forwarding the ports manually if you haven't already done so, then trying again.

    But most likely your ISP is blocking those ports.

    Edit: to answer your additional questions, most likely Verizon blocks those ports for FiOS users as well (I don't know, because I can't even get DSL, never mind fiber to my doorstep), and in my area Comcast doesn't block any ports.
    Thursday, January 10, 2008 4:56 PM
    Moderator
  • Hi Ken,
    I've had my MHS for a couple of months and I haven't been able to get the remote access working.  I've tried everything.  I went to Shields UP and it says my ports are "stealth".  I'm not sure what that means. I went to my router and changed the settings to "open" ports 80, 443, and 4125 but it still shows "stealth".  I called my ISP (Verizon) and they keep saying they don't block ports (after a 48 minute phone call).  Any other suggestions?
    Stealth means that those ports are unviewable from outside your LAN.  Either your port-forwarding isn't done correctly, your server firewall is misconfigured, or your ISP is blocking ports.  Also, please start your own thread (instead of adding to one that is 2 years old).
    Saturday, January 9, 2010 4:56 PM
    Moderator

All replies

  • Windows Home Server uses three ports for the Remote Access web site: 80, 443, and 4125 (all TCP). Port 80 is optional; you can access your server on port 443 if 80 is blocked. However, 443 and 4125 are not optional. Both ports must be open for you to use all features of the Remote Access web site.

    You can use a site such as Shields Up! to determine if those ports are open for you. You may be able to obtain a different service plan from your ISP that allows servers (the main reason for blocking those ports). I will warn you that it will probably be a business plan, and will likely be more expensive.
    Sunday, January 6, 2008 11:40 PM
    Moderator
  •  

    Thanks for the advise, but I still cannot access my Windows Home Server remotely.  I called my ISP, and they said that the ports were open.  I had another thought which was that maybe my internet connection speed isn't fast enough to remotely connect to my Windows Home Server.  I have internet connection speed of 768 Kbps /128 Kbps.  Is this enought to remotely access my Windows Home Server?
    Thursday, January 10, 2008 3:38 AM
  • You should be able to use the Windows Home Server remote access features even through a dialup connection (one that's permanently nailed up, of course...) Connection speed will affect the quality of your experience with remote access, but a slow connection won't normally completely block it.

    You should use the site I mentioned above and verify for yourself which of 80, 443, and 4125 are actually open. Your ISP's front-line tech support may not know the answer to the question.
    Thursday, January 10, 2008 4:59 AM
    Moderator
  • If you are using the McAfee firewall supplied by Verizon, you will need to configure it to open the ports you need, under firewall advanced options.

     

    Thursday, January 10, 2008 5:13 AM
  • I went to Shields Up, and it said that ports 80, 443, and 4125 were stealth.  I also do not have McAfee, and I did try this test with my firewall off.  Does this mean that my ISP is blocking those ports? 

    Thursday, January 10, 2008 4:05 PM
  • Verizon is known for squeezing every buck from the consumer. you might wanna go to cable if its in your area. optimum is a good choice they give you all those features at no extra cost.
    Thursday, January 10, 2008 4:44 PM
  • Does Comcast block ports 80, 443, and 4125 because Comcast is the only cable provider in my area?  Also, does Verizon Fios (fiberoptic) block these ports because I am thinking about upgrading to Fios?

     

    Thursday, January 10, 2008 4:48 PM
  •  Tech Pro wrote:

    I went to Shields Up, and it said that ports 80, 443, and 4125 were stealth.  I also do not have McAfee, and I did try this test with my firewall off.  Does this mean that my ISP is blocking those ports? 

    Before I say absolutely that that's the case, have you manually forwarded those ports to your WHS PC in your router's configuration tool, or are you using the UPnP tool in WHS? I would recommend turning off UPnP in your router and forwarding the ports manually if you haven't already done so, then trying again.

    But most likely your ISP is blocking those ports.

    Edit: to answer your additional questions, most likely Verizon blocks those ports for FiOS users as well (I don't know, because I can't even get DSL, never mind fiber to my doorstep), and in my area Comcast doesn't block any ports.
    Thursday, January 10, 2008 4:56 PM
    Moderator
  • I tried manually configuring my router, and I was still not able to access my Windows Home Server.  So, it looks like it is time to switch from Verizon to Comcast.  Thanks for all your help!

     

    Thursday, January 10, 2008 5:06 PM
  • Hi Ken,
    I've had my MHS for a couple of months and I haven't been able to get the remote access working.  I've tried everything.  I went to Shields UP and it says my ports are "stealth".  I'm not sure what that means. I went to my router and changed the settings to "open" ports 80, 443, and 4125 but it still shows "stealth".  I called my ISP (Verizon) and they keep saying they don't block ports (after a 48 minute phone call).  Any other suggestions?
    Thursday, January 7, 2010 3:39 PM
  • Hi Ken,
    I've had my MHS for a couple of months and I haven't been able to get the remote access working.  I've tried everything.  I went to Shields UP and it says my ports are "stealth".  I'm not sure what that means. I went to my router and changed the settings to "open" ports 80, 443, and 4125 but it still shows "stealth".  I called my ISP (Verizon) and they keep saying they don't block ports (after a 48 minute phone call).  Any other suggestions?
    Stealth means that those ports are unviewable from outside your LAN.  Either your port-forwarding isn't done correctly, your server firewall is misconfigured, or your ISP is blocking ports.  Also, please start your own thread (instead of adding to one that is 2 years old).
    Saturday, January 9, 2010 4:56 PM
    Moderator