locked
Client Backup Not Working RRS feed

  • Question

  • Hi,

    I have managed to get my client (Windows 7 Ultimate laptop) backing up it's two bitlocker encrypted HDDs however I have had to use the 3rd part add-on 'Lights On' to do this. If I use the WHS2011 backup method the client machine doesn't wake up from sleep and start the backup however using Lights On it works fine - the client machine wakes from sleep mode, performs the backup and then goes back to sleep.

    I have tried to move the backup window to a time when I can monitor it myself and the backup job doesn't seem to start even when the laptop is on. Also I have already checked the backup options and it is set to wake up the client for backups. 

    Does anyone know what could be causing this and how to fix it?

    Thanks.

    Monday, August 22, 2011 2:10 PM

All replies

  • ...] If I use the WHS2011 backup method the client machine doesn't wake up from sleep and start the backup [...

    Additional remarks you probably know:

    • WHS will not backup a client that is on battery power? So make sure you have your laptop connected to the power?
    • Also the laptop must be in "sleep" mode for it to "wake" up (i.e. do not power it down?).

    - Theo.

    Btw: Does the laptop wake from other events like using the keyboard or mouse?


    No home server like Home Server


    Monday, August 22, 2011 8:07 PM
  • Thanks for replying Theo.

    Yes the laptop is in sleep mode and it is in a docking station and powered.

    The laptop doesn't wake from using the keyboard and mouse. I press the power button to bring it back up. Will this make any difference?

     

     

     

     

    Monday, August 22, 2011 9:03 PM
  • Hi,
    That fine. As long as it is able to wakeup properly.

    FYI: I think Lights On wakes you laptop by sending a Wake On LAN (WOL) packed to your laptop. So waking up is initiated by the server.
    Windows Home Server does not use WOL. In stead it "programs" an event on the laptop to wake it. That's probably why for you Lights On wakeup works and default WHS does not. So I would say something is preventing the WHS set event to wake up the machine. Could be the OS somehow does not handle the wakeup event or else some power setting prevents it from activating a wake up.

    Hard to say what is worng. I can only give you a hints to check out the basic setting.
    Please check the advanced settings under power soptions->change plan settings->change advanced power settings. Make sure to select the correct power plan (currect power plan is marked "Active).

    Under "Sleep", is the "Alow wake timers" enabled?

    You may additionally want to check this by starting a "cmd" box running as "administrator":
    At the prompt type "powercfg -q | more".

    In the output shown (you may have to scroll down by pressing space) additionally check the "Allow wake timers" settings wich should look something like this:

      Power Setting GUID: bd3b718a-0680-4d9d-8ab2-e1d2b4ac806d (Allow wake timers)
       Possible Setting Index: 000
       Possible Setting Friendly Name: Disable
       Possible Setting Index: 001
       Possible Setting Friendly Name: Enable
      Current AC Power Setting Index: 0x00000001
      Current DC Power Setting Index: 0x00000001
    

    Above you see two settings (index 000 and 001) and there allocations to AC (=mains power) and DC (=battery power).
    In th example for AC Power sttings index 001 is active = enabled.

    - Theo.


    No home server like Home Server
    Tuesday, August 23, 2011 8:38 PM
  • From what I have read in the Lights On help it works with wake timers as WOL isn't supported by most wireless cards - it's greyed out on my Intel wireless NIC settings. 

    I have checked both settings and Allow wake timers is enabled for AC however I will try and remove Lights On completely and see if that has any affect as multiple wake timers may be confusing it.

    Wednesday, August 24, 2011 12:23 PM
  • HI Randalc1,

    curious if you learned any more about WHS 2011??  

    I had the same experience with WHS 2011 and LIghts Out as you did.  I have 2 HP DV7 Windows 7 laptops.  The laptops are configured to sleep when lid shut and they are connected to power cable all night.  They are ONLY connected wirelessly, no direct ethernet connection.  I have disabled hibernate via powercfg.exe -H OFF -> but I don't think that matters.

    When I had just WHS 2011 installed, the laptops would never backup automatically.  If the laptops were awake, I could manually initiate a backup from WHS 2011 and it would work.    If the laptops were in sleep or standby mode, I could not initiate a backup from WHS 2011.  Also, the laptops would NEVER get backed up automatically via WHS 2011 overnight.   I flailed at this for a couple weeks, learning Event Logs, Task Scheduler, Wake Timers, ACPI, powercfg.exe etc.

    When I installed Lights Out, 1.5.1.1656 -> I configured the backups to start at specific times for the laptops.  And when LIghts Out controls the backups, they work automatically overnight!!!!!!  I see that the laptops are in standby mode and then LIghts Out wakes them up and starts backup.  Finally, 6 weeks after screwing around with this stuff way more than I wanted to.

    And to confirm, what LIghts Out developer posted in another forum ...

    Lights Out uses Wake Timers to wake up laptap via Task Scheduler.  It does NOT use WOL commands from server to client.  Not clear how WHS 2011 initiates client backups at night.  But however they do it, it doesn't work for HP Windows 7 Laptops that are connected wirelessly.

    Lights Out is excellent.  Purchased the license, and developer is always posting.  Outstanding work.


    Todd

    Friday, February 17, 2012 4:22 AM