none
Can't update or delete rows that are created in another replica RRS feed

  • Question

  • Hi,

    I have tried to connect a built in SqlSyncProvider with a standard custom provider. Because of some compatibility issues (the sql provider is not easily connencted to a non-RelationalSyncProvider provider beacuse it uses a DbSyncContext object), I needed to change the data format and provide a DataRetriever to the Sql provider, similar to what is done in the ContactSyncSample (it contains a SqlCeProvider that syncs with a custom GenericSyncProvider).

    The problem that I'm facing is:

    First, I insert a row in a sql database and synchronize with the custom replica. Both replicas are fine.

    After that I delete or update that same row in the custom replica, and after syncing the change is not present in the sql replica. All other insert/update/delete combinations work fine.

    Can anyone give me a hint on how this problem can be solved?

    Wednesday, September 7, 2011 4:48 PM