locked
Large Files and Deleted Files sync issue RRS feed

  • Question

  • After the Live Mesh clean up tool was run on my account, all but 6 files synced properly.  I went through my folders, deleted those files and attempted to remove all traces that Live Mesh could recognize (clearing the holding area, etc.). Then I re-added the files with sync issues to their original folder locations. 

    Live Mesh seems to be working fine now, except for one large (2MB) excel file that I tried to put back.  Every time I add it (with the original file name) back to its original folder, live mesh deletes it and keeps it in the holding area on both computers.  However, if I rename the file, or move it to a different location, live mesh syncs it fine.

    Also, I have two 60MB quickbooks files that are updated from one computer, but have not synced with the other computer ever since I installed live mesh (about three weeks ago).  Both computers have been online this whole time and have broadband upload speeds of 1 Mbps (6 Mbps down). I do not sync with the Live Desktop.

    Any thoughts on why this is happening or what I could do about these 3 file sync issues?

    I'm so close to having a perfect sync of 36,000+ files (50GB) between two computers.  I started out with roughly 500-600 files that didn't sync properly, and now I only have 3 files won't sync properly. Keep up the good work Live Mesh team!!
    Monday, September 29, 2008 3:54 PM

Answers

  • Hi,

    Josh - I'm very glad to hear that the cleanup tool worked to resolve almost all of your conflict issues.  We'd like to figure out what's going on with those remaining three, though.  If you could send your Live Mesh logs to lmprev@microsoft.com and describe the issue as you have here, we can have someone take a closer look.

    Tony - If I understand correctly, you have just one file that isn't syncing properly?  What type of file is it (there are certain file types that Live Mesh doesn't work with)?  If you'd like us to look into it, please feel free to send your logs to lmprev@microsoft.com as well.

    Thanks,

    Ben.
    Monday, September 29, 2008 6:32 PM
  • Hi all,

    Please note that the issue reported by Tony above continued in this thread.  If you are hitting a similar problem, please see that thread for more details.

    Thanks,

    Ben.
    Wednesday, October 8, 2008 3:19 PM

All replies

  • Hi Josh - I've got exactly the same problem.

    I've not filed a bug yet cos I'm still playing. The conflict happens in the same way as yours, but the conflict dialogue tends to take 10 minutes or so to appear.

    Mine is actually a file that is locked most of the day - it is written to every 10 minutes or so, and therefore it's essential that I don't let it get moved, or a new one will be opened.

    Today, I've left the piece of software that runs it (a Live Messenger plugin) turned off, so it's moved the file and is giving me conflicts on it, and am responding to every conflict dialogue I get, just to see if maybe there are tons of versions.

    As a matter of interest, you can't see the "holding area" properly - it often looks empty but isn't. Mesh hides the files, but not in a way that you can look at them. I found this out by doing a search for the conflicted file, and seeing something odd - three versions with exactly the same name, in the same location, which isn't possible.

    When I clicked "open file location", I was taken to something with the title "recycle bin", with all the files given different names, the way they are in a normal recycle bin. So, Mesh does one of those file manipulation things that isn't open to user intervention.

    So, for now I'm gonna continue responding to the file conflicts, just to see. But if anyone has any ideas, I'd be grateful.
    Monday, September 29, 2008 6:11 PM
  • Hi,

    Josh - I'm very glad to hear that the cleanup tool worked to resolve almost all of your conflict issues.  We'd like to figure out what's going on with those remaining three, though.  If you could send your Live Mesh logs to lmprev@microsoft.com and describe the issue as you have here, we can have someone take a closer look.

    Tony - If I understand correctly, you have just one file that isn't syncing properly?  What type of file is it (there are certain file types that Live Mesh doesn't work with)?  If you'd like us to look into it, please feel free to send your logs to lmprev@microsoft.com as well.

    Thanks,

    Ben.
    Monday, September 29, 2008 6:32 PM
  • Hi Ben.

    It's an XML file - the Messenger Plus! extension plonks all your sign-ins etc. into one file.

    I've got Messenger running on the laptop, with its own "recorded events.xml" file, less than 1mb. This file transfers without problems.

    The main PC's "recorded events.xml" is 37mb (I like to keep records!) and just won't sync properly.

    The Plus! extension (or Live Messenger itself) locks the file tight, so Mesh won't touch it even if I'm signed out. I have to exit Messenger in order for sync to happen.

    Once the file syncs, it immediately gets moved, not into the visible holding area but into the "recycle bin" holding area.

    Every 10 minutes since 1.30pm London time I've looked at the file conflicts (it gives me three versions of the file), selected one specific one (same one each time, the latest version) and said "keep". It goes away, then the same conflict comes back.

    That's why I think it's a bug; it's like some kind of loop. Other XML files work just fine, but this one has never been right since I had the big sync problems a few weeks back.

    tony

    Oh, PS (I've been dead busy so not had a chance to post) - your clean-up tool solved all my conflict problems; it was a real relief just to see this one!
    Monday, September 29, 2008 7:50 PM
  • Hi Tony,

    That definitely sounds like a bug.  If you wouldn't mind, could you open a bug report through Connect and attach your logs so that we can look into it?

    On the plus side, it's great to hear that the cleanup tool solved all your other conflicts.  Thanks for letting us know. :)

    Ben.
    Monday, September 29, 2008 8:10 PM
  • Cheers Ben.

    Can I ask for a bit of advice before sending my logs?

    I don't know where the problem is occurring, so I don't know which logs to send - should I just send the logs from both sync'd PCs?
    Monday, September 29, 2008 8:13 PM
  • Hi Tony,

    Good catch - Yes, I think it would be most useful if you could attach the logs from both computers that are syncing (or failing to sync, as the case may be) the file in question.  Just attach the .cab generated by Start Menu > All Programs > Live Mesh > Collect Live Mesh Logs from each computer.

    Also, if you're willing to post the Connect Feedback ID here after you file the bug, that will make it easier for me to track internally.

    Thanks,

    Ben.
    Monday, September 29, 2008 8:26 PM
  • Hi all,

    Please note that the issue reported by Tony above continued in this thread.  If you are hitting a similar problem, please see that thread for more details.

    Thanks,

    Ben.
    Wednesday, October 8, 2008 3:19 PM