locked
Live Mesh doesn't start RRS feed

  • General discussion

  • Hi,

    some time ago I entered a problem on the Connect-site about a problem I'm facing. See

    https://connect.microsoft.com/LiveMesh/feedback/ViewFeedback.aspx?FeedbackID=521931&wa=wsignin1.0#details


    Since that time I reinstalled Live Mesh a few times without getting it to work.

    I can add the following:
    - This is about my work laptop and Live Mesh was working fine for some time. I thought it had something to do with the security settings of the domain, because I never could get connect at work with Live Mesh (now I can't anywhere). In the beginning I could get Live Mesh only to work outside this domain.
    - I didn't see any error message about Live Mesh in the event logs.
    - I disabled the virus scanner (AV) and firewall (standard XP firewall).
    - I removed the browsing history (Tools > Delete Browsing History)

    When right clicking on the Live Mesh -icon in the status area there is no reaction when I click on Sign In, Options and Show Notifier.
    Software:
    - Live Mesh 0.9.4014.7
    - OS: WIN XP SP3 with IE8
    Hardware:
    Dell Latitude E6400 / 2Gb RAM / Intel P8600 @ 2,4 GHz
    - Domain: no proxy is used to access the internet

    Remarks:
    - I don't know over which port Live Mesh communicates, but could it be forced to always port 80? This port will normally always be usable.
    - more information available on request

    Regards,
    Johan

    Friday, March 12, 2010 12:07 AM

All replies

  • Hello, Johan.
    No response at all from the clicks on the notifier, even after a reinstall of the software seems troubling. Did you also remove the device from www.mesh.com before reinstalling on the device?
    Live Mesh logs in via https, which would be port 443.
    Sync for Live Mesh via P2P is explained here: http://support.microsoft.com/kb/951862

    -steve
    ~ Microsoft MVP Windows Live ~ Windows Live OneCare| Live Mesh|MS Security Essentials Forums Moderator ~
    Monday, March 15, 2010 7:07 PM
    Moderator
  • Hi Steve,
    I can't remember that when I first uninstalled Live Mesh it was still present in the interface at www.mesh.com. However, I tried it again and it wasn't present when I did my last uninstall. To summarize what I did today:
    - made sure that this laptop was away from mesh
    - uninstall Live Mesh, it was not present in the list of add/remove programs (this was the first time I've seen this) so I used "LiveMesh.exe /uninstall" (mentioned in some other posts). Message to reboot the computer (which I did off course).
    - install again (I downloaded the latest version from the site)
    -> Result is the same: the small pop-up "Failed to start Live Mesh. / Click here to restart."

    I used Live Mesh since late 2008 and was very happy with it.
    Recently I’ve been wondering if it’s caused by an incompatibility with another program installed. I have installed several development tools and DBMS’s on my work laptop. Does there exists a known incompatibilities list?
    I just discovered the following: I have a VirtualPC-image (OS: Win XP) on this laptop and installed Live Mesh here. No problem there.

    Differences between the main-OS and this VPC:
    - There is almost no software installed on this VPC
    - it's not part of the domain, but of a workgroup

    I also checked if some ports are in use like mentioned in the link of yesterday by executing netatat -a, but discoverd that no parts between 30000 and 40000 are in use.

    Johan

    • Edited by Johan__ Tuesday, March 16, 2010 3:47 PM domain and netstat information added
    Tuesday, March 16, 2010 11:25 AM
  • I'm not aware of any compatibility list, Johan.
    I do recall that there were issues some time back if one was trying to use Live Mesh on a machine that they were also testing the Live Framework environment on, but I seem to recall that this was resolved. And, that environment is no longer open to developers, so I doubt that this could be your issue.
    I didn't follow your link to the original bug report. Is that when you first encountered the issue? Can you pinpoint what else may have changed on the machine when you first ran into the problem on this machine?
    -steve
    ~ Microsoft MVP Windows Live ~ Windows Live OneCare| Live Mesh|MS Security Essentials Forums Moderator ~
    Tuesday, March 16, 2010 6:44 PM
    Moderator
  • Hi Steve,

    I found back that around the period the problems started the following happened:
    - Installed Microsoft Outlook Web Access S/MIME (2007)
    - Removed DB2 Workgroup Server Edition
    - Installed DB2 Workgroup Server Edition
    - Avg8 Update
    - Software distribution Service 3.0 (?)
    - installation of video driver Intel_GM45-GE45-GS45-Integra_A08_R250033 6.14.10.5157A09 (the video driver which was installed by the manufacturer caused blue screens!)

    I can say that there were quite some problems with this DB2-stuff (domain rights, different rights needed between different versions, ...), however I started to think  about this video driver. Beside the file synchronization possibilities, Live Mesh also has the option to access remote desktops. For this reason there is a driver "Live Mesh Remote Desktop" installed. I selected the properties of the Live Mesh Remote Desktop Curtain Driver and set to not use this device. Rebooted the PC, but still the same

    I also examined the startup of Live Mesh with Process Explorer. I noticed the following:
    1) MOEMonitor is lanched
    C:\Documents and Settings\---USER---\Local Settings\Application Data\Microsoft\Live Mesh\Bin\Servicing\0.9.4014.7\MoeMonitor.exe
    2) MOE is launched
    C:\Documents and Settings\---USER---\Local Settings\Application Data\Microsoft\Live Mesh\GacBase\Moe.exe
    3) MOE is closed after about 1 second

    On a system where Live Mesh is running normally both MOEMonitor as MOE are active processes.

    Johan

    • Edited by Johan__ Wednesday, March 17, 2010 12:31 PM processes startup
    Wednesday, March 17, 2010 12:14 PM
  • I wonder about the AVG update more than anything. If the Live Mesh service is stopping immediately after start, it would seem to me that something is stopping it. Perhaps it is being blocked by AVG?
    -steve
    ~ Microsoft MVP Windows Live ~ Windows Live OneCare| Live Mesh|MS Security Essentials Forums Moderator ~
    Thursday, March 18, 2010 12:14 PM
    Moderator
  • Hi Steve,

     

    It seems a logical explanation that it would be caused by security software. Before I changed the settings of the Windows Firewall, also without success. The other systems on which I used Live Mesh had other virus scanners installed.

     

    The sad thing about this AVG software (Network Edition, version 8.5.437, virus DB: 271.1.1/2754) is that it doesn't has a possibility to (temporary) disable all activities.

     

    After your idea I changed some exception rules (exclude Live Mesh directories and executables from being watched). No success. This virus scanner has 4 processes:

    avgwdsvc.exe (Watchdog - service)

    avgtray.exe (tray icon)

    avgcsrvx.exe

    avgrsx.exe

    The first 2 executables I can kill or disable, but the last two ones not.

     

    The only way to continue testing if this AVG is the cause of the problem is by uninstalling it, but this is against the company policy.

     

    Any other ideas?

    Have you encountered similar problems with AVG or other security softwares before?

     

    Johan

    Friday, March 19, 2010 9:05 AM
  • H, Johan.

    I've not experienced this and haven't used AVG in ages.

    Since you can't remove the AVG software, about all I can suggest is that you submit logs (again) attached to your original bug report or submit a new one. I don't think that you will get a response, though. :-(

    -steve


    ~ Microsoft MVP Windows Live ~ Windows Live OneCare| Live Mesh|MS Security Essentials Forums Moderator ~
    Friday, March 19, 2010 1:06 PM
    Moderator
  • Hi Steve,

    I can add another episode to this story: I uninstalled AVG, rebooted and installed Live Mesh again, hoping that it would be solved.

    Unfortanelty this was not the case. After installation Live Mesh still refused to start.

    I wanted to collect new Live Mesh logs, but when I did this no logs where returned to me. Thus I can't send them to you.

    Johan

    Monday, March 22, 2010 9:36 PM
  • Hi, Johan. I guess that AVG was not the cause, but it certainly seems like the install of Live Mesh this go around is non-functioning. It seems to me that perhaps a dependent service may be disabled. Have you manipulated your running services and disabled any, assuming them not to be needed?

    -steve


    ~ Microsoft MVP Windows Live ~ Windows Live OneCare| Live Mesh|MS Security Essentials Forums Moderator ~
    Tuesday, March 23, 2010 1:37 PM
    Moderator
  • Hi Steve,

    here is a dump of my currently services.

    Johan

     


    Status   Name               DisplayName                          
    ------   ----               -----------                          
    Running  Alerter            Alerter                              
    Running  ALG                Application Layer Gateway Service    
    Running  AppMgmt            Application Management               
    Stopped  aspnet_state       ASP.NET State Service                
    Running  AudioSrv           Windows Audio                        
    Running  avg8wd             AVG8 WatchDog                        
    Running  BITS               Background Intelligent Transfer Ser...
    Running  Browser            Computer Browser                     
    Running  BthServ            Bluetooth Support Service            
    Stopped  CiSvc              Indexing Service                     
    Stopped  ClipSrv            ClipBook                             
    Stopped  clr_optimizatio... .NET Runtime Optimization Service v...
    Running  COMSysApp          COM+ System Application              
    Running  Credential Vaul... Credential Vault Host Control Service
    Running  Credential Vaul... Credential Vault Host Storage        
    Running  CryptSvc           Cryptographic Services               
    Running  DcomLaunch         DCOM Server Process Launcher         
    Running  Dhcp               DHCP Client                          
    Stopped  dmadmin            Logical Disk Manager Administrative...
    Stopped  dmserver           Logical Disk Manager                 
    Running  Dnscache           DNS Client                           
    Stopped  Dot3svc            Wired AutoConfig                     
    Stopped  EapHost            Extensible Authentication Protocol ...
    Running  ERSvc              Error Reporting Service              
    Running  Eventlog           Event Log                            
    Running  EventSystem        COM+ Event System                    
    Stopped  FastUserSwitchi... Fast User Switching Compatibility    
    Stopped  FontCache3.0.0.0   Windows Presentation Foundation Fon...
    Running  helpsvc            Help and Support                     
    Running  HidServ            HID Input Service                    
    Stopped  hkmsvc             Health Key and Certificate Manageme...
    Stopped  HTTPFilter         HTTP SSL                             
    Stopped  idsvc              Windows CardSpace                    
    Running  IISADMIN           IIS Admin                            
    Stopped  ImapiService       IMAPI CD-Burning COM Service         
    Running  LanmanServer       Server                               
    Running  lanmanworkstation  Workstation                          
    Running  LmHosts            TCP/IP NetBIOS Helper                
    Running  LMS                Intel(R) Active Management Technolo...
    Running  MDM                Machine Debug Manager                
    Stopped  Messenger          Messenger                            
    Stopped  mnmsrvc            NetMeeting Remote Desktop Sharing    
    Stopped  MsDepSvc           Web Deployment Agent Service         
    Running  MSDTC              Distributed Transaction Coordinator  
    Running  MSFtpsvc           FTP Publishing                       
    Stopped  MSIServer          Windows Installer                    
    Running  MySQL              MySQL                                
    Stopped  napagent           Network Access Protection Agent      
    Stopped  NetDDE             Network DDE                          
    Stopped  NetDDEdsdm         Network DDE DSDM                     
    Running  Netlogon           Net Logon                            
    Running  Netman             Network Connections                  
    Stopped  NetTcpPortSharing  Net.Tcp Port Sharing Service         
    Running  Nla                Network Location Awareness (NLA)     
    Stopped  NtLmSsp            NT LM Security Support Provider      
    Stopped  NtmsSvc            Removable Storage                    
    Stopped  odserv             Microsoft Office Diagnostics Service 
    Stopped  OracleDBConsole... OracleDBConsoleEFT31HEAD             
    Stopped  OracleDBConsole... OracleDBConsoleG31HEAD               
    Stopped  OracleDBConsole... OracleDBConsoleL31HEAD               
    Stopped  OracleDBConsole... OracleDBConsoleTEMPCBK               
    Stopped  OracleJobSchedu... OracleJobSchedulerEFT31HEAD          
    Stopped  OracleJobSchedu... OracleJobSchedulerG31HEAD            
    Stopped  OracleJobSchedu... OracleJobSchedulerL31HEAD            
    Stopped  OracleJobSchedu... OracleJobSchedulerTEMPCBK            
    Running  OracleOraDb10g_... OracleOraDb10g_home1iSQL*Plus        
    Running  OracleOraDb10g_... OracleOraDb10g_home1TNSListener      
    Stopped  OracleServiceEF... OracleServiceEFT31HEAD               
    Stopped  OracleServiceG3... OracleServiceG31HEAD                 
    Stopped  OracleServiceL3... OracleServiceL31HEAD                 
    Stopped  OracleServiceTE... OracleServiceTEMPCBK                 
    Stopped  ose                Office Source Engine                 
    Running  PlugPlay           Plug and Play                        
    Running  PolicyAgent        IPSEC Services                       
    Running  ProtectedStorage   Protected Storage                    
    Stopped  RasAuto            Remote Access Auto Connection Manager
    Running  RasMan             Remote Access Connection Manager     
    Stopped  RDSessMgr          Remote Desktop Help Session Manager  
    Stopped  RemoteAccess       Routing and Remote Access            
    Running  RemoteRegistry     Remote Registry                      
    Stopped  RpcLocator         Remote Procedure Call (RPC) Locator  
    Running  RpcSs              Remote Procedure Call (RPC)          
    Stopped  RSVP               QoS RSVP                             
    Running  SamSs              Security Accounts Manager            
    Running  SCardSvr           Smart Card                           
    Running  Schedule           Task Scheduler                       
    Running  SeaPort            SeaPort                              
    Running  seclogon           Secondary Logon                      
    Running  SENS               System Event Notification            
    Running  SharedAccess       Windows Firewall/Internet Connectio...
    Running  ShellHWDetection   Shell Hardware Detection             
    Running  SMTPSVC            Simple Mail Transfer Protocol (SMTP) 
    Running  Spooler            Print Spooler                        
    Running  srservice          System Restore Service               
    Running  SSDPSRV            SSDP Discovery Service               
    Running  STacSV             Audio Service                        
    Running  stisvc             Windows Image Acquisition (WIA)      
    Stopped  SwPrv              MS Software Shadow Copy Provider     
    Stopped  SysmonLog          Performance Logs and Alerts          
    Running  TapiSrv            Telephony                            
    Running  TermService        Terminal Services                    
    Running  Themes             Themes                               
    Stopped  TlntSvr            Telnet                               
    Running  TrkWks             Distributed Link Tracking Client     
    Running  UNS                Intel(R) Active Management Technolo...
    Stopped  upnphost           Universal Plug and Play Device Host  
    Stopped  UPS                Uninterruptible Power Supply         
    Stopped  VSS                Volume Shadow Copy                   
    Running  W32Time            Windows Time                         
    Running  W3SVC              World Wide Web Publishing            
    Running  WebClient          WebClient                            
    Running  winmgmt            Windows Management Instrumentation   
    Stopped  WinRM              Windows Remote Management (WS-Manag...
    Running  wlcrasvc           Live Mesh Remote Desktop             
    Running  wlidsvc            Windows Live ID Sign-in Assistant    
    Stopped  WmdmPmSN           Portable Media Serial Number Service 
    Stopped  Wmi                Windows Management Instrumentation ...
    Stopped  WmiApSrv           WMI Performance Adapter              
    Stopped  WMPNetworkSvc      Windows Media Player Network Sharin...
    Stopped  wscsvc             Security Center                      
    Running  WSearch            Windows Search                       
    Running  wuauserv           Automatic Updates                    
    Stopped  WudfSvc            Windows Driver Foundation - User-mo...
    Running  WZCSVC             Wireless Zero Configuration          
    Stopped  xmlprov            Network Provisioning Service         

    Tuesday, March 23, 2010 2:32 PM
  • I don't have an XP machine with Live Mesh running handy to compare that to, so I'll ask - did you stop/disable any services yourself?

    -steve


    ~ Microsoft MVP Windows Live ~ Windows Live OneCare| Live Mesh|MS Security Essentials Forums Moderator ~
    Tuesday, March 23, 2010 5:09 PM
    Moderator
  • The only services I manipulate manually are the Oracle-services.
    I might try to enable/disable all services one by one and see the results.

     

    I had to think about your very first message and searched especially about services/programs using port 443, but it seems less likely because I can connect to websites over HTTPS.

    Wednesday, March 24, 2010 1:53 PM
  • I cna't imagine that the Oracle services would have any impact, but you never know.

    -steve


    ~ Microsoft MVP Windows Live ~ Windows Live OneCare| Live Mesh|MS Security Essentials Forums Moderator ~
    Wednesday, March 24, 2010 6:05 PM
    Moderator

  • Your network folks are probably blocking this due to P2P application signatures.

    Check and see!

    David

    Thursday, November 4, 2010 1:32 AM