locked
CRM 4.0 "From Address" when using SMTP Outgoing Email Router RRS feed

  • Question

  • Hi All

    I have CRM running, with Incoming and Outgoing Email.

    Outgoing is working, and configured as:

    SMTP
    Anonymous
    mail.company.com
    use SSL:  NO


    The problem we are seeing is, all Emails that CRM send out does not use the AD/Exchange "Full Name" field.  This is the case when sending Internal OR EXternal users.

    Obviously, we want the recipient to see the from address as "Employee Name" not "E.Name@company.com"

    How do we fix this?

    On the Exchange 2007 side, we have an Internal Receive Connector for our Internal Subnet that has NO Authentication methods selected, and ONLY "Anonymous Users" in the Permissions Tab.

    To fix this I suspect I need to create a new receive specifically for it:

    1.  If I was to create a new Receive Connector *just for this CRM Relay*, what Authentication and Permissions do I give it?  
    2.  Where/which group do I add the 'Local System Account' of the Server which is running the CRM Email Router?



    Thanks
    Friday, March 6, 2009 5:13 AM

Answers

  • Sometimes it happens that way Matty, especially when our MVPs are traveling all over the world for conferences (two of them this month). But I'm glad to see you got it resolved and really appreciate you letting us know.
    CRM Site Manager
    • Marked as answer by Jim Glass Jr Thursday, March 12, 2009 8:18 PM
    Thursday, March 12, 2009 8:18 PM

All replies

  • Wow, awesome, thanks for the help.

    Sarcasm aside, I fixed this and thought others might be interested.

    I had two options:
    1.   Give the Local System User of CRMSERVER "Exchange Server' rights in AD.  I wasn't sure how to do this, I tried adding CRMSERVER$ into "Exchange Servers" Group in AD, but it didn't work.
    2.   Create a new Receive Connector in Exchange 2007,  with TLS/IPSec Authentication, and "Anonymous Users, Exchange Servers".  Then I added only the CRMSERVER to the IP Allow list.


    Tuesday, March 10, 2009 6:25 AM
  • Sometimes it happens that way Matty, especially when our MVPs are traveling all over the world for conferences (two of them this month). But I'm glad to see you got it resolved and really appreciate you letting us know.
    CRM Site Manager
    • Marked as answer by Jim Glass Jr Thursday, March 12, 2009 8:18 PM
    Thursday, March 12, 2009 8:18 PM