locked
CRM Reporting Extensions Setup RRS feed

  • Question

  • Installation fails at the System checks screen upon connecting to the report server "A referral was returned from the server". I can connect to the report server website but the SSRS Extensions won't install.

    Thursday, March 22, 2012 12:58 PM

All replies

  • please check the account from which SSRS is running.

    if it is using network services then change it to domain admin account.

    Hope this solves your issue.


    Ahmed - CRM Application Management

    Thursday, March 22, 2012 7:23 PM
  • I'm logged in as the domain admin. No joy. The deal is that SSRS isn't running, it won't install. During install when it goes to connect to the database the error that shows up in the System Checks window is "A referral was returned from the server:. SQL resides on this server along with Exchange and I can log into both of them easily.
    • Edited by John Karpf Thursday, March 22, 2012 9:03 PM
    Thursday, March 22, 2012 9:01 PM
  • which sql server edition you have run this query in database select serverproperty('Edition') and tell me the edition..

    Ahmed - CRM Application Management

    Monday, March 26, 2012 7:20 PM
  • SQL Server 2008 Standard Edition 64-Bit
    Monday, March 26, 2012 8:16 PM
  • I got SSRS installed , the problem now is that I can't create an organization:

    CRM 2011 is on the Exchange 2007 box (Server 2008 64 bit) and SSRS is on the SQL 2008 and Report server box along with the Email Router (Server 2008 64 bit). Report services is configured and available via http and Rollup 7 is installed on both the CRM Server and the SSRS and Email Router server. The database is created in SQL during the install but deployment manager shows the organization as failed and trying to look at the orgainzation's properties blows up the MMC.

    The log contains the following errors:

    14:24:20|  Error| Installer Complete: OrganizationCreator - Error encountered
    14:24:20|  Error| Exception occured during Microsoft.Crm.Tools.Admin.OrganizationCreator: Action Microsoft.Crm.Tools.Admin.ProvisionBusinessAction failed.
    InnerException:
    System.Runtime.InteropServices.COMException (0x8007202B): A referral was returned from the server.

    And further down the log;

    14:24:20|   Info| Setting organization state.  New state = Failed
    14:24:20|  Error| Create new Organization (Name=16b7b081-de75-e111-8890-842b2b735cc4, Id=nccbuss) failed with Exception:
    System.Exception: Action Microsoft.Crm.Tools.Admin.ProvisionBusinessAction failed. ---> System.Runtime.InteropServices.COMException: A referral was returned from the server.

    I have tried installing CRM on another server, I have uninstalled and re-installed everything several times. Your help tracking this down would be greatly appreciated.


    • Edited by John Karpf Monday, March 26, 2012 8:34 PM
    Monday, March 26, 2012 8:33 PM
  • Have you used VM tamplate?

    Can you please check for DNS service errors (DC side)?

    Tuesday, March 27, 2012 12:36 PM
  • The error 'A referral was returned from the server' is ultimately from your DNS setup. Unfortunately there's no simple solution to this, but it typically involves cleaning up or reinstalling a DNS server. The following link gives soe more information, but unfortunately no simple solutions for a production environment - http://crm.davidyack.com/journal/2007/12/24/active-directory-and-dns-gotcha.html


    Microsoft CRM MVP - http://mscrmuk.blogspot.com  http://www.excitation.co.uk


    Tuesday, March 27, 2012 12:55 PM
    Moderator
  • ok then you have ssrs

    I think you are not added in previlage groups

    1.you should be deployment administrator.

    2.you should be domain administrator.

    and also added in

    • PrivUserGroup
    • SQLAccessGroup
    • ReportingGroup
    • PrivUserReportingGroup

    these groups  check with it .. then try creating organisation ... hope this will help you ...


    Ahmed - CRM Application Management

    Tuesday, March 27, 2012 3:30 PM