locked
Forwarding calls to Voicemail - Makes mediation say 488 Not Acceptable Here RRS feed

  • Question

  •  

    Hi

    I can make and receive calls fine to and from my Office Communicator 2007 client. And UM works fine from OC, but when calling from the outside and to my number my communicator start to say incoming call… so everything is fine so far, but If I click on forward call to voice mail it continues to ring on my OC and I get this in the mediation server log.

    TL_INFO(TF_PROTOCOL) [0]0710.073C::04/14/2007-19:26:26.765.00000202 (S4,SipMessage.DataLoggingHelper:703.idx(500))

    >>>>>>>>>>>>Outgoing SipMessage c=[<SipTcpConnection_7297EA>], 192.168.49.1:5060->192.168.49.2:1075

    SIP/2.0 488 Not Acceptable Here

    FROM: "Anonymous"<sip:Anonymous@192.168.49.2:5060>;tag=6320324631353641001BB9B0

    TO: <sip:0855514675@192.168.49.1:5060>;epid=0F6927E6BA;tag=3db7d13c1a

    CSEQ: 1 INVITE

    CALL-ID: 01B229D2568140000000009B@sipgw.infrasystems.local

    MAX-FORWARDS: 70

    VIA: SIP/2.0/TCP 192.168.49.2:5060;branch=z9hG4bKB6503822021285437144F5F174E13701

    CONTENT-LENGTH: 0

    SERVER: RTCC/3.0.0.0 MediationServer/3.0.6090.0

     

    ------------EndOfOutgoing SipMessage

    The log on the OCS server looks fine and I think it tries to forward the call.

     

    TL_INFO(TF_PROTOCOL) [0]0710.073C::04/14/2007-19:26:26.765.00000202 (S4,SipMessage.DataLoggingHelper:703.idx(500))

    >>>>>>>>>>>>Outgoing SipMessage c=[<SipTcpConnection_7297EA>], 192.168.49.1:5060->192.168.49.2:1075

    SIP/2.0 488 Not Acceptable Here

    FROM: "Anonymous"<sip:Anonymous@192.168.49.2:5060>;tag=6320324631353641001BB9B0

    TO: <sip:0855514675@192.168.49.1:5060>;epid=0F6927E6BA;tag=3db7d13c1a

    CSEQ: 1 INVITE

    CALL-ID: 01B229D2568140000000009B@sipgw.infrasystems.local

    MAX-FORWARDS: 70

    VIA: SIP/2.0/TCP 192.168.49.2:5060;branch=z9hG4bKB6503822021285437144F5F174E13701

    CONTENT-LENGTH: 0

    SERVER: RTCC/3.0.0.0 MediationServer/3.0.6090.0

     

    ------------EndOfOutgoing SipMessage

     

     

     

    Event logs does not say anything special.

    Well where else to look?

    I found a new error mess that i didnt see before..

     

    TL_INFO(TF_PROTOCOL) [0]0550.0388::04/16/2007-17:57:45.366.000003bc (S4,SipMessage.DataLoggingHelper:703.idx(500))

    >>>>>>>>>>>>Outgoing SipMessage c=[<SipTlsConnection_348AB41>], 192.168.100.71:1876->192.168.100.62:5061

    BYE sip:exchangeserver.infrasystems.local:5066;transport=Tls SIP/2.0

    FROM: <sip:Anonymous@telindus.se;user=phone>;epid=56F63B4C5F;tag=5662cd54fb

    TO: <sip:885;phone-context=sthlmexch.infrasystems.local@telindus.se;user=phone>;tag=bf44da3bf0

    CSEQ: 29 BYE

    CALL-ID: 05b4bb31-40a2-49f7-a3b9-d1d7eb55932e

    MAX-FORWARDS: 70

    VIA: SIP/2.0/TLS 192.168.100.71:1876;branch=z9hG4bKeb7e7c3

    ROUTE: <sipSurprisecsserver.infrasystems.local:5061;transport=tls;lr>

    CONTENT-LENGTH: 0

    USER-AGENT: RTCC/3.0.0.0 MediationServer/3.0.6090.0

    Ms-diagnostics: 10006;source="mediation.infrasystems.local";reason="LCS Proxy side Media negotiation failed";component="MediationServer";ValidationError=Invalid candidate attribute: invalid priority value

    ------------EndOfOutgoing SipMessage

    Saturday, April 14, 2007 7:39 PM

Answers

  • I got this from MS, so what i did was that i changed the Regional settings to US on all boxes and restared. But its still that 0,9

    So maybee a reinstall Sad i dunno?

     

     

     

    Hi,

     

    I think I found the issue.  It looks like regional settings are not set correctly.  Here is the issue:

     

    We get a candidate for the RTP stream:

    a=candidate:a4gy/7XhAxYpWvAxXRpMs7XB5Mim2plYK+J47V0yErE 1 U6rb57cbsITzK5VdB94HJA UDP 0,9 192.168.100.50 15488

     

    After we declare UDP, the 0,9 is in an incorrect format.  We are expecting 0.9 for the value.

     

    This is being passed back from the Exchange server to the OCS server back to the mediation server.  The Regional settings are probably set incorrectly on the Exchange Server.  Check and make sure these are set to English.

     

    Thanks,

    Matt

     

    Sunday, May 6, 2007 2:13 PM
  • All i needed to do was vipe the settings for UM on the exchange server and reinstall UM role and then do the config again and it works fine.
    Monday, July 2, 2007 11:02 PM

All replies

  • Hi Tommy Clarke,

    I am curious on the status of your issue. Have you been able to solve this? If so, can you share your solution? If not, please let me know ASAP.

    Thanks.

    Friday, May 4, 2007 10:33 PM
  • I got this from MS, so what i did was that i changed the Regional settings to US on all boxes and restared. But its still that 0,9

    So maybee a reinstall Sad i dunno?

     

     

     

    Hi,

     

    I think I found the issue.  It looks like regional settings are not set correctly.  Here is the issue:

     

    We get a candidate for the RTP stream:

    a=candidate:a4gy/7XhAxYpWvAxXRpMs7XB5Mim2plYK+J47V0yErE 1 U6rb57cbsITzK5VdB94HJA UDP 0,9 192.168.100.50 15488

     

    After we declare UDP, the 0,9 is in an incorrect format.  We are expecting 0.9 for the value.

     

    This is being passed back from the Exchange server to the OCS server back to the mediation server.  The Regional settings are probably set incorrectly on the Exchange Server.  Check and make sure these are set to English.

     

    Thanks,

    Matt

     

    Sunday, May 6, 2007 2:13 PM
  • Hi,

    When you say you got this from MS, do you mean you had a support case going with MS and they were working on this with you? Or did someone from MS contact you through this post?

    By the looks of their email it appears the OCS server has a problem with the European format of using a comma where the US standard uses a period. I am not sure how this can be overcome with the public beta version. I will check whether this is something that will be addressed with the RTM version and post here.

    Monday, May 7, 2007 5:23 PM
  • hi tom,

     

    just wanted to ask whether you were able to make progress regarding the 'candidate comma issue'.

    unfortunately we ran into the same problem (using english OS-versions with localized country settings) and i truly hope that reinstalling our lab-environment is not the only solution ...

     

    tnx in advance,

    daniel

     

    Friday, May 18, 2007 2:24 PM
  • No i did not.

     

    But im going to reinstall the exchange server to see if it helps, just havent got enough time to do it yet.
    So please let me know if you have any luck

    Tuesday, May 22, 2007 10:14 AM
  • All i needed to do was vipe the settings for UM on the exchange server and reinstall UM role and then do the config again and it works fine.
    Monday, July 2, 2007 11:02 PM
  • Hi, we´ve the same problem in our enviroment. So I already changed the regional settings to US on the Exchange 2007 server and reinstalled the UM component. But it still won´t work. Anything else to do? Can you tell me in which log you found th entry with the comma?

    Thanks.

     

    Best regards Stephan

    Friday, October 12, 2007 11:34 AM