none
Error Importing Claims Provider Trust RRS feed

  • Question

  • I am attempting to import a Claims Provider Trust using the Wizard and getting the following error:

    An unexpected error occurred during an attempt to process the federation metadata.  Verify that the federation metadata is correct and try again.  Error message: MSIS7505: The metadata does not contain the signing key needed for the entity to be configured as a claims provider trust.

    Below is a an edited copy of the metadata that i am attempting to import:

    <EntitiesDescriptor xmlns="urn:oasis:names:tc:SAML:2.0:metadata" ID="..........">
    <EntityDescriptor ID=".........." entityID="..........">
            <IDPSSODescriptor ID=".........." WantAuthnRequestsSigned="true" protocolSupportEnumeration="urn:oasis:names:tc:SAML:2.0:protocol">
                <KeyDescriptor use="signing">
                    <ns1:KeyInfo Id=".........." xmlns:ns1="http://www.w3.org/2000/09/xmldsig#">
                        <ns1:X509Data>
                            <ns1:X509IssuerSerial>
                                <ns1:X509IssuerName>..........</ns1:X509IssuerName>
                                <ns1:X509SerialNumber>..........</ns1:X509SerialNumber>
                            </ns1:X509IssuerSerial>
                            <ns1:X509Certificate>..........</ns1:X509Certificate>
                            <ns1:X509SubjectName>..........</ns1:X509SubjectName>
                        </ns1:X509Data>
                    </ns1:KeyInfo>
                </KeyDescriptor>
                <ArtifactResolutionService Binding="urn:oasis:names:tc:SAML:2.0:bindings:SOAP" Location="https://.........." index="0" isDefault="true"/>
                <SingleSignOnService Binding="urn:oasis:names:tc:SAML:2.0:bindings:HTTP-Redirect" Location="https://.........."/>
            </IDPSSODescriptor>
        </EntityDescriptor>
    </EntitiesDescriptor>

    

    Friday, June 16, 2017 4:16 AM

All replies

  • Hi Matthew Ingebrand,

    This forum discusses and asks questions about .NET Framework Base Classes, Since your issue is more related ADFS, I would suggest that you could post your issue on ADFS forum for suitable support

    https://social.technet.microsoft.com/Forums/windows/en-US/home?forum=ADFS

    Thanks for your understanding.

    Best regards,

    Cole Wu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, June 16, 2017 7:46 AM