locked
Error during windows update Code 80070426 RRS feed

  • Question

  • I am getting the following error message
    Windows could not search for new updates
    An error occured while checking for new updates for your computer
    Error found
    Code 80070426

    I ran the Windows Genuine advantage and did a copy. Given below is the output
    Please help me resolve the issue.

    Diagnostic Report (1.9.0011.0):
    -----------------------------------------
    WGA Data-->
    Validation Status: Genuine
    Validation Code: 0

    Cached Validation Code: N/A, hr = 0x80070426
    Windows Product Key: *****-*****-4GV68-6D8JB-G6MF9
    Windows Product Key Hash: Ua+OBZ1y48sKA/bWkfKXiuCrOjY=
    Windows Product ID: 89578-OEM-7332157-00203
    Windows Product ID Type: 2
    Windows License Type: OEM SLP
    Windows OS version: 6.0.6002.2.00010300.2.0.003
    ID: {CC99A0E0-F960-4011-A5CE-92ECD7343EB7}(3)
    Is Admin: Yes
    TestCab: 0x0
    WGA Version: N/A, hr = 0x80070002
    Signed By: N/A, hr = 0x80070002
    Product Name: Windows Vista (TM) Home Premium
    Architecture: 0x00000000
    Build lab: 6002.lh_sp2rtm.090410-1830
    TTS Error:
    Validation Diagnostic:
    Resolution Status: N/A

    WgaER Data-->
    ThreatID(s): N/A, hr = 0x80070002
    Version: 6.0.6002.16398

    WGA Notifications Data-->
    Cached Result: N/A, hr = 0x80070002
    File Exists: No
    Version: N/A, hr = 0x80070002
    WgaTray.exe Signed By: N/A, hr = 0x80070002
    WgaLogon.dll Signed By: N/A, hr = 0x80070002

    OGA Notifications Data-->
    Cached Result: N/A, hr = 0x80070002
    Version: N/A, hr = 0x80070002
    OGAExec.exe Signed By: N/A, hr = 0x80070002
    OGAAddin.dll Signed By: N/A, hr = 0x80070002

    OGA Data-->
    Office Status: 103 Blocked VLK
    Microsoft Office Enterprise 2007 - 103 Blocked VLK
    OGA Version: N/A, 0x80070002
    Signed By: N/A, hr = 0x80070002
    Office Diagnostics: B4D0AA8B-604-645_B4D0AA8B-604-645_025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3

    Browser Data-->
    Proxy settings: N/A
    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
    Default Browser: C:\Program Files\Mozilla Firefox\firefox.exe
    Download signed ActiveX controls: Prompt
    Download unsigned ActiveX controls: Disabled
    Run ActiveX controls and plug-ins: Allowed
    Initialize and script ActiveX controls not marked as safe: Disabled
    Allow scripting of Internet Explorer Webbrowser control: Disabled
    Active scripting: Allowed
    Script ActiveX controls marked as safe for scripting: Allowed

    File Scan Data-->

    Other data-->
    Office Details: <GenuineResults><MachineData><UGUID>{CC99A0E0-F960-4011-A5CE-92ECD7343EB7}</UGUID><Version>1.9.0011.0</Version><OS>6.0.6002.2.00010300.2.0.003</OS><Architecture>x32</Architecture><PKey>*****-*****-*****-*****-G6MF9</PKey><PID>89578-OEM-7332157-00203</PID><PIDType>2</PIDType><SID>S-1-5-21-3642777815-77602633-2373383627</SID><SYSTEM><Manufacturer>Sony Corporation</Manufacturer><Model>VGN-FZ21E</Model></SYSTEM><BIOS><Manufacturer>Phoenix Technologies LTD</Manufacturer><Version>R1120J7</Version><SMBIOSVersion major="2" minor="4"/><Date>20070704000000.000000+000</Date></BIOS><HWID>12323507018400FA</HWID><UserLCID>0809</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>W. Europe Standard Time(GMT+01:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>Sony</OEMID><OEMTableID>VAIO</OEMTableID></OEM><GANotification/></MachineData><Software><Office><Result>103</Result><Products><Product GUID="{90120000-0030-0000-0000-0000000FF1CE}"><LegitResult>103</LegitResult><Name>Microsoft Office Enterprise 2007</Name><Ver>12</Ver><Val>ACD7202654E586</Val><Hash>fFic3JgCreGGRxyF8uMWB4R4Jcg=</Hash><Pid>89388-707-1528066-65356</Pid><PidType>14</PidType></Product></Products><Applications><App Id="15" Version="12" Result="103"/><App Id="16" Version="12" Result="103"/><App Id="18" Version="12" Result="103"/><App Id="19" Version="12" Result="103"/><App Id="1A" Version="12" Result="103"/><App Id="1B" Version="12" Result="103"/><App Id="44" Version="12" Result="103"/><App Id="A1" Version="12" Result="103"/><App Id="BA" Version="12" Result="103"/></Applications></Office></Software></GenuineResults> 

    Spsys.log Content: 0x80070002

    Licensing Data-->
    N/A, hr = 0x80070002

    HWID Data-->
    HWID Hash Current: OAAAAAIAAwABAAEAAgABAAAAAwABAAEAJJTKVl4j62K87nCwRoOicJwH2y3y9CoTnGEkGKxWKoU=

    OEM Activation 1.0 Data-->
    N/A

    OEM Activation 2.0 Data-->
    BIOS valid for OA 2.0: yes
    Windows marker version: 0x20000
    OEMID and OEMTableID Consistent: yes
    BIOS Information:
      ACPI Table Name    OEMID Value    OEMTableID Value
      APIC            Sony        VAIO
      FACP            Sony        VAIO
      HPET            Sony        VAIO
      BOOT            Sony        VAIO
      MCFG            Sony        VAIO
      SLIC            Sony        VAIO
      TMOR            Sony        VAIO
      APIC            Sony        VAIO
      SSDT            Sony        VAIO
      SSDT            Sony        VAIO
      SSDT            Sony        VAIO
      SSDT            Sony        VAIO


    Sunday, November 8, 2009 5:49 PM

Answers

  • Hi Thomas,

      It would seem you had multiple issues. The reason I say this is because the error "System error 2 has occurred." only occures when a specific registry entry is malformed.  The only time I have seen this error was when a user used a free Registry Cleaner and the Registry Cleaner deleted the Reg Entry that tell Vista where the slsvc.exe file is located, but when the cleaner trys to restore the registry entry back again, it doesn't do it right and the Reg Entry becomes Malformed.
     

    To fix the issue, Go to the main Vista Validation forum page http://social.microsoft.com/Forums/en-US/genuinevista/threads/, look in the announcement section and follow the steps found in thread "Fix for ‘Software Licensing service Has Stopped’ on some Vista 64bit systems.

    I hope that helps,
    Darin MS
    • Marked as answer by Darin Smith MS Wednesday, November 18, 2009 9:22 PM
    Wednesday, November 18, 2009 9:22 PM

All replies

  • Hello THOMAS.FABIAN,

    I believe Vista's Licensing store may be corrupt.  Give the below steps a try  

    1) Open an Internet Explorer browser window.
    2) Type: %windir%\system32 into the browser address bar.
    3) Find the file CMD.exe
    4) Right-Click on CMD.exe and select 'Run as Administrator'
    5) Type: net stop slsvc  (it may ask you if you are sure, select yes)
    6) Type: cd %windir%\ServiceProfiles\NetworkService\AppData\Roaming\Microsoft\SoftwareLicensing
    7) Type: rename tokens.dat tokens.bar
    8) Type: cd %windir%\system32
    9) Type: net start slsvc
    10) Type: cscript slmgr.vbs -rilc (It may take a long time for this to complete, please be patient)
    11) Restart your computer twice.
    12) You may be required to enter your Product Key and/or Activate.

    Thank you,
    Darin MS
    • Marked as answer by Darin Smith MS Monday, November 9, 2009 10:40 PM
    Monday, November 9, 2009 10:40 PM
  • Hi,

    I did the steps as you had mentioned, but I stopped at step 9. It gave an error message that the file cannot be found. It did not seem like an expected message.
    I have attached below the log for your reference.

    ================================================================================================
    Microsoft Windows [Version 6.0.6002]
    Copyright (c) 2006 Microsoft Corporation.  All rights reserved.

    C:\Windows\system32>net stop slsvc
    The slsvc service is not started.

    More help is available by typing NET HELPMSG 3521.


    C:\Windows\system32>cd %windir%\ServiceProfiles\NetworkService\AppData\Roaming\Microsoft\SoftwareLicensing

    C:\Windows\ServiceProfiles\NetworkService\AppData\Roaming\Microsoft\SoftwareLicensing>rename tokens.dat tokens.bar

    C:\Windows\ServiceProfiles\NetworkService\AppData\Roaming\Microsoft\SoftwareLicensing>cd %windir%\system32

    C:\Windows\System32>net start slsvc
    System error 2 has occurred.

    The system cannot find the file specified.


    C:\Windows\System32>

    =====================================================================================

    Thanks for your help
    Regards
    Thomas Fabian
    Monday, November 9, 2009 11:09 PM
  • Hi,

    I am getting the following error message
    Windows could not search for new updates
    An error occured while checking for new updates for your computer
    Error found
    Code 80070426

    I ran the Windows Genuine advantage and did a copy. The output has been copied below
    Please help me resolve the issue.

    Additionally I did the following steps, but it gave an error message that the file cannot be found. It did not seem like an expected message.

    1) Open an Internet Explorer browser window.
    2) Type: %windir%\system32 into the browser address bar.
    3) Find the file CMD.exe
    4) Right-Click on CMD.exe and select 'Run as Administrator'
    5) Type: net stop slsvc   (it may ask you if you are sure, select yes)
    6) Type: cd %windir%\ServiceProfiles\NetworkService\AppData\Roaming\Microsoft\SoftwareLicensing
    7) Type: rename tokens.dat tokens.bar
    8) Type: cd %windir%\system32
    9) Type: net start slsvc
    10) Type: cscript slmgr.vbs -rilc (It may take a long time for this to complete, please be patient)
    11) Restart your computer twice.
    12) You may be required to enter your Product Key and/or Activate.


    I have attached below the log for your reference.

    ================================================================================================
    Microsoft Windows [Version 6.0.6002]
    Copyright (c) 2006 Microsoft Corporation.  All rights reserved.

    C:\Windows\system32>net stop slsvc
    The slsvc service is not started.

    More help is available by typing NET HELPMSG 3521.


    C:\Windows\system32>cd %windir%\ServiceProfiles\NetworkService\AppData\Roaming\Microsoft\SoftwareLicensing

    C:\Windows\ServiceProfiles\NetworkService\AppData\Roaming\Microsoft\SoftwareLicensing>rename tokens.dat tokens.bar

    C:\Windows\ServiceProfiles\NetworkService\AppData\Roaming\Microsoft\SoftwareLicensing>cd %windir%\system32

    C:\Windows\System32>net start slsvc
    System error 2 has occurred.

    The system cannot find the file specified.


    C:\Windows\System32>

    =====================================================================================

    Output of Windows Genuine advantage is given below

    Diagnostic Report (1.9.0011.0):
    -----------------------------------------
    WGA Data-->
    Validation Status: Genuine
    Validation Code: 0

    Cached Validation Code: N/A, hr = 0x80070426
    Windows Product Key: *****-*****-4GV68-6D8JB-G6MF9
    Windows Product Key Hash: Ua+OBZ1y48sKA/bWkfKXiuCrOjY=
    Windows Product ID: 89578-OEM-7332157-00203
    Windows Product ID Type: 2
    Windows License Type: OEM SLP
    Windows OS version: 6.0.6002.2.00010300.2.0.003
    ID: {CC99A0E0-F960-4011-A5CE-92ECD7343EB7}(3)
    Is Admin: Yes
    TestCab: 0x0
    WGA Version: N/A, hr = 0x80070002
    Signed By: N/A, hr = 0x80070002
    Product Name: Windows Vista (TM) Home Premium
    Architecture: 0x00000000
    Build lab: 6002.lh_sp2rtm.090410-1830
    TTS Error:
    Validation Diagnostic:
    Resolution Status: N/A

    WgaER Data-->
    ThreatID(s): N/A, hr = 0x80070002
    Version: 6.0.6002.16398

    WGA Notifications Data-->
    Cached Result: N/A, hr = 0x80070002
    File Exists: No
    Version: N/A, hr = 0x80070002
    WgaTray.exe Signed By: N/A, hr = 0x80070002
    WgaLogon.dll Signed By: N/A, hr = 0x80070002

    OGA Notifications Data-->
    Cached Result: N/A, hr = 0x80070002
    Version: N/A, hr = 0x80070002
    OGAExec.exe Signed By: N/A, hr = 0x80070002
    OGAAddin.dll Signed By: N/A, hr = 0x80070002

    OGA Data-->
    Office Status: 103 Blocked VLK
    Microsoft Office Enterprise 2007 - 103 Blocked VLK
    OGA Version: N/A, 0x80070002
    Signed By: N/A, hr = 0x80070002
    Office Diagnostics: B4D0AA8B-604-645_B4D0AA8B-604-645_025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3

    Browser Data-->
    Proxy settings: N/A
    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
    Default Browser: C:\Program Files\Mozilla Firefox\firefox.exe
    Download signed ActiveX controls: Prompt
    Download unsigned ActiveX controls: Disabled
    Run ActiveX controls and plug-ins: Allowed
    Initialize and script ActiveX controls not marked as safe: Disabled
    Allow scripting of Internet Explorer Webbrowser control: Disabled
    Active scripting: Allowed
    Script ActiveX controls marked as safe for scripting: Allowed

    File Scan Data-->

    Other data-->
    Office Details: <GenuineResults><MachineData><UGUID>{CC99A0E0-F960-4011-A5CE-92ECD7343EB7}</UGUID><Version>1.9.0011.0</Version><OS>6.0.6002.2.00010300.2.0.003</OS><Architecture>x32</Architecture><PKey>*****-*****-*****-*****-G6MF9</PKey><PID>89578-OEM-7332157-00203</PID><PIDType>2</PIDType><SID>S-1-5-21-3642777815-77602633-2373383627</SID><SYSTEM><Manufacturer>Sony Corporation</Manufacturer><Model>VGN-FZ21E</Model></SYSTEM><BIOS><Manufacturer>Phoenix Technologies LTD</Manufacturer><Version>R1120J7</Version><SMBIOSVersion major="2" minor="4"/><Date>20070704000000.000000+000</Date></BIOS><HWID>12323507018400FA</HWID><UserLCID>0809</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>W. Europe Standard Time(GMT+01:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>Sony</OEMID><OEMTableID>VAIO</OEMTableID></OEM><GANotification/></MachineData><Software><Office><Result>103</Result><Products><Product GUID="{90120000-0030-0000-0000-0000000FF1CE}"><LegitResult>103</LegitResult><Name>Microsoft Office Enterprise 2007</Name><Ver>12</Ver><Val>ACD7202654E586</Val><Hash>fFic3JgCreGGRxyF8uMWB4R4Jcg=</Hash><Pid>89388-707-1528066-65356</Pid><PidType>14</PidType></Product></Products><Applications><App Id="15" Version="12" Result="103"/><App Id="16" Version="12" Result="103"/><App Id="18" Version="12" Result="103"/><App Id="19" Version="12" Result="103"/><App Id="1A" Version="12" Result="103"/><App Id="1B" Version="12" Result="103"/><App Id="44" Version="12" Result="103"/><App Id="A1" Version="12" Result="103"/><App Id="BA" Version="12" Result="103"/></Applications></Office></Software></GenuineResults> 

    Spsys.log Content: 0x80070002

    Licensing Data-->
    N/A, hr = 0x80070002

    HWID Data-->
    HWID Hash Current: OAAAAAIAAwABAAEAAgABAAAAAwABAAEAJJTKVl4j62K87nCwRoOicJwH2y3y9CoTnGEkGKxWKoU=

    OEM Activation 1.0 Data-->
    N/A

    OEM Activation 2.0 Data-->
    BIOS valid for OA 2.0: yes
    Windows marker version: 0x20000
    OEMID and OEMTableID Consistent: yes
    BIOS Information:
      ACPI Table Name    OEMID Value    OEMTableID Value
      APIC            Sony        VAIO
      FACP            Sony        VAIO
      HPET            Sony        VAIO
      BOOT            Sony        VAIO
      MCFG            Sony        VAIO
      SLIC            Sony        VAIO
      TMOR            Sony        VAIO
      APIC            Sony        VAIO
      SSDT            Sony        VAIO
      SSDT            Sony        VAIO
      SSDT            Sony        VAIO
      SSDT            Sony        VAIO


    Thanks for your help
    Regards
    Thomas Fabian
    • Merged by Darin Smith MS Wednesday, November 18, 2009 10:23 PM same issue
    Sunday, November 15, 2009 12:18 AM
  • Hi Thomas,

      It would seem you had multiple issues. The reason I say this is because the error "System error 2 has occurred." only occures when a specific registry entry is malformed.  The only time I have seen this error was when a user used a free Registry Cleaner and the Registry Cleaner deleted the Reg Entry that tell Vista where the slsvc.exe file is located, but when the cleaner trys to restore the registry entry back again, it doesn't do it right and the Reg Entry becomes Malformed.
     

    To fix the issue, Go to the main Vista Validation forum page http://social.microsoft.com/Forums/en-US/genuinevista/threads/, look in the announcement section and follow the steps found in thread "Fix for ‘Software Licensing service Has Stopped’ on some Vista 64bit systems.

    I hope that helps,
    Darin MS
    • Marked as answer by Darin Smith MS Wednesday, November 18, 2009 9:22 PM
    Wednesday, November 18, 2009 9:22 PM