locked
CRM 2011 Cannot run any reports RRS feed

  • Question

  • Hi

    Once again I've run into a reporting issue, with one of my customers.

    All users seem to be able to run reports perfectly from their client, but with my user from the CRM server it gives me this error:

    Process: w3wp |Organization:00000000-0000-0000-0000-000000000000 |Thread:   48 |Category: Platform |User: 00000000-0000-0000-0000-000000000000 |Level: Error |ReqId: 4054a6ee-f8c2-441f-8853-62eef4e319ad | ExceptionConverter.ConvertMessageAndErrorCode  ilOffset = 0x23B
    >System.InvalidOperationException: Microsoft Dynamics CRM has experienced an error. Reference number for administrators or support: #23A289F7: System.InvalidOperationException: CRM Parameter Filter - Invalid parameter 'recordOptions=on' in Request.QueryString on page /APPension/_grid/cmds/dlg_runreport.aspx
    >The raw request was 'GET /APPension/_grid/cmds/dlg_runreport.aspx?recordOptions=on' called from http://apdyncrm01/APPension/_grid/cmds/dlg_runreport.aspx?enableview=1&id=%7b8ef33806-2227-e111-bc71-78e7d1df263e%7d&numselected=0.
    >   at Microsoft.Crm.Application.ParameterFilter.ValidateParameter(HttpRequest request, ArrayList parameterCollection, String key, String value, ParameterSources source, EntityType pageEntityType, FormAdditionalAllowedParameters additionalAllowedParameters)
    >   at Microsoft.Crm.Application.ParameterFilter.ValidateParameters(Page page, EntityType pageEntityType, Boolean alwaysEnableParameterChecking, FormAdditionalAllowedParameters formAdditionalAllowedParametersTemp)
    >   at Microsoft.Crm.Application.ParameterFilter.ValidateParameters(Page page, EntityType pageEntityType, Boolean alwaysEnableParameterChecking)
    >   at Microsoft.Crm.Application.Controls.AppPage.ValidatePageParameters()
    >   at Microsoft.Crm.Application.Controls.AppPage.OnInit(EventArgs e)
    >   at System.Web.UI.Control.InitRecursive(Control namingContainer)
    >   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    and this error page (An error has occurred...) right away when I choose which data the report should run on.

    I have no clue what "recordOptions = on" is, and can't find anything on Google, related to this CRM Parameter.

    This issue is happening when I run custom AND standard reports (All reports in CRM)

    I really need help here, because I dont know what to do now.

    Thursday, January 30, 2014 12:35 PM

Answers

  • I would check to see if this is a permission issue in disguise.  Temporarily give the user the sys admin role and see if he/she can run the report.  If that works, then start looking for differences he/she has with other users such as security role privileges and business unit assignment.

    Another thing to check would be to see if this is specific to the user or isolated to the workstation is to have this user log into CRM through IE on a machine from someone without the problem and see if the report runs.


    Jason Peterson

    • Marked as answer by Casper Schau1 Tuesday, March 25, 2014 8:22 AM
    Thursday, January 30, 2014 12:46 PM

All replies

  • I would check to see if this is a permission issue in disguise.  Temporarily give the user the sys admin role and see if he/she can run the report.  If that works, then start looking for differences he/she has with other users such as security role privileges and business unit assignment.

    Another thing to check would be to see if this is specific to the user or isolated to the workstation is to have this user log into CRM through IE on a machine from someone without the problem and see if the report runs.


    Jason Peterson

    • Marked as answer by Casper Schau1 Tuesday, March 25, 2014 8:22 AM
    Thursday, January 30, 2014 12:46 PM
  • Is that Sys/Admin role on the SQL Server?
    Friday, January 31, 2014 8:32 AM