locked
Dependent Option Set JavaScript code not working RRS feed

  • Question

  • I had a Dependent Option set all correctly set up in CRM and it was working fine.  It was between 2 fields and I had it set up just as it is in your example above.  A few months ago I upgraded our CRM 2011 On-Premise system to CRM 2015 On-Premise - it was quite a hassle (total understatement!!!!) but eventually most problems have been worked out.  The Dependent Option Set code still worked fine.

    We have now added several entities, multiple forms and numerous business rules.  Once the business rules were added to our test system (CRM 2015, just as our Production site), the Dependent Option Set code no longer works.  I have examined all of files (.xml, .js) and all appear to be "correct."  During my research into why my js code might not be working, I found my references to the fact that if a field’s value is set by a Business Rule, it’s onChange event will not fire – meaning that if there is any code in that event, it will not work.  So, I examined all of the Business Rules associated with that field and, upon finding any, I converted it to js code.  After doing this, my Dependent Option Set code still does not work.

    My next move is to see if I can programmatically fire onChange my Dependent Option Set code…although I am not quite sure where to locate that code within the form.

    So, any ideas, suggestions, advice on either the cause of the problem and/or a possible resolution would be greatly appreciated. 

    Thanks, Michelle

    Thursday, February 4, 2016 2:06 PM