locked
Unable to send email through email router RRS feed

  • Question

  • Hi guys and girls

    Hoping someone got an idea how to solve this.

    We have set up an OnPremise 2016 with an email router that connects to Office 365 Exchange.

    We are using user based authentication for Exchange, so each user, types in their password on their email setup page in CRM.

    We have tested the connection and the test email goes through to the exchange and the user recieves their test email.

    But.. when we try to manually create an email in CRM, the email just stays in status "Sending".. and it retrieves 500 times.. then fails..

    Why is that?

    Anyone got an idea how to solve this or what could be wrong?


    Rune Daub Senior Consultant - Dynateam CRM http://www.dynateam.dk

    Friday, October 28, 2016 8:03 AM

All replies

  • Hello,

    I would suggest to check email router log for explanation.

    Side question - why don't you use Server Side Sync?


    Dynamics CRM MVP
    Read My blog
    Subscribe for one of my courses

    Friday, October 28, 2016 8:17 AM
    Moderator
  • I had problems setting it up.. and then I read there was problems with combining CRM Onpremise with Exchange Online.. and that it wasent fixed yet..

    Our problem is that the CRM is not IFD'ed. Its only on available on the inside of the firewall.

    I followed the guide on https://technet.microsoft.com/en-us/library/mt703269.aspx but


    Rune Daub Senior Consultant - Dynateam CRM http://www.dynateam.dk


    • Edited by RuneDaub Friday, October 28, 2016 8:23 AM
    Friday, October 28, 2016 8:20 AM
  • ok.. so the strangest thing just happend..

    I can get the email router to work just fine.. if I set both incoming and outgoing to use email router..

    but if I change the incoming to Outlook and the outgoing to Email router.. then it stops working for outgoing as well...

    The only thing I change is the setting on the user in crm.


    Rune Daub Senior Consultant - Dynateam CRM http://www.dynateam.dk

    Friday, October 28, 2016 9:16 AM