locked
Problem doing a MOC to MOC voice call with federated partners ONLY RRS feed

  • Question

  • I everyone,

    I have OCS R2 : Standard Edition and Consolidated Edge R2 Topology.

    EVERYTHING works execpt when I try a MOC to MOC to our federated partners (Microsoft is one example)

    I get this error on my R2 client:
    "Call was disconnected"  : (The call was disconnected because you stopped receiving audio from USERNAME. Please try the call again.)

    Chat works, Web conf works,  and I am able to MOC call external domain users.

    Only the Fderated partners that does not work....

    Thanks for any help

    JP
    Thursday, June 18, 2009 1:27 PM

Answers

All replies

  • Language Settings on the Edge Server ?

    Take a look at this:

    http://unified-communications.blogspot.com/2009/01/ocs-2007-r2-and-localization.html


    or this

    http://blogs.technet.com/ucspotting/archive/2009/05/25/3245364.aspx

    A hotfix is described in the article.

    /T 
    Thursday, June 18, 2009 2:12 PM
  • All of our servers are already setup with English (US) regional settings.

    Any other ideas.

    PS: we are not using any NAT on our Edge.

    Here is a snip of a OCS  Logger:

    SIP/2.0 415 Unsupported Media Type
    TL_INFO(TF_PROTOCOL) [1]093C.0BDC::06/18/2009-15:14:59.116.000f602f (SIPStack,SIPAdminLog::TraceProtocolRecord:SIPAdminLog.cpp(122))$$begin_record
    Instance-Id: 000003FF
    Direction: outgoing;source="external edge";destination="internal edge"
    Peer: mtl-ww-im01.domain.prod:57507
    Message-Type: response
    Start-Line: SIP/2.0 415 Unsupported Media Type
    From: "Jean-Philippe Breton"<sip:Jean-Philippe.Breton@domin.com>;tag=0387d5e2cb;epid=6be15bed3c
    To: <sip:jonathan.lefebvre@alphamosaik.com>;tag=CA41BCCDAC8E39E60B0513F1FAA0DB42
    CSeq: 1 INVITE
    Call-ID: 64f6114d98374d6ca2d06e53b18bd78a
    ms-edge-proxy-message-trust: ms-source-type=AutoFederation;ms-ep-fqdn=mtl-ww-edgeim01.domain.prod;ms-source-verified-user=verified;ms-source-network=federation
    Via: SIP/2.0/TLS 10.14.36.36:57507;branch=z9hG4bK42EA2879.D36B979CA02A7382;branched=FALSE;ms-received-port=57507;ms-received-cid=100
    Via: SIP/2.0/TLS 165.115.88.88:50291;ms-received-port=50291;ms-received-cid=26600
    Accept: application/sdp
    Content-Length: 0
    ms-diagnostics: 1011;reason="Ms-Diagnostics header not provided by previous hop";source="sip.domain.com";Domain="alphamosaik.com";PeerServer="sip.alphamosaik.com"
    Message-Body: –
    $$end_record


    UPDATE: 
    MOC to MOC voice call works when users are External:  External user calls a federated MOC.
     But when internal users tries to voice call an Federated MOC...it does not work??


    Regards

    JP
    Thursday, June 18, 2009 3:20 PM
  • Found the solution.

    Resolved
    • Marked as answer by JP BretonMVP Monday, June 29, 2009 4:33 PM
    Monday, June 29, 2009 4:33 PM
  • Hi JP,
    What was the solution finally ?
    did you modify some settings on your edge server ?
    Thanks.
    Monday, August 31, 2009 2:57 PM
  • There was a port : 3478 UDP that was not open on the firewall.

    Hope this help

    Regards

    Jean-Philippe
    • Proposed as answer by JaBr UK Wednesday, September 9, 2009 11:42 PM
    Monday, August 31, 2009 3:22 PM