DirectX on 64bit RRS feed

  • Question

  • I'm making an app that requires DirectX in a control inside a form. I originally did this in C# and it worked because I'm running XP 32bit. My friend is running 64bit Vista, so Managed DirectX became a problem, and I ported the control to C++ so that only DirectX stuff had to be in C++ and the rest could still be C#. The problem is that now, when my friend tries to load the program it crashes and Windows closes it.

    My DirectXSpace class inherits the UserControl class so that it can be put on a form easily. The only thing strange I had to do was return LPDIRECT3DDEVICE9 from GetDevice() as void* because of this bug .

    Also, I have tried compiling the app using the x64 SDK lib directory, but this just gives me "unresolved external symbol "extern "C" struct IDirect3D9 * __stdcall Direct3DCreate9(unsigned int)""

    Compiling with the x86 lib and running it on my 32bit machine works as expected.
    • Edited by TyPR124 Sunday, July 5, 2009 11:50 PM Link was messed up
    • Moved by nobugz Sunday, July 5, 2009 11:57 PM not a .net q, post to forums.xna.com (From:64-Bit .NET Framework Development.)
    Sunday, July 5, 2009 11:49 PM