locked
Access or Opening a document RRS feed

  • Question

  • This morning a colleague came up to me wanting to know why he could not access a file that is on Mesh.  It appears to have been synced and should work.  I went back to my own system to check to make sure we could access that same document via the web, which we could.  I then tried to open random docs, some could and some coud not open.  Then tried a document that could not be opened on my system but could be opened on my co-workers and it worked successfully.  Any suggestion of how to fix this or what is wrong? 
    Tuesday, August 4, 2009 2:21 PM

Answers

  • Right click the files in the Mesh folder and look at properties and permissions. Live Mesh does not preserve the permissions at the folder level, but preserves/sets them at the file level. So, if you or your co-worker save the file locally and it synchronizes, it may be saving the file with permissions for only the user who saved the file last.
    -steve
    Microsoft MVP Windows Live / Windows Live OneCare, Live Mesh, & MS Security Essentials Forums Moderator
    Tuesday, August 4, 2009 2:29 PM
    Moderator

All replies

  • Right click the files in the Mesh folder and look at properties and permissions. Live Mesh does not preserve the permissions at the folder level, but preserves/sets them at the file level. So, if you or your co-worker save the file locally and it synchronizes, it may be saving the file with permissions for only the user who saved the file last.
    -steve
    Microsoft MVP Windows Live / Windows Live OneCare, Live Mesh, & MS Security Essentials Forums Moderator
    Tuesday, August 4, 2009 2:29 PM
    Moderator
  • You are right.  When I right click on the document I can't open, there is no properties option at all.  I assume I have to have the person who created the document change teh settings?  Why are there permissions at all and how do I insure that we get rid of them?  As far as I know, we have never used permissions.

    Tuesday, August 4, 2009 2:40 PM
  • Have the person who created the document change the permissions on the file to be everyone/full access and see if you can open it then after a sync.
    This has been reported as an issue by others, by the way, so I hope it is addressed in a future update. If a Live Mesh folder is shared, all of the contents are shared out to your invited people, but then new files don't get that property, which is a pain. This is not an issue if you grant read only access to a folder on your Mesh and the other party grants you read only access on a folder shared to your Mesh, but that means that you can't collaborate on files. THe workaround would be for both of you to remember to set the permissions on new (possibly also changed) files added to the Mesh folder you share.
    -steve
    Microsoft MVP Windows Live / Windows Live OneCare, Live Mesh, & MS Security Essentials Forums Moderator
    Tuesday, August 4, 2009 3:06 PM
    Moderator
  • Does the length of the file name have anything to do with any of this?  At the moment the person who's system created the documents is not here, but I tried downloading a file from Mesh.com, was able to open it.  Then wanted to delete the old file and put the one I can open in its place.  When I tried to do this, it told me that the file name was too long. 

    Also, I don't see options to change permssions anywhere.  I tried going to Help, but that didn't solve my problem. 
    Tuesday, August 4, 2009 3:19 PM
  • The length should not have anything to do with it.
    I should have asked - what operating system are you using? And the other person?

    Have a look here for XP http://support.microsoft.com/default.aspx/kb/308419
    Vista: http://www.vista4beginners.com/Change-permissions-take-ownership

    -steve


    Microsoft MVP Windows Live / Windows Live OneCare, Live Mesh, & MS Security Essentials Forums Moderator
    Wednesday, August 5, 2009 12:26 AM
    Moderator
  • At the moment there are three of us using mesh.  One person has Vista and is using Word 2002, another is using XP and Office 2007 and I'm using XP and Office 2003.  I'll take a look at those links.

    Thanks for you help!

    Randy
    Wednesday, August 5, 2009 1:58 PM
  • I went through the instructions on Vista to give permissions.  I guess I'm confused with how the other person's computer (the Vista system) knows who I am to give the rest of us permission.  I made sure that "Users" and "Administrators" have access, but it doesn't seem to work. 

    Wednesday, August 5, 2009 2:26 PM
  • If you are setting the permissions for the files on your XP machine, you need to see the XP link, near the bottom, to be able to see the Security tab:
    Important: If you are not joined to a domain and you want to view the Security tab:
    1. Click Start, and then click Control Panel.
    2. Click Appearance and Themes, and then click Folder Options.
    3. Click the View tab, and then click to clear the Use simple file sharing [Recommended] check box in the Advanced settings box.

    Then, you will take ownership, and set the permissions for *Everyone* to have full access to the files.
    Alternatively, you can do this from the other user's Vista machine and set the permissions for Everyone. You may need to do this every time someone changes a file and it syncs, since the file may then become "owned" by the user that saved the file.

    I know, it's miserable, and I hope that they fix this as it makes sharing folders between meshes rather difficult for collaboration.
    -steve


    Microsoft MVP Windows Live / Windows Live OneCare, Live Mesh, & MS Security Essentials Forums Moderator
    Wednesday, August 5, 2009 2:49 PM
    Moderator
  • Hi Stephen,

    Well I have partially solved the problem after speaking with a support person at Dell.  Basically by trial and error we were able to determine that the long file names were making it unable to open some files.  There are other files that are on two of the systems, but not on the online version of Mesh and not on the Vista Version.  Most of these problems seemed to appear when we added the vista machine to the mix.  Any hints/suggestions of how/where I can find a solution and how I can regain access to the files with the long file names?  It won't let me access them on either of the machines that can see them.

    Randy
    Wednesday, August 5, 2009 6:49 PM
  • Replied to your email to inquire about the file names.
    -steve
    Microsoft MVP Windows Live / Windows Live OneCare, Live Mesh, & MS Security Essentials Forums Moderator
    Thursday, August 6, 2009 12:28 AM
    Moderator