locked
WHS hangs after boot RRS feed

  • Question

  • Dear all

    after a long period of smooth work, I found my server hanging.

    I tried to troubleshoot without success.

    Basically the system starts (it even allows me to log in as administrator and after 10 seconds or more it hangs.

    If I try in safe mode (including network connection) it works fine. The system seeme to hangs after a predifined period of time (30 seconds).

    I tried to select the option of the last konwn good configuration , but no sucess. I also tried to stop all startup scripot via msconfig. No change

    It works in fine mode  but not in a normal configuration.

    The only information I found (but my experience is limited) was some time ago , a bad sector on a Hard drive, but the checkdisk did not show any problem.

    I would like to avoid to reinstall the operating system. As antivirus I use AVAST

    Thanks for any suggestion. 

     

    Saturday, September 11, 2010 9:18 AM

All replies

  • Hi,
    I could imagine, that the attempt to load the backup service causes the machine to hang, if the backup database is corrupted (maybe due to the faulty sector you experienced a while ago?).
    You can test this by setting the startup type of the Windows Home Server backup service to manual. If the server comes up now without freezing, you may attempt to start the service manual.

    Does it hang again? If this is the case, you might have to try deleting the backup database and start backups from the scratch.

    Best greetings from Germany
    Olaf

    Saturday, September 11, 2010 5:54 PM
    Moderator
  • Hi Olaf

    thanks for the suggestions. I follwed your recommendation and I find it very useful. Indeed it was not the backup service, but stopping all services and restarinting them one by one, I found that the following one does not start

    The Windows Home Server Setup Service service failed to start due to the following error:

    The service did not respond to the start or control request in a timely fashion.

    WHS setuop service does not start.Event Type: Error
    Event Source: Service Control Manager
    Event Category: None
    Event ID: 7000
    Date:  12/09/2010
    Time:  12:14:24
    User:  N/A
    Computer: MANTINEO
    Description:
    The Windows Home Server Setup Service service failed to start due to the following error:
    The service did not respond to the start or control request in a timely fashion.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    \Another culprit seemed to be the ntivirus , but at the end it worked OK.

    I am not sure about this servic role

    Regards

    Sunday, September 12, 2010 10:34 AM
  • Hm, a little bit strange.

    On my German Home Server which I run here I cannot see a service, which would translate to Windows Home Server Setup service. Is it a self built system or an OEM machine? In the services console, what is the path to exe file shown for this service?

    Best greetings from Germany
    Olaf

     

    Sunday, September 12, 2010 5:42 PM
    Moderator
  • Hi

    it is pointing toward  \install\qs.exe

     

    strange enough, now I can see the shared directories and use teh remote desktop, but I can not use the remote console.

     

    Maybe the only solution is to reinstall the operating system.

     

    Regards

     

     

    Sunday, September 12, 2010 6:52 PM
  • Maybe, your installation process never completed, causing the misbehavior.

    So a server reinstall may be really the best way to fix it.

    Good luck
    Olaf

    Sunday, September 12, 2010 10:07 PM
    Moderator
  • Hi

    the system had worked fine for 20 months so the installation left open does not really convince me.

     

    In any case I did the re installation ( it was a very long process with huge number of reboot for any update).

     

    Teh only thing not yet clear is the fact that I have two HD 1 TB and 2 TB mounted in spanning mode (WHS function not a RAID).

    At WHS everything is OK however when I open the My Computer in a console of the server I see only one of the 2 hdds and the space available is computed only for the phisical unit. (in the WHS console the overall space available is correct)

    The unit is shown (in storage management) but no drive letter is assigned (correctly) and it is linked to a spanning directory of the system logical unit (C:)

    Before I was seeing a single logical unit and all the space available

     

    Regards

     

     

     

    Thursday, September 16, 2010 10:29 AM
  • So did you apply all the upgrades to WHS (Power Packs and other patches)? Which version number is shown in the console?
    The calculation of total space in Explorer for drive D: came only after a certain update.

    Can you access your data files in Shared Folders and the backups properly?

    Best greetings from Germany
    Olaf

    Thursday, September 16, 2010 1:48 PM
    Moderator