none
Synctoy 2.1 (x64) does not behave as expected in echo mode when files are deleted from the right

    Question

  • This question has been asked several times before but the answer is not satisfactory.

    Steps to reproduce the issue:

    1. Create folders c:\left and c:\right
    2. create dummy files inside c:\left
    3. create a folder pair to echo left to right.
    4. run the folder pair and confirm dummy files appear in c:\right
    5. delete dummy files from c:\right
    6. run the folder pair.  No files are copied.  This is not the expected behavior.  The expected behavior is that synctoy should copy the files from left to right.

    This issue is mentioned in the FAQ, but the explanation does not make sense to me:

    Q. SyncToy 2.0 appears not to sync deleted files when I have the sync option set to 'Echo'

    A. This can happen if the files are updated on the right. This includes if the file was touched by an anti-virus program, music player, etc. To confirm that this is indeed the case - change the sync option to "Synchronize" and do a "Preview" sync. Do NOT hit run because this will sync changes from the right to the left. If on a preview you see updates from the right to the left folder, this means it was changed on the right. The only workaround in this case would be to manually delete the file on the right. And do not forget to change your sync option back to "Echo".

    Thanks,

    -Cameron

    Saturday, March 08, 2014 4:15 PM

All replies