locked
File and Print Sharing Fails after 2.0 Upgrade RRS feed

  • Question

  • Since the two Vista machines on my (wireless) LAN were automatically upgraded to OneCare 2.0, two strange things are occurring:

     

    1.  The Vista Network page on both machines can see both machines, but they cannot open a network machine (or any share on the machine).  This is true for file shares or printer shares.  They time out saying "not reachable or access denied".  Used to work perfectly.

     

    2.  On one machine a phantom entry has appeared in the Vista Network page.  This phantom machine has the same name as the host it appears on, but with "-OC" appended.  This phantom machine can be opened up and accessed exactly as the host machine it mirrors.  It appears that this phantom is being seen via the network rather than ourely locally, because when the Vista network page is rfreshed it appears after a delay, the same as with othe machines on the network.  I haven't found a way to get rid of this phantom entry.

     

    Maybe these two are related?  Any clues about what might have changed?

     

    Trevor

    Thursday, December 13, 2007 9:19 AM

Answers

  • The OC entry is placed there by OneCare for Vista to allow OneCare to enable the new printer sharing feature of OneCare. However, it will not share if your network is identified as Public and not Private.

    Open OneCare 2.0.

    Click on Change Settings

    On the Firewall Tab, click on Configure Firewall.

    Assuming that it is showing "Public Place", click on Change Location to make it Private.

    -steve

     

    Thursday, December 13, 2007 4:05 PM
    Moderator

All replies

  • The OC entry is placed there by OneCare for Vista to allow OneCare to enable the new printer sharing feature of OneCare. However, it will not share if your network is identified as Public and not Private.

    Open OneCare 2.0.

    Click on Change Settings

    On the Firewall Tab, click on Configure Firewall.

    Assuming that it is showing "Public Place", click on Change Location to make it Private.

    -steve

     

    Thursday, December 13, 2007 4:05 PM
    Moderator
  • On both machines, Vista Networking regards the network as "Private", and Onecare Firewall regards the network as "Work or Home". The two machines are not domain joined but in a common workgroup, and part of the same OneCare circle.  User accounts with the same passwords on both machines.  Guest is enabled (yuk!).  Only when OneCare firewall is turned off am I getting any sharing at all.

     

    Trevor

     

    Friday, December 14, 2007 2:37 AM
  • Thanks for confirming the network settings.

    Open OneCare, click on Change Settings, Firewall tab, advanced, Ports and protocols.

    Is File and Printer Sharing - for local network (subnet) checked?

    If not, place a check in there.

    If it is checked, try also placing a check mark on the next entry, File and Printer Sharing - for subnet and Internet.

    -steve

     

    Friday, December 14, 2007 2:58 AM
    Moderator
  • File and Print Sharing (Local) is already turned on on both machines.  I have also added File and Print Sharing for Subnet and Internet.  No change.

     

    One thing I should have mentioned is that from each machine you can see ther shares available on the other, but you cannot open the shares - it times out and then gives an error message indicating the share is not available and suggesting lack of permission as a possible reason.  That shouldn't be the case. (It WAS working before the upgrade)

     

    Trevor

     

    Sunday, December 16, 2007 5:18 AM
  • Since it appears that you have everything set correctly and it did work before the upgrade to 2.0, please contact support for further help with this - 

    How to reach support (FAQ) - http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=2421771&SiteID=2

     

    -steve

    Monday, December 17, 2007 6:28 PM
    Moderator
  • OK.  Thanks for your efforts.

     

    Trevor

     

    Monday, December 17, 2007 10:19 PM
  • You're welcome, Trevor. Please let us know how this turns out.

    -steve

     

    Tuesday, December 18, 2007 2:27 AM
    Moderator
  • On the computer that you are trying to connect remote shares, please do the following

    • Open administrative command prompt
      • Type in cmd.exe after clicking on start button
      • select command windows, right click and click run as administrator
    • type in "net session"

    This will tell you what credentials it is using to connect to other computers. My guess is that somehow your computer is establishing connection with the other computer using guest account which does not have permission for shares.

     

    Wednesday, December 19, 2007 12:01 AM
  • Assuming your guess is correct, Neeraj, what then?

    -steve

     

    Wednesday, December 19, 2007 1:11 AM
    Moderator
  • In that case, we will have to find out which program is creating that connectins using which account. Solutions are either

    a) Give permission to the account being used on all file/printer shares on the other machine

    b) OR change the account used by this application to correct one/disable the application

     

    Thanks

    Neeraj

    Sunday, December 23, 2007 4:19 PM