locked
File sharing issues between Windows XP and Windows 7 RRS feed

  • Question

  • I am used to being able to access any file on the C: drive of a networked Windows computer from any other computer on the same

    network and domain/workgroup by using the default hidden share C$ (entering \\<computername>\c$ in Windows Explorer), without

    having to jump through any extra security hoops, as long as I know the user name and password of an account with

    administrative privileges on the PC to which I'm connecting, but I've recently encountered a situation where this does not

    work as expected.

     

    In this situation, there are three computers. One (A) is running Windows XP Media Center Edition 2002 with Service Pack 3,

    another (B) is running Windows XP Tablet PC Edition 2005 with Service Pack 2, and the other (C) is running Windows 7 Ultimate

    x64 with Service Pack 1. Each of them can access its own share (I mention this only to demonstrate that I've verified that the

    expected hidden share is actually set up on each of them). Each of them can also ping the others, and I can connect to

    printers and other resources that have been explicitly shared on each of them from the others.

     

    B and C can access the hidden share on A without trouble. When I attempt to connect to C from either A or B, I am prompted for

    credentials (which I expect), but when I enter the user name and password of an administrator account on C, the prompt simply

    re-appears and no access is granted. It does this over and over, regardless of how many times I enter the credentials. On B,

    the "Remember my password" checkbox is available but has no effect; on A, this checkbox is simply not there.

     

    Further, when I attempt to connect to B from A, the credentials prompt has the User name prefilled as Guest (which, as usual,

    is disabled) and the box is grayed out so that no other user can be entered. When I attempt to connect to B from C, I am

    prompted for credentials, but again, the prompt simply re-appears (with the error "Access is denied." listed in this case)

    each time I click OK.

     

    I guess I'm not that surprised that there are some obstacles in accessing C, since Windows 7 is more locked-down than XP (I

    have done this successfully in other situations, however). The weirdest part to me is why B is proving so difficult. Is there

    something about Tablet PC Edition that modifies the default behavior I'm used to? I've tried many tweaks and done many Google

    searches, but since Google ignores punctuation, it's difficult to search for "C$" with any reliability. I've tried turning off

    password protected sharing on the Win7 machine (C), but that had no effect. At this point, I'm stumped. Please let me know if

    you have any suggestions.

    Saturday, April 23, 2011 4:58 AM

All replies

  • Well, I've figured out the issue connecting to the Tablet PC Edition machine (B). Simple File Sharing was the culprit. This was boneheaded of me -- it should have occurred to me to check that before now. As is so often the case, it took posting a question to spur the thought, but at least it's working. The issue with the XP computers connecting to the C$ share on the Windows 7 machine remains, though, so if anyone can give me some tips there, it would be much appreciated!

    Saturday, April 23, 2011 5:14 AM
  • This are the steps that I took in order to successfully map hidden shares between Windows XP Pro and Windows 7 Pro:

    On the Windows 7 PC:

    Run> secpol.msc

    Browsed to "Local Policies" -> "Security Options" changed entry for "Network Security: LAN Manager authentication level" to "Send LM & NTLM - use NTLMv2 session security if negotiated"

    In the Advanced sharing settings page of Network and sharing center:

    -Enable network discovery
    -Turn on  file and print sharing
    -Turn off password protected sharing
    -Use user accounts and passwords to connect to other computers
    -Encryption disabled.

    Run > “gpedit.msc”
    In “Computer Configuration”/Windows Settings/Security Settings/Local Policies/Security Settings:

    Network access: Allow anonymous SID/name translation
    Network access: Let Everyone permissions apply to anonymous users
    Network access: Restrict anonymous access to Named Pipes and Shares
    Network access: Do not allow anonymous enumeration of SAM accounts
    Network access: Do not allow anonymous enumeration of SAM accounts and shares

    Modify the registery:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System.
    Create a new DWORD (32-bit) value with the name:  LocalAccountTokenFilterPolicy
    Assign it a value of 1

    Disable the Homegroup setting:

    Control Panel > Network and Internet > HomeGroup > Click on blue link to Leave the HomeGroup.


    Most importantly, ensure the user is a member of the Administrators group.

    Saturday, August 6, 2011 11:38 PM