none
ICE window too big to fit screen - Surface Pro

    Question

  • Hello and thanks for a new version of this great software.

    I installed it on my Surface Pro 3 and it works great except the interface window extends beyond the edge of my screen on the right and bottom. For instance, the close window icon [X] is not visible on the top right (but acressible with the mouse)

    In windowed mode there is no way to resize it either. I tried making a shortcut on my desktop and selected the compability option "Deactivate scaling for high rez monitors" but that didn't make a difference either.

    It's a bit annoying, can you help me fix this problem?

    HW: Surface Pro 3 i5 running at native resolution

    SW: ICE 2.0 64-bit version.

    Edit:

    I've confirmed the problem to be a scaling issue. In the Control Panel I have an option to "Make elements bigger or smaller" --> and cross off "Choose one scaling for all my displays" and everything on my screen goes really tiny. Then ICE fits.

    Also, my scaling is larger than default which causes the problem. However, the ICE window could be able to detect such settings and fit to screen on any scaling settings, isnt it?
    • Edited by Sigurd R Thursday, February 5, 2015 8:27 PM
    Thursday, February 5, 2015 7:38 PM

Answers

All replies

  • Am having the same problem. Running on a 15.6" laptop with 1366x768 resolution. ICE occupies almost the entire vertical space and cannot be resized smaller. I am using the default DPI scaling settings.
    • Edited by Chrysler Friday, February 6, 2015 9:30 PM
    Friday, February 6, 2015 9:26 PM
  • Sigmund has a point, since the Surface Pro 3 screen is 2160 x 1440.

    Chrysler, on the other hand... wow. 1996 called and wants their laptop screen back.
    On a screen that tiny, why in the world would you not always have ICE maximized?

    There is no effect without a cause.

    Saturday, February 7, 2015 12:50 PM
  • Chrysler, on the other hand... wow. 1996 called and wants their laptop screen back.
    On a screen that tiny, why in the world would you not always have ICE maximized?
    Huh, is that resolution so outdated already? The laptop is 3.5 years old. I haven't had any issues with that screen size and resolution with any other program yet. But the new ICE version seems to be designed for higher DPI only. http://i.imgur.com/yVDpY0b.png
    Saturday, February 7, 2015 2:49 PM
  • The problem is that ICE2's minimum screen size is too big (really!!) and that it does not respond to the "Disable display scaling" compatibility setting from the launcher shortcut. Chryslers problem isn't that he won't run it maximised, he CAN'T.


    • Edited by Sigurd R Saturday, February 7, 2015 2:56 PM
    Saturday, February 7, 2015 2:55 PM
  • Chryslers problem isn't that he won't run it maximised, he CAN'T.

    No, maximizing works and I probably will always have it maximized, but only because I have to (because of the large controls). I would like the controls to be smaller, like the old ICE so I wouldn't have to maximize it. Hope that makes it clear. :)
    Saturday, February 7, 2015 3:03 PM
  • Oh ok :)
    Saturday, February 7, 2015 3:06 PM
  • We've fixed this problem in the latest update (ICE version 2.0.3). Please download from the ICE home page (http://research.microsoft.com/en-us/um/redmond/projects/ice/), or accept the automatic update the next time you run ICE.

    Eric Stollnitz, Computational Photography Group, Microsoft Research

    Thursday, February 26, 2015 11:04 PM
    Moderator
  • Eric,

    I have a similar problem on my Win7-64 desktop system.

    I want to run ICE on a smaller part of my screen and I cannot downsize it. (e.g. by using the Size option from the application menu)

    Updating to v 2.0.3.0 does not help.

    Regards, Gilbert

    Monday, September 14, 2015 2:25 PM